Bug 6667 - BUG IN DYNAMIC LINKER ld.so
BUG IN DYNAMIC LINKER ld.so
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: glibc (Show other bugs)
6.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
:
: 7424 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-11-02 18:04 EST by ennio.zarlenga
Modified: 2008-05-01 11:37 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-05-22 10:52:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description ennio.zarlenga 1999-11-02 18:04:52 EST
Just after the installation of the RedHat 6.0, I wanted to
install pbm2ppa.

------------------------------------------------------------
[root@ariane pbm2ppa-0.8.6]# make 720
cp defaults.720.h defaults.h
gcc -Wall -02 -c pbm2ppa.c
BUG IN DYNAMIC LINKER ld.so: dynamic-link.h: 57:
elf_get_dynamic_info: Assertion `!"bad dynamic tag"' failed!
make: *** [pbm2ppa.o] Error 127
------------------------------------------------------------

What does it mean ?
I encountered the same problem when I wanted to compile a
new kernel (2.2-13), typing: "make xconfig".
Comment 1 Bill Nottingham 1999-11-03 12:10:59 EST
*** Bug 6685 has been marked as a duplicate of this bug. ***

system is Pentium, video card is S3 86C765
Frequency: 100% reproducible
Install linux 6.1
run X windows using "startX"
the following error occurs
BUG IN DYNAMIC LINKER ld:so: dynamic_link.h:57
elf_get_dynamic_info: Assertion '! "bad dynamic tag"' failed

Tried different configurations using 'xf86config', problem
still occurred.

Also Tried a second pentium machine with video card S3
ViRGE.  The problem still showed.

This is a serious bug which I think may relate to other
ld.so bugs.  This will prevent users from running X and X
application.
Comment 2 krap 1999-11-07 12:05:59 EST
I got same problem whenever I try to use gcc or egcs... (but not with
X)
Comment 3 r_dess 1999-11-20 15:23:59 EST
[root@localhost linux]# uname -a
Linux localhost.localdomain 2.2.5-15 #1 Mon Apr 19 22:21:09 EDT 1999 i586 unknown
[root@localhost linux]# make xconfig
rm -f include/asm
( cd include ; ln -sf asm-i386 asm)
make -C scripts kconfig.tk
make[1]: Entering directory `/usr/src/linux-2.2.5/scripts'
gcc -Wall -Wstrict-prototypes -O2 -fomit-frame-pointer -c -o tkparse.o tkparse.c
BUG IN DYNAMIC LINKER ld.so: dynamic-link.h: 57: elf_get_dynamic_info: Assertion `! "bad dynamic tag"' failed!
make[1]: *** [tkparse.o] Error 127
make[1]: Leaving directory `/usr/src/linux-2.2.5/scripts'
make: *** [xconfig] Error 2
[root@localhost linux]#
Comment 4 tomot21 1999-12-05 08:38:59 EST
After install of the RedHat 6.0 , when i type :
gcc or egcs i have this sentence :

BUG IN DYNAMIC LINKER ld.so: dynamic-link.h: 57: elf_get_dynamic_info: Assertion `! "bad dynamic tag"' failed!

But the command c++ work and i've no problem with X
Comment 5 Bill Nottingham 1999-12-06 11:58:59 EST
What happens if you re-run ldconfig?

------- Email Received From  Christophe CHAILLOLEAU <krap@free.fr> 12/08/99 10:37 -------
Comment 6 tomot21 1999-12-08 14:48:59 EST
Nothing ,
the program seems to work , but gcc don't.
tryed to test some function od ldconfig , no success
Comment 7 tomot21 1999-12-08 14:52:59 EST
Nothing ,
the program seems to work , but gcc don't.
tryed to test some function od ldconfig , no success


------- Email From  "Nguyen, Trieu" <trieu.nguyen@intel.com> 12/08/99 16:17 -------
Attached to Bug # 6667.
Comment 8 Bill Nottingham 2000-02-05 14:58:59 EST
*** Bug 7424 has been marked as a duplicate of this bug. ***
Comment 9 Cristian Gafton 2000-05-22 10:52:59 EDT
assign to jakub
Comment 10 Brent Fox 2002-06-05 00:48:11 EDT
Closing due to old age.  Please reopen if you see the behavior with the current
release.

Note You need to log in before you can comment on or make changes to this bug.