Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 667143 - Reposync crashes after file not found
Reposync crashes after file not found
Status: CLOSED ERRATA
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Server (Show other bugs)
540
Unspecified Unspecified
low Severity medium
: ---
: ---
Assigned To: Michael Mráka
Dimitar Yordanov
:
: 727840 (view as bug list)
Depends On:
Blocks: sat54-blockers
  Show dependency treegraph
 
Reported: 2011-01-04 10:58 EST by Šimon Lukašík
Modified: 2011-12-09 05:21 EST (History)
5 users (show)

See Also:
Fixed In Version: spacewalk-backend-1.2.13-57
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-11-21 04:44:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
snip of the rhn_taskomatic_daemon.log (3.04 KB, text/plain)
2011-01-04 11:00 EST, Šimon Lukašík
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:1466 normal SHIPPED_LIVE Red Hat Network Satellite server spacewalk-backend bug fix update 2011-11-21 09:43:48 EST

  None (edit)
Description Šimon Lukašík 2011-01-04 10:58:54 EST
Description of problem:
If the package described in repodata is deleted from repository 
during the repo-sync, process of reposync will fail.

Version-Release number of selected component (if applicable):
spacewalk-backend-tools-1.2.13-20.el5sat

How reproducible:
1 of 1

Steps to Reproduce:
1. Start a sync of a repository
2. Delete the package from the rerpository
3.
  
Actual results:
Reposync crashes with no such file exception

Expected results:
Reposync should skip the package and sync the rest of the
repo. Or at least notify the system administrator


Additional info:
Comment 1 Šimon Lukašík 2011-01-04 11:00:27 EST
Created attachment 471688 [details]
snip of the rhn_taskomatic_daemon.log
Comment 2 Šimon Lukašík 2011-01-04 11:02:04 EST
QA can use global [beaker-tasks] repository, which is pretty much unstable.
Comment 3 Michael Mráka 2011-03-03 10:26:49 EST
It's been fixed some time ago by commits
d09d119267834048004b2aecc98ec1adba91edf4
16dbafff04c457cef2e0327cb8ee0adbfe816df8

Package spacewalk-backend-1.4.16-1 works as expected.
Comment 4 Michael Mráka 2011-03-03 10:28:28 EST
(In reply to comment #3)
> It's been fixed some time ago by commits
> d09d119267834048004b2aecc98ec1adba91edf4
> 16dbafff04c457cef2e0327cb8ee0adbfe816df8
> 
> Package spacewalk-backend-1.4.16-1 works as expected.

This is a fix in upstream not in satellite.
Comment 5 Šimon Lukašík 2011-08-03 08:47:41 EDT
*** Bug 727840 has been marked as a duplicate of this bug. ***
Comment 6 Michael Mráka 2011-10-26 04:59:19 EDT
Backported to SATELLITE-5.4 as
commit 1cf37a27b2afa909852fd88a361a44aeb69e6e00
    moved checksum logic into ContentPackage
    yum repo metadata have precomputed checksum we can use to compare the
    package on disk; unfortunately it's a different from the one we want to
    store so we have to compute the second one on our own
commit 97ec057ce6487efc98f3b9557b738a2d7dcb777f
    spacewalk-repo-sync should not download package which is already on disk
Comment 8 Michael Mráka 2011-10-27 03:46:07 EDT
One more backported commit
commit 09df8004b27a1658d366fda96cf5ed339e42fa0b
    shortened and narrowed package sync logic
    process packages in one loop
    (cherry picked from commit ab07eddd4caf3de6a04c7e35ae9217eda101bffa)
Comment 11 Šimon Lukašík 2011-11-11 10:02:20 EST
Given the bug 753158 comment 0, which says it's 100% reproducible -->
isn't this bug supposed to be FailedQA?
Comment 12 errata-xmlrpc 2011-11-21 04:44:49 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1466.html

Note You need to log in before you can comment on or make changes to this bug.