Bug 66725 - gdm hangs because missing /etc/HOSTNAME file
gdm hangs because missing /etc/HOSTNAME file
Product: Red Hat Linux
Classification: Retired
Component: initscripts (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
Depends On:
  Show dependency treegraph
Reported: 2002-06-14 09:25 EDT by Peter Englmaier
Modified: 2014-03-16 22:28 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2005-09-29 16:00:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Peter Englmaier 2002-06-14 09:25:14 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020513

Description of problem:
When ethernet is installed after installing redhat (that is not during
the install process), gdm was only working when ethernet was up and

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
Here is what I did and how I fixed it. 
I installed rh7.3 from scratch on a Dell Inspiron 3800. Later, I configured
When rebooting without ethernet cable attached or ethernet device
disabled - gdm hangs. I noticed a forked subprocess of xdm hanging on something
having to do with my hostname (found this out with strace -p gdm-pid). When
doing 'hostname localhost'
as root, the hanging gdm suddenly worked. Having realized that, I found out that
I needed to write my hostname to /etc/HOSTNAME in order to get gdm work without
ethernet as well. This file used to be
created by initscripts, AFAIK. Can be, that this bug is really a problem in
'neat' or somewhere else.

Additional info:
Comment 1 Pam Huntley 2002-07-08 13:42:05 EDT

We had this problem, except gdm was reverting back to text mode, even though
inittab had runlevel 5.  I was able to fix it also by adding the guys host name,
with ip address, into the /etc/hosts file.  I figured it was because
he was using dhcp, but had manually specified a hostname. 

I also commented on bug #63956, it seemed to be related.
Comment 2 Bill Nottingham 2005-09-29 16:00:54 EDT
Closing bugs on older, no longer supported, releases. Apologies for any lack of

If this persists on a current release, such as Fedora Core 4, please open a new bug.

Note You need to log in before you can comment on or make changes to this bug.