Bug 667376 - Missing Builder in eclipse (CDT and Texlipse)
Missing Builder in eclipse (CDT and Texlipse)
Status: CLOSED DUPLICATE of bug 684894
Product: Fedora
Classification: Fedora
Component: eclipse (Show other bugs)
14
Unspecified Unspecified
low Severity medium
: ---
: ---
Assigned To: Chitlesh GOORAH
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-01-05 08:27 EST by Pierre Blavy
Modified: 2011-04-27 08:07 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-04-27 08:07:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
The complete yum update summary that breaks texlipse (27.06 KB, application/octet-stream)
2011-01-05 08:27 EST, Pierre Blavy
no flags Details

  None (edit)
Description Pierre Blavy 2011-01-05 08:27:41 EST
Created attachment 471860 [details]
The complete yum update summary that breaks texlipse

Description of problem:
The texlipse plugins fails to open latex files (system editor is used instead) and to compile latex.

Version-Release number of selected component (if applicable):
Broken on last yum update (works perviously)
eclipse-jdt x86_64 1:3.6.1-6.1.fc14  updates  23 M
eclipse-nls noarch 3.6.0.v20100814043401-2.fc14 updates  6.0 k
eclipse-nls-fr noarch 3.6.0.v20100814043401-2.fc14 updates  2.0 M
eclipse-platform  x86_64 1:3.6.1-6.1.fc14  updates  30 M
eclipse-rcp  x86_64 1:3.6.1-6.1.fc14  updates  7.8 M
eclipse-swt  x86_64 1:3.6.1-6.1.fc14  updates  2.3 M

Here are my actual eclipse* packages versions
 eclipse-birt noarch 2.5.2-1.fc14 @fedora 3.7 M
 eclipse-cdt x86_64 1:7.0.1-2.fc14 @updates 38 M
 eclipse-cdt-parsers x86_64 1:7.0.1-2.fc14 @updates 3.4 M
 eclipse-cdt-sdk x86_64 1:7.0.1-2.fc14 @updates 12 M
 eclipse-dtp noarch 1.8.1-1.fc14 @updates 13 M
 eclipse-emf noarch 2.6.0-2.fc14 @fedora 5.3 M
 eclipse-gef noarch 3.6.1-1.fc14 @updates 1.7 M
 eclipse-jdt x86_64 1:3.6.1-6.1.fc14 @updates 25 M
 eclipse-linuxprofilingframework x86_64 0.6.1-1.fc14 @updates 69 k
 eclipse-mylyn noarch 3.4.0-4.fc14 @fedora 5.6 M
 eclipse-mylyn-cdt noarch 3.4.0-4.fc14 @fedora 98 k
 eclipse-nls noarch 3.6.0.v20100814043401-2.fc14 @updates 0.0 
 eclipse-nls-fr noarch 3.6.0.v20100814043401-2.fc14 @updates 5.5 M
 eclipse-platform x86_64 1:3.6.1-6.1.fc14 @updates 34 M
 eclipse-ptp noarch 4.0.3-3.fc14 @fedora 24 M
 eclipse-ptp-etfw-ppw noarch 4.0.3-3.fc14 @fedora 65 k
 eclipse-rcp x86_64 1:3.6.1-6.1.fc14 @updates 11 M
 eclipse-rse noarch 3.2-1.fc14 @fedora 13 M
 eclipse-swt x86_64 1:3.6.1-6.1.fc14 @updates 3.4 M
 eclipse-texlipse noarch 1.3.0-2.20090829cvs.fc12 @fedora 2.3 M
 eclipse-valgrind x86_64 0.6.1-1.fc14 @updates 1.2 M


How reproducible:
Always

Steps to Reproduce:
1. Open a texlipse project in eclipse
2. Go in project properties/Builder
3. If you see ``Missing Builder (net.sourceforge.texlipse.builder.TexlipseBuilder), it's buggy
  
Actual results:
not fixed with a yum reinstall eclipse*

Expected results:
Makes texlipse work again
Comment 1 Pierre Blavy 2011-01-05 11:31:10 EST
** The same bug happens for CDT, the builder is not found.



**WORKAROUND for CDT : use the eclipse.org version 

cd/tmp  
wget http://eclipse.ialto.com/technology/epp/downloads/release/helios/SR1/eclipse-cpp-helios-SR1-linux-gtk-x86_64.tar.gz
tar -xf eclipse-cpp-helios-SR1-linux-gtk-x86_64.tar.gz
cd eclipse
./eclipse


- If code is shown in black and white, write click your code file and choose open with C++ editor




** WORKAROUND for texlipse : use eclipse.org version of eclipse

install the textlipse plugin: Point your Eclipse Update site browser to: http://texlipse.sourceforge.net/


- If code is shown in black and white, write click your code file and choose open with latex editor



**Others things I've tried
- Using a new workspace do NOT fix the bug
- yum reinstall java do NOT fix the bug
Comment 2 Alexander Kurtakov 2011-02-18 06:29:27 EST
Can you try removing your ~/.eclipse folder and retry?
Comment 3 Andrew Overholt 2011-04-27 08:07:15 EDT

*** This bug has been marked as a duplicate of bug 684894 ***

Note You need to log in before you can comment on or make changes to this bug.