This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 684894 - Dropins content not loaded
Dropins content not loaded
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: eclipse (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Chris Aniszczyk
Fedora Extras Quality Assurance
:
: 667376 697338 699646 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-03-14 14:18 EDT by Matěj Cepl
Modified: 2014-07-25 01:53 EDT (History)
10 users (show)

See Also:
Fixed In Version: eclipse-3.6.2-5.fc15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-04-30 23:21:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
the first run of eclipse (2.37 KB, text/plain)
2011-03-14 14:18 EDT, Matěj Cepl
no flags Details
the second run of eclipse (2.37 KB, text/plain)
2011-03-14 14:19 EDT, Matěj Cepl
no flags Details
the fourth run of eclipse (with eclipse-pde) (5.84 KB, text/plain)
2011-03-14 14:22 EDT, Matěj Cepl
no flags Details
screenshots of the Task dialog (9.13 KB, image/png)
2011-04-15 09:21 EDT, Matěj Cepl
no flags Details
screenshot of the new projects dialog (23.89 KB, image/png)
2011-04-15 09:22 EDT, Matěj Cepl
no flags Details

  None (edit)
Description Matěj Cepl 2011-03-14 14:18:37 EDT
Created attachment 484272 [details]
the first run of eclipse

Steps to Reproduce:
1. yum install eclipse-pydev-mylyn eclipse-mylyn-trac
2. start eclipse, exit; pkill -KILL -f eclipse
3. start eclipse, exit; pkill -KILL -f eclipse
4. yum install eclipse-pde
5. start eclipse
  
Version-Release number of selected component (if applicable):
eclipse-swt-3.6.1-5.fc15.x86_64
eclipse-nls-3.6.0.v20100814043401-5.fc15.noarch
eclipse-mylyn-3.4.2-5.fc15.noarch
eclipse-jdt-3.6.1-5.fc15.x86_64
eclipse-jgit-0.10.1-2.fc15.noarch
eclipse-platform-3.6.1-5.fc15.x86_64
eclipse-egit-0.10.1-2.fc15.noarch
eclipse-pydev-1.6.4-2.fc15.x86_64
eclipse-pydev-mylyn-1.6.4-2.fc15.x86_64
eclipse-pde-3.6.1-5.fc15.x86_64
eclipse-mylyn-trac-3.4.2-5.fc15.noarch
eclipse-nls-cs-3.6.0.v20100814043401-5.fc15.noarch
eclipse-rcp-3.6.1-5.fc15.x86_64


How reproducible:
100%

Actual results:
In step 3 there is no PyDev persepcitve, nor any Mylyn view
Both are available in step 5 

Expected results:
In step 2 (or 3) there should be fully available mylyn and pydev

Additional info:
17:00:52] akurtakov: mcepl: can you install eclipse-pde and retry
[17:01:01] mcepl: sure
wtfness se přejmenoval na foocraft
foocraft se přejmenoval na nixness
[17:24:25] mcepl: akurtakov: yup, I have no PyDev
[17:24:41] mcepl: and mylyn
[17:24:51] akurtakov: mcepl: second start after pde install ?
[17:29:03] mcepl: no, the first one
[17:29:06] mcepl: OK, let me try once again
[17:29:21] mcepl: sorry, I have now PyDev, but no egit, will check again
[17:44:13] mcepl: akurtakov: OK, everythings work now
[17:44:25] mcepl: so, why it doesn't work without -pde?
[18:14:41] akurtakov: mcepl: obviously error on our site
[18:16:18] overholt: akurtakov: I think this confirms the ant.source (or whatever jar it was) problem in dropins
[18:16:43] overholt: akurtakov: I don't know why that's happening.  we provision the JDT using the directory and move everything over to dropins/jdt and then do the same with PDE
[18:17:50] overholt: akurtakov: perhaps there's a logic error in the moving bits of the ant files
[18:18:12] akurtakov: overholt: yes, the strange thing is that it should be in platform?
[18:19:31] overholt: akurtakov: really?  I guess we need to go through the features and figure that out.  or use the director to provision into a new directory and see what gets added as each feature gets installed.
[18:20:35] akurtakov: overholt: mcepl had neither jdt nor pde and it was failing for him this way
[18:20:43] overholt: akurtakov: interesting
[18:21:38] mcepl: akurtakov: BTW, I should file a bug for it, right?
[18:21:57] overholt: akurtakov: o.e.platform feature includes o.a.ant and o.e.ant.core
[18:21:57] akurtakov: mcepl: yes,  please
[18:22:11] akurtakov: mcepl: with the details too
[18:22:26] mcepl: what do you mean by details?

[18:22:57] akurtakov: mcepl: the last 20-30 lines ^^^
[18:24:23] akurtakov: overholt: I have to go now 
[18:24:26] akurtakov: ttyl
[18:24:33] overholt: akurtakov: bye
[18:39:15] orionp: Isn't this bug 665249?
[18:41:01] overholt: there's more than one duplicate ATM
Comment 1 Matěj Cepl 2011-03-14 14:19:55 EDT
Created attachment 484274 [details]
the second run of eclipse
Comment 2 Matěj Cepl 2011-03-14 14:22:15 EDT
Created attachment 484277 [details]
the fourth run of eclipse (with eclipse-pde)

(the third run was just after installation of pde, then neither pydev nor mylyn were present)
both mylyn and pydev are present
Comment 3 Alexander Kurtakov 2011-04-15 07:48:57 EDT
The problem should be fixed in latest F-15 build, would you please check?
Comment 4 Matěj Cepl 2011-04-15 09:21:18 EDT
Created attachment 492375 [details]
screenshots of the Task dialog

bradford:~ $ rpm -qa eclipse\*
eclipse-swt-3.6.2-2.fc15.x86_64
eclipse-platform-3.6.2-2.fc15.x86_64
eclipse-nls-cs-3.6.0.v20100814043401-5.fc15.noarch
eclipse-rcp-3.6.2-2.fc15.x86_64
eclipse-nls-3.6.0.v20100814043401-5.fc15.noarch
eclipse-pydev-mylyn-1.6.5-1.fc15.x86_64
eclipse-mylyn-3.4.2-5.fc15.noarch
eclipse-pydev-1.6.5-1.fc15.x86_64
eclipse-mylyn-trac-3.4.2-5.fc15.noarch
bradford:~ $
Comment 5 Matěj Cepl 2011-04-15 09:22:30 EDT
Created attachment 492376 [details]
screenshot of the new projects dialog

To make long story short: it doesn't seem to be fixed with the version of packages as shown above.
Comment 6 Alexander Kurtakov 2011-04-15 09:36:22 EDT
Chris, wasn't this fixed?
Comment 7 Chris Aniszczyk 2011-04-15 10:38:54 EDT
It should be

Can you make sure that ~/.eclipse is deleted before you reinstall Eclipse? Otherwise you end up with information from the old local profile.
Comment 8 Matěj Cepl 2011-04-15 16:07:06 EDT
(In reply to comment #7)
> It should be
> 
> Can you make sure that ~/.eclipse is deleted before you reinstall Eclipse?
> Otherwise you end up with information from the old local profile.

I did rm -rf ~/.eclipse before every attempt.
Comment 9 Aiden 2011-04-16 11:50:31 EDT
FYI, though not latest pkgs

================================================================================
 Package                  Arch         Version               Repository    Size
================================================================================
Installing:
 eclipse-phpeclipse       noarch       1.2.3-3.fc15          fedora        13 M
 eclipse-platform         x86_64       1:3.6.1-5.fc15        fedora        28 M
 eclipse-pydev            x86_64       1:1.6.5-1.fc15        fedora       5.1 M
Installing for dependencies:
 eclipse-rcp              x86_64       1:3.6.1-5.fc15        fedora       7.6 M
 eclipse-swt              x86_64       1:3.6.1-5.fc15        fedora       2.3 M
 piccolo2d                noarch       1.3-8.fc15            fedora       267 k

Transaction Summary
================================================================================

No plugins show up, no editors to associate. Issues similar to:

https://bugzilla.redhat.com/show_bug.cgi?id=665249

Confirm resolved with:

a) Install eclipse-pde 3.6.1-5.fc15
b) rm -rf ~/.eclipse
c) eclipse -clean -debug
d) restart eclipse

Plugins show up with PDE.
Comment 10 Alexander Kurtakov 2011-04-18 04:29:13 EDT
*** Bug 697338 has been marked as a duplicate of this bug. ***
Comment 11 Alexander Kurtakov 2011-04-18 04:30:52 EDT
Chris, one more report of the same problem https://bugzilla.redhat.com/show_bug.cgi?id=697338
Comment 12 Andrew Overholt 2011-04-27 08:07:16 EDT
*** Bug 667376 has been marked as a duplicate of this bug. ***
Comment 13 Andrew Overholt 2011-04-27 08:09:51 EDT
Renaming for clarity.
Comment 14 Andrew Overholt 2011-04-27 09:27:50 EDT
*** Bug 699646 has been marked as a duplicate of this bug. ***
Comment 15 Chris Aniszczyk 2011-04-27 17:42:38 EDT
This will be fixed with eclipse-3.6.2-5.fc15

http://koji.fedoraproject.org/koji/buildinfo?buildID=241043
Comment 16 Fedora Update System 2011-04-27 17:48:37 EDT
eclipse-3.6.2-5.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/eclipse-3.6.2-5.fc15
Comment 17 Fedora Update System 2011-04-27 17:52:19 EDT
sat4j-2.3.0-2.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/sat4j-2.3.0-2.fc15
Comment 18 Fedora Update System 2011-04-28 10:38:31 EDT
eclipse-3.6.2-5.fc15,sat4j-2.3.0-2.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/eclipse-3.6.2-5.fc15,sat4j-2.3.0-2.fc15
Comment 19 Fedora Update System 2011-04-28 15:01:17 EDT
Package eclipse-3.6.2-5.fc15, sat4j-2.3.0-2.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing eclipse-3.6.2-5.fc15 sat4j-2.3.0-2.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/eclipse-3.6.2-5.fc15,sat4j-2.3.0-2.fc15
then log in and leave karma (feedback).
Comment 20 Fedora Update System 2011-04-30 23:20:57 EDT
eclipse-3.6.2-5.fc15, sat4j-2.3.0-2.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.