Bug 667528 - seg fault when starting open office
seg fault when starting open office
Status: CLOSED DUPLICATE of bug 649310
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
14
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-01-05 16:39 EST by Peter F. Patel-Schneider
Modified: 2011-01-07 10:22 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-01-07 10:22:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter F. Patel-Schneider 2011-01-05 16:39:53 EST
Description of problem:

office seg faults when starting

Version-Release number of selected component (if applicable):

1:3.3.0-18.2.fc14
 
2.6.35.10-74.fc14.x86_64 #1 SMP Thu Dec 23 16:04:50 UTC 2010 x86_64 x86_64 x86_64 GNU/Linux

How reproducible:

Always (on one machine).

Steps to Reproduce:
1. ooffice
2.
3.
  
Actual results:

obelix 321> ooffice
[Splash screen shows for a short while]
/usr/lib64/openoffice.org3/program/soffice: line 116:  6038 Segmentation fault      (core dumped) "$sd_prog/$sd_binary" "$@"


Expected results:

openoffice starts correctly

Additional info:

Just in case the problem is with package requires:

obelix 319> sudo yum list 'openoffice*'
[sudo] password for pfps: 
Loaded plugins: langpacks, presto, refresh-packagekit
Adding en_US to language list
Installed Packages
openoffice.org-brand.x86_64                    1:3.3.0-18.2.fc14        @updates
openoffice.org-calc.x86_64                     1:3.3.0-18.2.fc14        @updates
openoffice.org-calc-core.x86_64                1:3.3.0-18.2.fc14        @updates
openoffice.org-core.x86_64                     1:3.3.0-18.2.fc14        @updates
openoffice.org-draw.x86_64                     1:3.3.0-18.2.fc14        @updates
openoffice.org-draw-core.x86_64                1:3.3.0-18.2.fc14        @updates
openoffice.org-graphicfilter.x86_64            1:3.3.0-18.2.fc14        @updates
openoffice.org-impress.x86_64                  1:3.3.0-18.2.fc14        @updates
openoffice.org-impress-core.x86_64             1:3.3.0-18.2.fc14        @updates
openoffice.org-langpack-en.x86_64              1:3.3.0-18.2.fc14        @updates
openoffice.org-math.x86_64                     1:3.3.0-18.2.fc14        @updates
openoffice.org-math-core.x86_64                1:3.3.0-18.2.fc14        @updates
openoffice.org-opensymbol-fonts.noarch         1:3.3.0-18.2.fc14        @updates
openoffice.org-pdfimport.x86_64                1:3.3.0-18.2.fc14        @updates
openoffice.org-presenter-screen.x86_64         1:3.3.0-18.2.fc14        @updates
openoffice.org-ure.x86_64                      1:3.3.0-18.2.fc14        @updates
openoffice.org-writer.x86_64                   1:3.3.0-18.2.fc14        @updates
openoffice.org-writer-core.x86_64              1:3.3.0-18.2.fc14        @updates
Available Packages
openoffice.org-base.x86_64                     1:3.3.0-18.2.fc14        updates 
openoffice.org-base-core.x86_64                1:3.3.0-18.2.fc14        updates 
openoffice.org-bsh.x86_64                      1:3.3.0-18.2.fc14        updates 
openoffice.org-devel.i686                      1:3.3.0-18.2.fc14        updates 
openoffice.org-devel.x86_64                    1:3.3.0-18.2.fc14        updates 
openoffice.org-emailmerge.x86_64               1:3.3.0-18.2.fc14        updates 
openoffice.org-extendedPDF.x86_64              1.4-10.fc14              fedora  
openoffice.org-headless.x86_64                 1:3.3.0-18.2.fc14        updates 
openoffice.org-javafilter.x86_64               1:3.3.0-18.2.fc14        updates 
[lots of lang packs]
openoffice.org-ogltrans.x86_64                 1:3.3.0-18.2.fc14        updates 
openoffice.org-ooolatex.x86_64                 4.0.0-0.8.beta2.fc14.1   fedora  
openoffice.org-presentation-minimizer.x86_64   1:3.3.0-18.2.fc14        updates 
openoffice.org-pyuno.x86_64                    1:3.3.0-18.2.fc14        updates 
openoffice.org-report-builder.x86_64           1:3.3.0-18.2.fc14        updates 
openoffice.org-rhino.x86_64                    1:3.3.0-18.2.fc14        updates 
openoffice.org-sdk.x86_64                      1:3.3.0-18.2.fc14        updates 
openoffice.org-sdk-doc.x86_64                  1:3.3.0-18.2.fc14        updates 
openoffice.org-testtools.x86_64                1:3.3.0-18.2.fc14        updates 
openoffice.org-voikko.x86_64                   3.1.2-1.fc14             fedora  
openoffice.org-wiki-publisher.x86_64           1:3.3.0-18.2.fc14        updates 
openoffice.org-writer2latex.x86_64             1.0.2-3.fc14             fedora  
openoffice.org-writer2xhtml.x86_64             1.0.2-3.fc14             fedora  
openoffice.org-xsltfilter.x86_64               1:3.3.0-18.2.fc14        updates 
obelix 320>
Comment 1 David Tardon 2011-01-06 02:54:41 EST
Does it help if you remove ~/.openoffice.org/3/user/extensions ?
Comment 2 Peter F. Patel-Schneider 2011-01-07 08:56:55 EST
Yep.  That "fixes" the crash (but I don't know just what functionality I've removed, if anything).
Comment 3 David Tardon 2011-01-07 10:22:36 EST
None at all. That dir contains only autogenerated data. It will just be recreated on the next start.

*** This bug has been marked as a duplicate of bug 649310 ***

Note You need to log in before you can comment on or make changes to this bug.