Bug 649310 - [abrt] dp_registry::backend::bundle::(anonymous namespace)::BackendImpl::PackageImpl::getBundle (mixed-arch config dir ?)
[abrt] dp_registry::backend::bundle::(anonymous namespace)::BackendImpl::Pack...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
14
x86_64 Unspecified
low Severity medium
: ---
: ---
Assigned To: David Tardon
Fedora Extras Quality Assurance
abrt_hash:11f09e5699b8b2948f612e479c9...
:
: 649351 649353 649391 653920 654410 655406 663085 665600 666481 667404 667528 670627 671519 672531 679406 682849 689132 689942 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-11-03 10:16 EDT by Eric Blake
Modified: 2011-04-14 16:54 EDT (History)
21 users (show)

See Also:
Fixed In Version: openoffice.org-3.3.0-20.5.fc14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-04-14 16:54:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: backtrace (215.61 KB, text/plain)
2010-11-03 10:16 EDT, Eric Blake
no flags Details
as requested in comment 8 (77.61 KB, application/octet-stream)
2010-11-04 09:59 EDT, Eric Blake
no flags Details

  None (edit)
Description Eric Blake 2010-11-03 10:16:38 EDT
abrt version: 1.1.13
architecture: x86_64
Attached file: backtrace
cmdline: /usr/lib64/openoffice.org3/program/scalc.bin -calc file:///home/eblake/Documents/hours.ods
comment: just trying to start any ooo app after preupgrading from F13 to F14
component: openoffice.org
crash_function: dp_registry::backend::bundle::(anonymous namespace)::BackendImpl::PackageImpl::getBundle
executable: /usr/lib64/openoffice.org3/program/scalc.bin
kernel: 2.6.35.6-48.fc14.x86_64
package: openoffice.org-calc-1:3.3.0-9.3.fc14
rating: 4
reason: Process /usr/lib64/openoffice.org3/program/scalc.bin was killed by signal 11 (SIGSEGV)
release: Fedora release 14 (Laughlin)
time: 1288793163
uid: 14986
Comment 1 Eric Blake 2010-11-03 10:16:41 EDT
Created attachment 457447 [details]
File: backtrace
Comment 2 David Tardon 2010-11-03 12:03:58 EDT
Does it crash again? Which bundled extensions do you have? (run unopkg list --bundled to get them)
Comment 3 David Tardon 2010-11-03 12:06:57 EDT
*** Bug 649351 has been marked as a duplicate of this bug. ***
Comment 4 David Tardon 2010-11-03 12:07:13 EDT
*** Bug 649353 has been marked as a duplicate of this bug. ***
Comment 5 Eric Blake 2010-11-03 12:09:54 EDT
Yes, it crashes every time I attempt to start any ooo app, while the splash screen says "Synchronizing repository for bundled extensions".

$ unopkg list --bundled
/usr/lib64/openoffice.org3/program/unopkg: line 102: 31901 Segmentation fault      (core dumped) "$sd_prog/unopkg.bin" "$@" "-env:INIFILENAME=vnd.sun.star.pathname:$sd_prog/redirectrc"
$ echo $?
0

(that's bad in itself - a segfault/coredump should never give 0 exit status)
Comment 6 Eric Blake 2010-11-03 12:11:33 EDT
trying again as root:

# unopkg list --bundled
sh: line 1: 31940 Aborted                 (core dumped) /bin/sh -c "gconftool-2 -g /desktop/gnome/interface/accessibility" 2> /dev/null
All deployed bundled extensions:

Identifier: com.sun.star.PDFImport-linux_x86_64
  Version: 1.0.3
  URL: vnd.sun.star.expand:$BUNDLED_EXTENSIONS/pdfimport.oxt
  is registered: no
  Media-Type: application/vnd.sun.star.package-bundle
  Description: The PDF Import Extension allows you to import and modify PDF documents. Best results with 100% layout accuracy can be achieved with the "PDF/ODF hybrid file" format, which this extension also enables. A hybrid PDF/ODF file is a PDF file that contains an embedded ODF source file. Hybrid PDF/ODF files will be opened in OpenOffice.org as an ODF file without any layout changes.

  bundled Packages: {
      URL: vnd.sun.star.expand:$BUNDLED_EXTENSIONS/pdfimport.oxt/basic/
      is registered: no
      Media-Type: application/vnd.sun.star.basic-library
      Description: 

      URL: vnd.sun.star.expand:$BUNDLED_EXTENSIONS/pdfimport.oxt/xpdfimport
      is registered: no
      Media-Type: application/vnd.sun.star.executable
      Description: 

      URL: vnd.sun.star.expand:$BUNDLED_EXTENSIONS/pdfimport.oxt/pdfimport.uno.so
      is registered: no
      Media-Type: application/vnd.sun.star.uno-component;type=native;platform=Linux_X86_64
      Description: 

      URL: vnd.sun.star.expand:$BUNDLED_EXTENSIONS/pdfimport.oxt/pdf_import_filter.xcu
      is registered: no
      Media-Type: application/vnd.sun.star.configuration-data
      Description: 

      URL: vnd.sun.star.expand:$BUNDLED_EXTENSIONS/pdfimport.oxt/pdf_types.xcu
      is registered: no
      Media-Type: application/vnd.sun.star.configuration-data
      Description: 

  }

Identifier: com.sun.PresenterScreen-linux_x86_64
  Version: 1.1.0
  URL: vnd.sun.star.expand:$BUNDLED_EXTENSIONS/presenter-screen.oxt
  is registered: no
  Media-Type: application/vnd.sun.star.package-bundle
  Description: The Presenter Console Extension provides more control over your slide show presentation, such as the ability to see the upcoming slide, the slide notes, and a presentation timer whereas the audience see only the current slide.
To avoid confusions by displaying a large number of presentation elements, the Presenter Console displays the elements on three different easily changeable views.

  bundled Packages: {
      URL: vnd.sun.star.expand:$BUNDLED_EXTENSIONS/presenter-screen.oxt/help
      is registered: no
      Media-Type: application/vnd.sun.star.help
      Description: 

      URL: vnd.sun.star.expand:$BUNDLED_EXTENSIONS/presenter-screen.oxt/registry/schema/org/openoffice/Office/extension/PresenterScreen.xcs
      is registered: no
      Media-Type: application/vnd.sun.star.configuration-schema
      Description: 

      URL: vnd.sun.star.expand:$BUNDLED_EXTENSIONS/presenter-screen.oxt/PresenterScreen.uno.so
      is registered: no
      Media-Type: application/vnd.sun.star.uno-component;type=native;platform=Linux_X86_64
      Description: 

      URL: vnd.sun.star.expand:$BUNDLED_EXTENSIONS/presenter-screen.oxt/registry/data/org/openoffice/Office/Jobs.xcu
      is registered: no
      Media-Type: application/vnd.sun.star.configuration-data
      Description: 

      URL: vnd.sun.star.expand:$BUNDLED_EXTENSIONS/presenter-screen.oxt/registry/data/org/openoffice/Office/ProtocolHandler.xcu
      is registered: no
      Media-Type: application/vnd.sun.star.configuration-data
      Description: 

      URL: vnd.sun.star.expand:$BUNDLED_EXTENSIONS/presenter-screen.oxt/registry/data/org/openoffice/Office/extension/PresenterScreen.xcu
      is registered: no
      Media-Type: application/vnd.sun.star.configuration-data
      Description: 

  }

Identifier: com.sun.star.PresentationMinimizer-linux_x86_64
  Version: 1.0.2
  URL: vnd.sun.star.expand:$BUNDLED_EXTENSIONS/presentation-minimizer.oxt
  is registered: yes
  Media-Type: application/vnd.sun.star.package-bundle
  Description: The Presentation Minimizer is used to reduce the file size of the current presentation. Images will be compressed, and data that is no longer needed will be removed.
The Presentation Minimizer can optimize the image quality size. Presentations designed for screen or projector do not require the same high quality as presentations designed for print.

  bundled Packages: {
      URL: vnd.sun.star.expand:$BUNDLED_EXTENSIONS/presentation-minimizer.oxt/registry/schema/org/openoffice/Office/extension/SunPresentationMinimizer.xcs
      is registered: yes
      Media-Type: application/vnd.sun.star.configuration-schema
      Description: 

      URL: vnd.sun.star.expand:$BUNDLED_EXTENSIONS/presentation-minimizer.oxt/SunPresentationMinimizer.uno.so
      is registered: yes
      Media-Type: application/vnd.sun.star.uno-component;type=native;platform=Linux_X86_64
      Description: 

      URL: vnd.sun.star.expand:$BUNDLED_EXTENSIONS/presentation-minimizer.oxt/registry/data/org/openoffice/Office/extension/SunPresentationMinimizer.xcu
      is registered: yes
      Media-Type: application/vnd.sun.star.configuration-data
      Description: 

      URL: vnd.sun.star.expand:$BUNDLED_EXTENSIONS/presentation-minimizer.oxt/registry/data/org/openoffice/Office/Addons.xcu
      is registered: yes
      Media-Type: application/vnd.sun.star.configuration-data
      Description: 

      URL: vnd.sun.star.expand:$BUNDLED_EXTENSIONS/presentation-minimizer.oxt/registry/data/org/openoffice/Office/ProtocolHandler.xcu
      is registered: yes
      Media-Type: application/vnd.sun.star.configuration-data
      Description: 

  }

Identifier: org.openoffice.legacy.extendedPDF.zip
  URL: vnd.sun.star.expand:$BUNDLED_EXTENSIONS/extendedPDF.zip
  is registered: n/a
  Media-Type: application/vnd.sun.star.package-bundle
  Description: 
  bundled Packages: {
    <none>
  }

$
Comment 7 David Tardon 2010-11-03 13:36:38 EDT
*** Bug 649391 has been marked as a duplicate of this bug. ***
Comment 8 David Tardon 2010-11-04 09:45:37 EDT
Could you run

tar -cjf /tmp/bundled.tar.bz2 ~/.openoffice.org/3/user/extensions/bundled

and attach /tmp/bundled.tar.bz2 here? When you have done that, remove ~/.openoffice.org/3/user/extensions/bundled and oo.o should start.
Comment 9 Eric Blake 2010-11-04 09:59:07 EDT
Created attachment 457800 [details]
as requested in comment 8
Comment 10 Eric Blake 2010-11-04 10:02:20 EDT
I can confirm that moving ~/.openoffice.org/3/user/extensions/bundled out of the way lets me start oo.o again.  Thanks.
Comment 11 David Tardon 2010-11-04 13:50:05 EDT
sweet
Comment 12 David Tardon 2010-11-06 06:24:05 EDT
It seems that the new concept of on-start activation of extensions has some shortcomings... In particular, this crash is caused by presence of activation data for x86 version of presenter-screen on x86_64 system.

dtardon->eblake: Do you use shared home on machines of different architectures? Or did you copy it (or the openoffice.org configuration) from another machine that was running i686 version of Fedora 14?
Comment 13 Eric Blake 2010-11-06 08:59:00 EDT
(In reply to comment #12)
> dtardon->eblake: Do you use shared home on machines of different architectures?
> Or did you copy it (or the openoffice.org configuration) from another machine
> that was running i686 version of Fedora 14?

I've set my machine up as a triple-boot between x86_64 F14, x86_64 RHEL 6 beta, and i686 rawhide, and yes, my /home is on a partition shared between all three.  And yes, the cross-arch shared home does flush out some interesting issues (which is partly why I do it).
Comment 14 David Tardon 2010-11-16 08:57:45 EST
*** Bug 653920 has been marked as a duplicate of this bug. ***
Comment 15 David Tardon 2010-11-17 14:58:31 EST
*** Bug 654410 has been marked as a duplicate of this bug. ***
Comment 16 Joël Wijngaarde 2010-11-17 15:03:36 EST
Just added a comment to Bug 654410, which is now marked as a duplicate, but maybe this comment is still helpful; so I post it here too:


I could resolve the issue by deleting my F13 .openoffice.org directory from my
home dir. Apparently the directory created by OpenOffice in Fedora 13 is not
compatible. Instead of overwriting or a dialog, OpenOffice crashes (core
dumped).

So the good news is, you can work around this problem by removing your
.openoffice.org from your homedir.
Comment 17 Caolan McNamara 2010-11-20 16:02:10 EST
*** Bug 655406 has been marked as a duplicate of this bug. ***
Comment 18 Matthew Gardner 2010-11-20 16:39:30 EST
I had abrt post bug 655406, which is a duplicate of this bug.  Now that I see what happened, I can give some more information about how I ran into this, in case anyone might find it helpful.

I upgraded from F12 to F14, using rsync to backup my home directory before I did the reinstall (just a fresh install; I didn't use preupgrade).  When I restored my home directory, the .openoffice.org directory was restored with it, causing the problem.  After I saw these comments, I removed my .openoffice.org directory and everything worked fine.
Comment 19 Caolan McNamara 2010-12-14 11:43:24 EST
*** Bug 663085 has been marked as a duplicate of this bug. ***
Comment 20 David Tardon 2010-12-25 07:33:45 EST
*** Bug 665600 has been marked as a duplicate of this bug. ***
Comment 21 David Tardon 2011-01-01 11:03:08 EST
*** Bug 666481 has been marked as a duplicate of this bug. ***
Comment 22 David Tardon 2011-01-05 12:16:49 EST
*** Bug 667404 has been marked as a duplicate of this bug. ***
Comment 23 David Tardon 2011-01-07 10:22:36 EST
*** Bug 667528 has been marked as a duplicate of this bug. ***
Comment 24 Philippe Jumelle 2011-01-10 07:50:10 EST
Package: openoffice.org-brand-1:3.3.0-18.2.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. start openoffice. Crash occurs every time
2.
3.


Comment
-----
not sure what is wrong with my setup to result in this crash making the whole openoffice environment unusable
Comment 25 Joël Wijngaarde 2011-01-10 11:52:56 EST
Well, do not know if this is similar to another issue I had. I solved this by removing my .openoffice.org directory in my $HOME folder and restarting OpenOffice forcing a recreation of this directory.
Comment 26 Philippe Jumelle 2011-01-10 12:13:43 EST
Thanks a lot for this piece of advice. Issue solved!
FYI: I cross-graded recently from F14 i686 to F14 x64. My home directory was untouched in this process and Open Office worked for some time ... As mentioned above, it seems I am having some kind of cross-arch issue.
Comment 27 David Tardon 2011-01-19 00:13:02 EST
*** Bug 670627 has been marked as a duplicate of this bug. ***
Comment 28 David Tardon 2011-01-22 01:55:20 EST
*** Bug 671519 has been marked as a duplicate of this bug. ***
Comment 29 Filipe Sousa 2011-01-22 05:35:36 EST
(In reply to comment #25)
> Well, do not know if this is similar to another issue I had. I solved this by
> removing my .openoffice.org directory in my $HOME folder and restarting
> OpenOffice forcing a recreation of this directory.

Thank you so much for the tip. Now it works.
Comment 30 David Tardon 2011-01-25 08:19:08 EST
*** Bug 672531 has been marked as a duplicate of this bug. ***
Comment 31 Lofton Alley 2011-01-27 07:43:35 EST
Package: openoffice.org-writer-1:3.3.0-19.2.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1.install oo.o and try to start any of the apps
2.Solved by removing the /home/me/.openoffice.org folder
3.
Comment 32 Mitch Davis 2011-02-04 21:22:12 EST
Package: openoffice.org-writer-1:3.3.0-19.2.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. Started Writer :-(
2.
3.


Comment
-----
I'm not sure if this is relevant, but I recently installed Fedora 14 64-bit.  Previously I was running Fedora 14 32-bit.  My /home is carried over from the previous OS.  It's possible that there's something left over in /home that Writer is reading on startup (recovery files?) that causes the 64-bit version to barf.
Comment 33 Manuel Viana 2011-02-07 06:38:21 EST
Package: openoffice.org-writer-1:3.3.0-19.2.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. run openoffice writer
2.
3.


Comment
-----
Simple running of Open Office Writer on Fedora 14 x86_64 base install.
Comment 34 Caolan McNamara 2011-02-08 08:01:14 EST
caolanm->dtardon: where are we with this one, do we have a fix, or is it really messed up ?
Comment 35 David Tardon 2011-02-10 04:24:48 EST
dtardon->caolanm: I think we are near the goal. The code is now able to cope with different platform when unregistering an extension on start, but I'm getting a crash somewhere after that. I suspect I've missed some little bit that causes an exception later...
Comment 36 David Tardon 2011-02-10 09:21:17 EST
That crash I spoke about in comment 35 is completely unrelated (and hopefully only present on libreoffice master), so I've commited the fix. It will be in >=openoffice.org-3.3.0-20.3.fc14 .
Comment 37 David Tardon 2011-02-22 12:42:30 EST
*** Bug 679406 has been marked as a duplicate of this bug. ***
Comment 38 fm 2011-02-26 20:11:51 EST
Package: openoffice.org-writer-1:3.3.0-20.2.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1.lanuch openoffice from menu or terminal.
Comment 39 Caolan McNamara 2011-03-07 15:01:33 EST
*** Bug 682849 has been marked as a duplicate of this bug. ***
Comment 40 Alan Topham 2011-03-14 13:54:34 EDT
Package: openoffice.org-writer-1:3.3.0-20.2.fc14
Architecture: i686
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1.log in
2.start OpenOffice
3.Crash...
Comment 41 Nicolas R. 2011-03-19 15:06:58 EDT
Package: openoffice.org-writer-1:3.3.0-20.2.fc14
Architecture: i686
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. Open OpenOffice
2.
3.
Comment 42 David Tardon 2011-03-20 04:11:29 EDT
*** Bug 689132 has been marked as a duplicate of this bug. ***
Comment 43 Caolan McNamara 2011-03-22 16:39:25 EDT
*** Bug 689942 has been marked as a duplicate of this bug. ***
Comment 44 Bill Wesman 2011-04-05 19:02:23 EDT
Package: openoffice.org-writer-1:3.3.0-20.2.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1.I upgraded from Fedora 14 (x86) to Fedora 14 (x86_64) keeping system (etc.) data in /home.
2.I then tried to start OpeOffice Write/Calc
3.


Comment
-----
Other OOO apps don't seem to work either.
Comment 45 Fedora Update System 2011-04-06 03:59:22 EDT
openoffice.org-3.3.0-20.5.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/openoffice.org-3.3.0-20.5.fc14
Comment 46 Fedora Update System 2011-04-06 18:28:16 EDT
Package openoffice.org-3.3.0-20.5.fc14:
* should fix your issue,
* was pushed to the Fedora 14 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing openoffice.org-3.3.0-20.5.fc14'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/openoffice.org-3.3.0-20.5.fc14
then log in and leave karma (feedback).
Comment 47 Fedora Update System 2011-04-14 16:54:08 EDT
openoffice.org-3.3.0-20.5.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.