Bug 6681 - can't upgrade 6.0 --> 6.1
can't upgrade 6.0 --> 6.1
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
6.1
i386 Linux
high Severity high
: ---
: ---
Assigned To: Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-11-03 10:07 EST by larrieu
Modified: 2015-01-07 18:39 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-11-30 09:36:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description larrieu 1999-11-03 10:07:40 EST
installer program (patched, using the Oct 22 boot disk and
updates disk) says that it can't upgrade because there are
no linux partitions.  Here is what fdisk has to say, when
run from the currently installed 6.0:


The number of cylinders for this disk is set to 1869.
There is nothing wrong with that, but this is larger than
1024,
and could in certain setups cause problems with:
1) software that runs at boot time (e.g., LILO)
2) booting and partitioning software from other OSs
   (e.g., DOS FDISK, OS/2 FDISK)

Command (m for help): p

Disk /dev/hda: 255 heads, 63 sectors, 1869 cylinders
Units = cylinders of 16065 * 512 bytes

   Device Boot    Start       End    Blocks   Id  System
/dev/hda1            72      1869  14442435    f  Win95
Ext'd (LBA)
/dev/hda2   *         8        71    514080    6  FAT16
/dev/hda3   *         1         7     56196   16  Hidden
FAT16
/dev/hda5   *        72       263   1542208+  83  Linux
/dev/hda6           264       326    506016   83  Linux
/dev/hda7           327       343    136521   82  Linux swap
/dev/hda8           344      1869  12257563+  83  Linux
Comment 1 Jay Turner 1999-11-30 09:36:59 EST
This is a known bug with the installer not being able to see past type "f"
partitions.  The workaround is to convert the partition to type "5" for the
duration of the upgrade and then convert it back to type "f" after you have
completed the upgrade.

In addition, we should be releasing another updates disk here this week (fingers
crossed) which will solve this problem without having to muck with the partition
type.


*** This bug has been marked as a duplicate of 5511 ***

Note You need to log in before you can comment on or make changes to this bug.