Bug 66812 - anaconda dump, failed installation,
Summary: anaconda dump, failed installation,
Status: CLOSED DUPLICATE of bug 66181
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
(Show other bugs)
Version: 7.3
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Michael Fulbright
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-06-17 10:04 UTC by Daniel Le
Modified: 2007-04-18 16:43 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-06-17 21:29:05 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Anaconda, checking hard drive for bad blocks crash pc. (57.42 KB, text/plain)
2002-06-17 10:07 UTC, Daniel Le
no flags Details

Description Daniel Le 2002-06-17 10:04:54 UTC
Description of Problem:

Installing RedHAt Linux 7.3 using CD-ROM bootable setup.
At the creation of partition for Linux, I chosed check hard disk for bad 
blocks and if found any bad blocks Redhat should assign the bad blocks 
unusable block, because I know my hard drive have bad sectors about 512 bytes. 
But instead of making the block unusable for data, it just crashed. Displaying 
a window that is a bug, etc. and ask me to save he bug reported to a floppy 
disk (anacdump.txt).

hmm how can i attach this file here? no attach button.


Daniel

Comment 1 Daniel Le 2002-06-17 10:07:01 UTC
Created attachment 61124 [details]
Anaconda, checking hard drive for bad blocks crash pc.

Comment 2 Michael Fulbright 2002-06-17 16:17:26 UTC
Could you try again w/o checking for bad blocks?

Comment 3 Michael Fulbright 2002-06-17 21:28:08 UTC
This error occurs when the badblocks command detects bad blocks on the system. 
The traceback occurred because the output from the badblocks command has
changed, fooling our parser.

If you get this traceback it means you have bad blocks on the drive it was testing.

In the future an error dialog will be presented saying bad blocks have been
detected.

Comment 4 Michael Fulbright 2002-06-17 21:32:18 UTC

*** This bug has been marked as a duplicate of 66181 ***

Comment 5 Daniel Le 2002-06-18 06:05:19 UTC
I have tried to install RedHat 7.3 again, without the checking for bad blocks. 
But as soon as copying packages to the hard disk where the bad blocks is, will 
still crash and goes to the command prompt, it doesn't let me continue the 
installation.

I have no problem installing Novell Netware 5.1 and MS Windows 2000 Server, 
with this hard drive, because during the installation, these areas with bad 
blocks would be marked unused and continues and have no problems after the 
installation.

Hmm don't know why Redhat 7.3, can't continue and finish the setup?

Is there a way to by-pass this error? I installed Redhat 6.2 without any 
problems before. I can reinstall RedHAt 6.2 and upgrade to 7.3, but it's gonna 
be a long process. I just like a fresh install with RedHat 7.3 not an upgrade.

At the moment, i'm trying to write zeros to the hard drive and do a low-level 
format, trying to kill that bad blocks or make unusable area of some sort.


Regards,

Daniel


Note You need to log in before you can comment on or make changes to this bug.