Bug 66181 - anaconda crashes during badblock check on full install
anaconda crashes during badblock check on full install
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.3
i386 Linux
high Severity high
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
: 64711 66135 66199 66714 66757 66812 66817 66922 66925 67019 67393 67556 68337 69748 69757 69941 70012 70015 70037 70044 70075 70092 70519 70664 70742 70823 71049 71321 71591 71597 71753 71883 72365 72796 72830 72945 73182 73541 73666 73725 73798 74082 74216 74495 74642 74768 74966 75445 75545 76398 76679 77046 77982 78062 78595 78798 78918 79051 86160 103827 (view as bug list)
Depends On: 66234
Blocks:
  Show dependency treegraph
 
Reported: 2002-06-05 18:16 EDT by Bruce Link
Modified: 2005-10-31 17:00 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-29 12:08:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Anaconda dump file (59.66 KB, text/plain)
2002-06-05 18:17 EDT, Bruce Link
no flags Details
anaconda dump file (57.20 KB, text/plain)
2002-06-08 04:57 EDT, major
no flags Details
Anaconda dump (77.72 KB, text/plain)
2002-06-27 15:32 EDT, Kevin R. Page
no flags Details

  None (edit)
Description Bruce Link 2002-06-05 18:16:26 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.4.1)
Gecko/20020508 Netscape6/6.2.3

Description of problem:
When installing RedHat 7.3 from verified CDs, the install crashed when checking
the partitions for bad blocks.  System is pc pentiumII with separate partitions
for / /var /usr /home swap, all on second hard drive.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.select defaults upto disk partitioning
2.partition second disk hdb1=/boot hdb2=swap hdb3=/var hdb4=extended partition
hdb5=/ hdb6=/home hdb7=/usr
3.in diskdruid, select to format all non swap partitions to ext3 and check blocks
4. select custom install and a bunch of packages
5. install
	

Actual Results:  installation crashes when checking /dev/hdb7 for bad blocks,
see info below.

Expected Results:  System should have installed successfully.

Additional info:

Bug is similar to # 64847 but crashes one line earlier with different error.
Comment 1 Bruce Link 2002-06-05 18:17:32 EDT
Created attachment 59804 [details]
Anaconda dump file
Comment 2 Michael Fulbright 2002-06-06 11:44:27 EDT
This has been reported - assigning to an engineer.

If you skip the bad block check it should work ok.
Comment 3 major 2002-06-08 04:57:53 EDT
Created attachment 60164 [details]
anaconda dump file
Comment 4 Jeremy Katz 2002-06-14 03:57:52 EDT
*** Bug 66714 has been marked as a duplicate of this bug. ***
Comment 5 Michael Fulbright 2002-06-17 17:28:02 EDT
This error occurs when the badblocks command detects bad blocks on the system. 
The traceback occurred because the output from the badblocks command has
changed, fooling our parser.

If you get this traceback it means you have bad blocks on the drive it was testing.

In the future an error dialog will be presented saying bad blocks have been
detected.
Comment 6 Michael Fulbright 2002-06-17 17:31:08 EDT
*** Bug 64711 has been marked as a duplicate of this bug. ***
Comment 7 Michael Fulbright 2002-06-17 17:31:19 EDT
*** Bug 66135 has been marked as a duplicate of this bug. ***
Comment 8 Michael Fulbright 2002-06-17 17:31:34 EDT
*** Bug 66199 has been marked as a duplicate of this bug. ***
Comment 9 Michael Fulbright 2002-06-17 17:31:43 EDT
*** Bug 66568 has been marked as a duplicate of this bug. ***
Comment 10 Michael Fulbright 2002-06-17 17:31:56 EDT
*** Bug 66757 has been marked as a duplicate of this bug. ***
Comment 11 Michael Fulbright 2002-06-17 17:32:07 EDT
*** Bug 66812 has been marked as a duplicate of this bug. ***
Comment 12 Michael Fulbright 2002-06-17 17:32:22 EDT
*** Bug 66817 has been marked as a duplicate of this bug. ***
Comment 13 Michael Fulbright 2002-06-20 11:02:19 EDT
*** Bug 66922 has been marked as a duplicate of this bug. ***
Comment 14 Michael Fulbright 2002-06-20 11:03:03 EDT
*** Bug 66925 has been marked as a duplicate of this bug. ***
Comment 15 Michael Fulbright 2002-06-26 01:09:19 EDT
*** Bug 67393 has been marked as a duplicate of this bug. ***
Comment 16 Michael Fulbright 2002-06-26 01:29:43 EDT
*** Bug 67019 has been marked as a duplicate of this bug. ***
Comment 17 Kevin R. Page 2002-06-27 14:58:08 EDT
I am also experiencing this problem, though I am sceptical that the badblocks 
causing the error are "real".

I am creating software RAID 1 mounts, and for each mount point if I include a 
badblocks check one of the drives fails on its constituent partition (a Seagate 
Barracuda IV 40GB).

Each time a badblock is reported on the <F5> console, an "attempt to access 
beyond end of device" error is reported on the <F4> console. It always the last 
block in the partition (which doesn't seem to trigger the anaconda bug) or last 
two blocks in the partition (which does).

Note that it's always the last few blocks even if I change the partition sizes 
in the partition table! (I would have presumed that physical bad blocks would 
map to different parts of (different) partitions in this case).

This might tie in with problems I've seen before with these sorts of errors and 
related ext3 errors on the old 7.2 install on the same machine. Indeed these 
errors were the reason I opted to go with a complete repartition and reinstall 
rather than an upgrade to 7.3.

For these reasons I am _very_ unhappy about just turning the badblock check 
off - I'm suspicious that the partition sizes are being incorrectly assigned - 
and I feal that if I skip the check it'll come back later to bite me.

If you can give me instructions on how to set the partitions sizes to be a few 
blocks smaller than wanted, I could see if this cures the problem.
Comment 18 Kevin R. Page 2002-06-27 15:32:47 EDT
Created attachment 62924 [details]
Anaconda dump
Comment 19 Jeremy Katz 2002-06-28 01:56:17 EDT
*** Bug 67556 has been marked as a duplicate of this bug. ***
Comment 20 Kevin R. Page 2002-07-08 17:56:09 EDT
ok, I think I now know why I was getting bad blocks - see bug #67949 - I don't
believe it was due to bad discs.

Doesn't solve this particular bug, but may be useful as a pointer if you
encounter  bad blocks consistently at the end of a partition typed raid autodetect.
Comment 21 Michael Fulbright 2002-07-10 15:00:23 EDT
*** Bug 68337 has been marked as a duplicate of this bug. ***
Comment 22 Need Real Name 2002-07-25 11:41:32 EDT
I've also had anaconda abort on me doing a RH 7.3 install, however I did NOT get
the same error message as listed in the dumps here. Unfortunately, the system
this has happened on has no floppy drive, so getting a copy of the entire dump
is a bit hellacious.

Scenario: Rave intel 2U box, two 40gig IDE drives. Partionined for software raid
with the following scheme:
  /boot - 256megs
  swap  - 256megs
  /     - 1 gig
  /tmp  - 1 gig
  /home - 4 gig
  /usr  - 6 gig
  /usr/local - 6 gig
  /var  - remaining space (about 20 gig)

I setup the same partitions on both IDE drives (as software raid type), then
setup the RAID partitions as level 1. In all cases I indicated to check for bad
blocks.

I'm not sure which partition the error occured on but it was after succesfully
checking at leas the first 2 partitions. The dump had an error message about
"Integer lital too long".

I suspect that in my case, the problem was the partition it was supposed to
bad-block check was bigger than allowed for. the crash may have even just been
in the code for rendering the progress display.
Comment 23 Need Real Name 2002-07-26 09:18:13 EDT
I copied down the most relevant bits of the crash I got mentioned above. On the
F4 virtual screen this was the last error messag elisted:

  <6>Attempt to access beyond end of device
  <6>03:45: rw=0, want=4096544, limit=4096543

In the primary display, the innermost error from the installation script was
listed as so:

  File "/usr/lib/anaconda/fsset.py" line 211, in badblocksDevice
  ValueError: invalid literal too long(): 4096540
    4096541

Which at least to me looks like a case of a scripting error, ie. not allowing
for badblock checks of very large partitions. At a guess, anyways, i'm not at
all familiar with Python.

Skipping the badblock test did allow me to install with no problem. However,
that's a poor solution, :(
Comment 24 Michael Fulbright 2002-08-02 12:24:12 EDT
*** Bug 70075 has been marked as a duplicate of this bug. ***
Comment 25 Michael Fulbright 2002-08-02 12:25:23 EDT
*** Bug 70012 has been marked as a duplicate of this bug. ***
Comment 26 Michael Fulbright 2002-08-02 12:27:18 EDT
*** Bug 70519 has been marked as a duplicate of this bug. ***
Comment 27 Michael Fulbright 2002-08-02 14:25:05 EDT
*** Bug 70092 has been marked as a duplicate of this bug. ***
Comment 28 Michael Fulbright 2002-08-02 14:27:25 EDT
*** Bug 70044 has been marked as a duplicate of this bug. ***
Comment 29 Michael Fulbright 2002-08-02 14:27:55 EDT
*** Bug 70037 has been marked as a duplicate of this bug. ***
Comment 30 Michael Fulbright 2002-08-02 14:30:18 EDT
*** Bug 70015 has been marked as a duplicate of this bug. ***
Comment 31 Michael Fulbright 2002-08-02 14:36:00 EDT
*** Bug 69941 has been marked as a duplicate of this bug. ***
Comment 32 Michael Fulbright 2002-08-02 14:51:23 EDT
*** Bug 69757 has been marked as a duplicate of this bug. ***
Comment 33 Michael Fulbright 2002-08-02 14:52:06 EDT
*** Bug 69748 has been marked as a duplicate of this bug. ***
Comment 34 Michael Fulbright 2002-08-05 11:33:43 EDT
*** Bug 70742 has been marked as a duplicate of this bug. ***
Comment 35 Michael Fulbright 2002-08-05 11:36:14 EDT
*** Bug 70664 has been marked as a duplicate of this bug. ***
Comment 36 Michael Fulbright 2002-08-12 15:13:25 EDT
*** Bug 71321 has been marked as a duplicate of this bug. ***
Comment 37 Michael Fulbright 2002-08-12 16:23:21 EDT
*** Bug 71049 has been marked as a duplicate of this bug. ***
Comment 38 Michael Fulbright 2002-08-12 17:28:13 EDT
*** Bug 70823 has been marked as a duplicate of this bug. ***
Comment 39 Michael Fulbright 2002-08-15 12:16:44 EDT
*** Bug 71591 has been marked as a duplicate of this bug. ***
Comment 40 Michael Fulbright 2002-08-15 12:21:33 EDT
*** Bug 71597 has been marked as a duplicate of this bug. ***
Comment 41 Michael Fulbright 2002-08-19 12:01:49 EDT
*** Bug 71753 has been marked as a duplicate of this bug. ***
Comment 42 Michael Fulbright 2002-08-22 12:57:19 EDT
*** Bug 71883 has been marked as a duplicate of this bug. ***
Comment 43 Michael Fulbright 2002-08-23 11:29:19 EDT
*** Bug 72365 has been marked as a duplicate of this bug. ***
Comment 44 Michael Fulbright 2002-08-28 13:06:34 EDT
*** Bug 72830 has been marked as a duplicate of this bug. ***
Comment 45 Michael Fulbright 2002-08-28 13:08:45 EDT
*** Bug 72796 has been marked as a duplicate of this bug. ***
Comment 46 Michael Fulbright 2002-08-29 12:08:17 EDT
*** Bug 72945 has been marked as a duplicate of this bug. ***
Comment 47 Mike McLean 2002-08-29 17:14:37 EDT
I'm not having any problems using the badblocks check with latest trees
CLOSED->RAWHIDE
Comment 48 Michael Fulbright 2002-09-02 11:18:32 EDT
*** Bug 73182 has been marked as a duplicate of this bug. ***
Comment 49 Michael Fulbright 2002-09-16 13:13:09 EDT
*** Bug 74082 has been marked as a duplicate of this bug. ***
Comment 50 Michael Fulbright 2002-09-16 14:42:04 EDT
*** Bug 73798 has been marked as a duplicate of this bug. ***
Comment 51 Michael Fulbright 2002-09-16 15:22:35 EDT
*** Bug 73725 has been marked as a duplicate of this bug. ***
Comment 52 Michael Fulbright 2002-09-16 17:19:54 EDT
*** Bug 73666 has been marked as a duplicate of this bug. ***
Comment 53 Michael Fulbright 2002-09-17 15:51:45 EDT
*** Bug 73541 has been marked as a duplicate of this bug. ***
Comment 54 Michael Fulbright 2002-09-20 15:09:20 EDT
*** Bug 73182 has been marked as a duplicate of this bug. ***
Comment 55 Michael Fulbright 2002-09-27 15:20:39 EDT
*** Bug 74495 has been marked as a duplicate of this bug. ***
Comment 56 Michael Fulbright 2002-09-30 15:53:37 EDT
*** Bug 74642 has been marked as a duplicate of this bug. ***
Comment 57 Michael Fulbright 2002-10-01 14:44:08 EDT
*** Bug 74768 has been marked as a duplicate of this bug. ***
Comment 58 Jeremy Katz 2002-10-09 11:42:13 EDT
*** Bug 75445 has been marked as a duplicate of this bug. ***
Comment 59 Jeremy Katz 2002-10-14 10:56:00 EDT
*** Bug 75545 has been marked as a duplicate of this bug. ***
Comment 60 Michael Fulbright 2002-10-23 15:45:38 EDT
*** Bug 76398 has been marked as a duplicate of this bug. ***
Comment 61 Michael Fulbright 2002-10-24 15:04:18 EDT
*** Bug 74216 has been marked as a duplicate of this bug. ***
Comment 62 Michael Fulbright 2002-10-30 17:42:26 EST
*** Bug 76679 has been marked as a duplicate of this bug. ***
Comment 63 Michael Fulbright 2002-10-30 17:43:55 EST
*** Bug 74966 has been marked as a duplicate of this bug. ***
Comment 64 Michael Fulbright 2002-10-31 12:45:08 EST
*** Bug 77046 has been marked as a duplicate of this bug. ***
Comment 65 Michael Fulbright 2002-11-18 15:28:52 EST
*** Bug 78062 has been marked as a duplicate of this bug. ***
Comment 66 Michael Fulbright 2002-11-18 15:35:57 EST
*** Bug 77982 has been marked as a duplicate of this bug. ***
Comment 67 Michael Fulbright 2002-11-26 17:15:12 EST
*** Bug 78595 has been marked as a duplicate of this bug. ***
Comment 68 Michael Fulbright 2002-12-02 11:00:13 EST
*** Bug 78798 has been marked as a duplicate of this bug. ***
Comment 69 Michael Fulbright 2002-12-03 12:27:38 EST
*** Bug 78918 has been marked as a duplicate of this bug. ***
Comment 70 Michael Fulbright 2002-12-06 12:26:06 EST
*** Bug 79051 has been marked as a duplicate of this bug. ***
Comment 71 Michael Fulbright 2002-12-20 12:38:25 EST
Time tracking values updated
Comment 72 Michael Fulbright 2003-03-17 14:16:54 EST
*** Bug 86160 has been marked as a duplicate of this bug. ***
Comment 73 Timothy Bowers 2003-03-17 19:46:35 EST
Additional Comment #47 (dated last August) states that this bug has been closed,
and yet this bug is still very active.  I was unable to install RedHat 7.3 using
images downloaded last month, so what does "resolved" mean if the bug is still
veryt much alive and well (bug #86160)?
Comment 74 Michael Fulbright 2003-03-21 11:00:20 EST
*** Bug 86160 has been marked as a duplicate of this bug. ***
Comment 75 Mike McLean 2003-09-05 11:45:42 EDT
*** Bug 103827 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.