Bug 669850 - Libvirt can not start qemu VM with qxl support
Libvirt can not start qemu VM with qxl support
Status: CLOSED DUPLICATE of bug 664192
Product: Fedora
Classification: Fedora
Component: qemu (Show other bugs)
Unspecified Unspecified
low Severity medium
: ---
: ---
Assigned To: Justin M. Forbes
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2011-01-14 20:58 EST by Mikhail Kulemin
Modified: 2013-01-09 06:44 EST (History)
15 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2011-01-21 08:15:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
Patch for qemu package (481 bytes, patch)
2011-01-15 14:58 EST, Mikhail Kulemin
no flags Details | Diff
failing domain (2.00 KB, text/xml)
2011-01-29 06:37 EST, Julian Sikorski
no flags Details

  None (edit)
Description Mikhail Kulemin 2011-01-14 20:58:34 EST
Description of problem:

Libvirt can not start VM with qxl graphics.

Version-Release number of selected component (if applicable):

libvirt 0.8.7-1.fc14 from virt-preview repo
qemu 0.13.0-1.fc14

How reproducible:

Steps to Reproduce:

1. Create domain with qxl graphics:
(from XML description):
      <model type='qxl' heads='1'/>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x02' function='0x0'/>

2. Try to start virsh start <domain>
Actual results:
error: Failed to start domain WindowsXP
error: unsupported configuration: This QEMU does not support QXL graphics adapters

Expected results:
Domain started normally.

Additional info:
This build of qemu supports qxl: VM can be started manually using qemu command:

qemu-kvm -m 1024 -drive file=/dev/vg_virt/fedora14 -monitor stdio -spice port=1234,disable-ticketing -vga qxl

But libvirt check qxl support using qemu-kvm --help. In output we can not find qxl in supported modes list:

home ~ $ qemu-kvm --help | grep vga
-vga [std|cirrus|vmware|xenfb|none]

So this bug can be fixed by adding qxl in help output of qemu.
Comment 1 Mikhail Kulemin 2011-01-15 14:58:54 EST
Created attachment 473665 [details]
Patch for qemu package

Patch in attachment fix this bug in qemu.
Comment 2 Pavel Zhukov 2011-01-21 08:15:39 EST

*** This bug has been marked as a duplicate of bug 664192 ***
Comment 3 Julian Sikorski 2011-01-29 06:37:09 EST
Created attachment 475939 [details]
failing domain

With this package and libvirt from virt-preview repo the domain (attached) still won't start:
# LANG=C virsh start windows
error: Failed to start domain windows
error: wewnętrzny błąd Zakończono proces podczas odczytywania wyjścia dziennika console: qemu-kvm: -spice port=5900,addr=,disable-ticketing: Invalid parameter 'addr'
parse error: port=5900,addr=,disable-ticketing

Note You need to log in before you can comment on or make changes to this bug.