Bug 664192 - Error testing qemu qxl support
Error testing qemu qxl support
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: qemu (Show other bugs)
14
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Justin M. Forbes
Fedora Extras Quality Assurance
:
: 669850 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-12-18 20:10 EST by Amador Pahim
Modified: 2013-01-09 06:44 EST (History)
20 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-02-24 04:28:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch for qemu package to fixing help messsages (482 bytes, application/octet-stream)
2011-01-21 08:19 EST, Mikhail Kulemin
no flags Details
failing domain (2.00 KB, text/xml)
2011-01-29 06:39 EST, Julian Sikorski
no flags Details
final patch version (1.62 KB, patch)
2011-01-30 19:04 EST, Julian Sikorski
no flags Details | Diff

  None (edit)
Description Amador Pahim 2010-12-18 20:10:08 EST
Description of problem:
Running libvirt 0.8.6, spice parameters does not work

Version-Release number of selected component:
0.8.6

Steps to Reproduce:
Change the VM video device from:
    <video>
      <model type='cirrus' vram='9216' heads='1'/>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x02' function='0x0'/>
    </video>
to:
     <video>
      <model type='qxl' heads='1'/>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x02' function='0x0'/>
    </video>

Try to start VM with:
# virsh start Ubuntu

Actual results:
error: Failed to start domain Ubuntu
error: unsupported configuration: This QEMU does not support QXL graphics adapters

Expected results:
Domain Ubuntu started

Additional info:
To skip this test, I had to edit the "src/qemu/qemu_command.c", in libvirt source, commenting this lines:

/*   if ((def->videos[0]->type == VIR_DOMAIN_VIDEO_TYPE_QXL) &&
 *    !(qemuCmdFlags & QEMUD_CMD_FLAG_VGA_QXL)) {
 *    qemuReportError(VIR_ERR_CONFIG_UNSUPPORTED, "%s",
 *                    _("This QEMU does not support QXL graphics adapters"));
 *    goto error;
 *   } 
 */
Comment 1 Amador Pahim 2010-12-20 06:19:49 EST
Going deeper in this problem, I saw qemu does not show the vga qxl capability in help:

[root@pahim-pc libvirt]# qemu --version
QEMU emulator version 0.13.0 (qemu-kvm-0.13.0), Copyright (c) 2003-2008 Fabrice Bellard

[root@pahim-pc libvirt]# qemu -help | grep vga
-vga [std|cirrus|vmware|xenfb|none]

I think libvirt is OK, but qemu needs to show the correct information about capabilities.
Comment 2 Pavel Zhukov 2011-01-21 08:15:39 EST
*** Bug 669850 has been marked as a duplicate of this bug. ***
Comment 3 Mikhail Kulemin 2011-01-21 08:19:56 EST
Created attachment 474624 [details]
Patch for qemu package to fixing help messsages
Comment 4 Pavel Zhukov 2011-01-21 09:58:40 EST
koji build with michail's patch
https://koji.fedoraproject.org/koji/taskinfo?taskID=2734866
mock: ok

minor changes (only list of vga has been corrected, not more)
SRPM: http://landgraf.fedorapeople.org/qemu-0.13.0-2.fc14.src.rpm

please push it to updates
Comment 5 Julian Sikorski 2011-01-29 06:39:02 EST
Created attachment 475940 [details]
failing domain

Sorry for posting this twice but I clicked the wrong bug initially. With this package and libvirt from virt-preview repo the domain (attached) won't start:
# LANG=C virsh start windows
error: Failed to start domain windows
error: wewnętrzny błąd Zakończono proces podczas odczytywania wyjścia dziennika
console: qemu-kvm: -spice port=5900,addr=127.0.0.1,disable-ticketing: Invalid
parameter 'addr'
parse error: port=5900,addr=127.0.0.1,disable-ticketing
Comment 6 Mikhail Kulemin 2011-01-29 08:01:20 EST
This bug explain problem:
https://bugzilla.redhat.com/show_bug.cgi?id=664190

With patched libvirt spice works well.
Comment 7 Pavel Zhukov 2011-01-29 08:02:37 EST
"addr" parse error is a bug of libvirt, not qemu. 
qemu "spice" section hasn't "addr" option.
Comment 8 Mikhail Kulemin 2011-01-29 08:11:43 EST
It should be noted that in the last development version of qemu we can find "addr" option in spice parameters. So, I hope that in next update of qemu (In virt preview repo) that issue will be fixed.
Comment 9 Julian Sikorski 2011-01-30 19:04:10 EST
Created attachment 476098 [details]
final patch version

This patch disables the failing test so that the srpm can actually be rebuilt.
Comment 10 Julian Sikorski 2011-01-30 19:07:24 EST
Comment on attachment 476098 [details]
final patch version

Oops wrong bug...
Comment 11 Julian Sikorski 2011-02-11 18:21:13 EST
Looks like the problem is fixed in version 2:0.14.0-0.1.201102107aa8c46.fc14 which recently appeared in the virt-preview repo.
Comment 12 Pavel Zhukov 2011-02-24 04:28:35 EST
The problem fixed in rawhide.

Note You need to log in before you can comment on or make changes to this bug.