Bug 67007 - libpng has file libpng.so.3, but doesn't "Provide:" it
libpng has file libpng.so.3, but doesn't "Provide:" it
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: libpng (Show other bugs)
1.0
All Linux
low Severity medium
: ---
: ---
Assigned To: Jonathan Blandford
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-06-19 10:34 EDT by Moritz Barsnick
Modified: 2013-04-02 00:16 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-02-20 13:09:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Moritz Barsnick 2002-06-19 10:34:16 EDT
Description of Problem:


Installing a newer version of libpng(12), while having older
packages which requires libpng.so.3, rpm refuses to install it
(without --nodeps). This is despite the fact that the new
libpng12 RPM has a file libpng.so.3 which is a symlink to the
newly named libpng12.so.0.



Version-Release number of selected component (if applicable):



libpng-1.2.2-5


How Reproducible:



Always when not doing a full RawHide update, but just of libpng


Steps to Reproduce:

1. 
iInstall  older packages relying on libpng.so.3
2. 
Try to install libpng-1.2.2-5


Actual Results:



Fails due to dependencies (requirement of libpng.so.3


Expected Results:



Successfully install without warning or error.


Additional Information:

	

It's a simple problem: libpng.so.3 is provided as
backward compatibility to the "old" naming scheme,
which has been replaced by libpng12.so.0. The provided
symlink is not recognized by "find-provides" (which
checks sonames only, obviously). All you need is a line
"Provides: libpng.so.3" as long as this symlink is
being delivered. I had (would've had) to rebuild quite
a few packages (of my own) to fix this dependency,
despite the delivered backward compat symlink.
Comment 1 Moritz Barsnick 2002-06-19 10:36:10 EDT
Oh, this is a bit of a dupe of bug #64646, by the way.
Comment 2 Jonathan Blandford 2003-02-19 22:44:12 EST

*** This bug has been marked as a duplicate of 64646 ***
Comment 3 Moritz Barsnick 2003-02-20 04:24:21 EST
Nice try, marking as duplicate but solving only the wrong part of the dupe.  ;-) 
"libpng.so.3" is still not provided by the package, despite its symlink being 
delivered. Though I know that "libpng12.so.0" is the new naming scheme used by 
most distributions, this still breaks legacy packages requiring "libpng.so.3".




I'd like to reopen this bug, but can't (haven't got my old account's password 
handy right now, and can't have one mailed there either. ;->)




(In the dupe, only the old gcc2.96 naming scheme was fixed, AFAICT.)




Thanks for listening,


Moritz
Comment 4 Jonathan Blandford 2003-02-20 12:42:15 EST
Whoops.  Didn't read it carefully enough.  Sorry about that.
Comment 5 Jonathan Blandford 2003-02-20 13:09:40 EST
Alright.  Now it's fixed in rawhide. (-;

Note You need to log in before you can comment on or make changes to this bug.