Bug 670271 - build issue: fix warnings from AC_COMPILE_IFELSE
build issue: fix warnings from AC_COMPILE_IFELSE
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: spice-client (Show other bugs)
6.1
Unspecified Unspecified
low Severity medium
: rc
: ---
Assigned To: Hans de Goede
Desktop QE
:
Depends On:
Blocks: 671383
  Show dependency treegraph
 
Reported: 2011-01-17 13:24 EST by Alon Levy
Modified: 2014-08-04 18:08 EDT (History)
4 users (show)

See Also:
Fixed In Version: spice-client-0.7.2-1.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-05-19 09:15:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alon Levy 2011-01-17 13:24:12 EST
When building spice we get warnings because we don't use AC_LANG_SOURCE
which has become required when using AC_COMPILE_IFELSE. Fix sent upstream:

http://lists.freedesktop.org/archives/spice-devel/2011-January/002201.html


Version-Release number of selected component (if applicable):
0.7.1

How reproducible:
Always (build issue)

Steps to Reproduce:
1. run ./configure
2.
3.
  
Actual results:
warnings about missing AC_LANG_SOURCE

Expected results:
no warnings

Additional info:
This removes the last warnings (atm).
Comment 2 Uri Lublin 2011-01-19 10:21:54 EST
(In reply to comment #0)
> Actual results:
> warnings about missing AC_LANG_SOURCE

Actually this warning is only shown on Fedora 15, but the fix is correct.
Comment 3 Hans de Goede 2011-01-25 08:52:08 EST
A new spice-client-0.7.2-1.el6 fixing this has been build, moving to modified.
Comment 6 errata-xmlrpc 2011-05-19 09:15:22 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-0583.html

Note You need to log in before you can comment on or make changes to this bug.