Bug 670597 - firstboot subscription search bug
Summary: firstboot subscription search bug
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager
Version: 6.1
Hardware: Unspecified
OS: Unspecified
low
medium
Target Milestone: rc
: ---
Assignee: Jesus M. Rodriguez
QA Contact: J.C. Molet
URL:
Whiteboard:
: 670794 (view as bug list)
Depends On:
Blocks: Entitlement-Beta
TreeView+ depends on / blocked
 
Reported: 2011-01-18 18:41 UTC by J.C. Molet
Modified: 2011-05-19 13:38 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-05-19 13:38:56 UTC
Target Upstream Version:


Attachments (Terms of Use)
firstboot crash report (42.51 KB, text/xml)
2011-01-18 18:41 UTC, J.C. Molet
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2011:0611 normal SHIPPED_LIVE new package: subscription-manager 2011-05-18 17:56:21 UTC

Description J.C. Molet 2011-01-18 18:41:09 UTC
Created attachment 474125 [details]
firstboot crash report

Description of problem:
Firstboot crashes when searching for a subscription.

Version-Release number of selected component (if applicable):
subscription-manager-gnome-0.93.13-1.el6.x86_64
python-rhsm-0.94.15-1.el6.noarch
subscription-manager-0.93.13-1.el6.x86_64
subscription-manager-firstboot-0.93.13-1.el6.x86_64
firstboot-1.110.8-1.el6.x86_64

rhel entitlement beta: http://download.lab.bos.redhat.com/devel/candidates/RHEL6.1-20110118.0/6/Server/x86_64/os/

How reproducible:
always

Steps to Reproduce:
1. Install latest rhel entitlement beta compose
2. Proceed through firstboot, registering with rhsm
3. After registered, go to the "available subscriptions" tab
4. Update the search
  
Actual results:
Clicking update spawns the progress bar and then crashes.

Expected results:
Clicking update displays search results.

Additional info:
see attached crash report.

Comment 1 Jesus M. Rodriguez 2011-01-20 20:13:16 UTC
In firstboot, the registration and mainwindow screens are created
simultaneously at startup. Both contain a Consumer object. The
registration screen will reload it with the identity certificate
after registration, but the mainwindow instance is not updated.
Firstboot will call initializeUI method on the screen transition
which in turn calls the refresh() method on MainWindow which is
a good location for reloading its instance of Consumer.

Comment 2 Jesus M. Rodriguez 2011-01-20 20:42:59 UTC
*** Bug 670794 has been marked as a duplicate of this bug. ***

Comment 4 J.C. Molet 2011-01-21 21:04:09 UTC
This is now working as of the latest compose: RHEL6.1-20110121.0

The steps in the description were run, a search list was brought down and subscribed to successfully.

Comment 5 errata-xmlrpc 2011-05-19 13:38:56 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2011-0611.html


Note You need to log in before you can comment on or make changes to this bug.