Bug 671294 - geforce 6600 / nouveau - mutter crashes
geforce 6600 / nouveau - mutter crashes
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-nouveau (Show other bugs)
rawhide
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Ben Skeggs
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F15GNOMEfail
  Show dependency treegraph
 
Reported: 2011-01-20 22:00 EST by Vlad
Modified: 2011-02-22 10:15 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-02-22 10:15:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Vlad 2011-01-20 22:00:28 EST
Description of problem:
Can't load gnome-shell.

Version-Release number of selected component (if applicable):
gnome-shell.x86_64 2.91.5-3.fc15
mutter.x86_64 2.91.5-1.fc15
xorg-x11-drv-nouveau.x86_64 1:0.0.16-17.20110117git38e8809.fc15
mesa-dri-drivers.i686 7.10-0.24.fc15
mesa-dri-drivers.x86_64 7.10-0.24.fc15                                                                    
mesa-dri-filesystem.i686 7.10-0.24.fc15                                                                  
mesa-dri-filesystem.x86_64 7.10-0.24.fc15                                                                      
mesa-dri-llvmcore.i686 7.10-0.24.fc15                                                                    
mesa-dri-llvmcore.x86_64 7.10-0.24.fc15                                                                             
mesa-libGL.i686 7.10-0.24.fc15                                                                           
mesa-libGL.x86_64 7.10-0.24.fc15                                                                     
mesa-libGL-devel.x86_64 7.10-0.24.fc15                                                                            
mesa-libGLU.i686 7.10-0.24.fc15
mesa-libGLU.x86_64 7.10-0.24.fc15
mesa-libGLU-devel.x86_64 7.10-0.24.fc15  

How reproducible:
Every time.

Steps to Reproduce:
1. Enable 3d acceleration on nouveau.
2. Login in graphic session.
  
Actual results:
Empty screen with wallpaper only.

Expected results:
Appearance of gnome-shell

Additional info:
Some logs from /var/log/messages:
Jan 21 09:25:46 localhost kernel: [  195.252381] mutter[2505] trap int3 ip:305864c159 sp:7fff26b766b0 error:0
Jan 21 09:25:47 localhost kernel: [  196.162969] mutter[2613] trap int3 ip:305864c159 sp:7fff79212ae0 error:0
Jan 21 09:25:48 localhost kernel: [  196.380734] mutter[2627] trap int3 ip:305864c159 sp:7fff382a0a50 error:0
Jan 21 09:25:48 localhost kernel: [  196.606892] mutter[2634] trap int3 ip:305864c159 sp:7fffb3a79c10 error:0
Jan 21 09:25:48 localhost kernel: [  196.830370] mutter[2645] trap int3 ip:305864c159 sp:7ffff79484e0 error:0
Jan 21 09:25:48 localhost kernel: [  197.057928] mutter[2669] trap int3 ip:305864c159 sp:7fff428ec6b0 error:0
Jan 21 09:25:49 localhost kernel: [  197.295171] mutter[2681] trap int3 ip:305864c159 sp:7fff288ff170 error:0
Jan 21 09:25:49 localhost kernel: [  197.519413] mutter[2736] trap int3 ip:305864c159 sp:7fff76e85cb0 error:0
Jan 21 09:25:51 localhost kernel: [  199.719510] do_trap: 9 callbacks suppressed
Jan 21 09:25:51 localhost kernel: [  199.719515] mutter[2902] trap int3 ip:305864c159 sp:7fff1af95350 error:0
Jan 21 09:25:51 localhost kernel: [  199.940616] mutter[2909] trap int3 ip:305864c159 sp:7fff1476ead0 error:0
Jan 21 09:25:51 localhost kernel: [  200.159305] mutter[2916] trap int3 ip:305864c159 sp:7fff40863bd0 error:0
Jan 21 09:25:52 localhost kernel: [  200.382576] mutter[2923] trap int3 ip:305864c159 sp:7fffe2d367e0 error:0
Jan 21 09:25:52 localhost kernel: [  200.602753] mutter[2978] trap int3 ip:305864c159 sp:7fff32f54410 error:0
Jan 21 09:25:52 localhost kernel: [  200.821716] mutter[2985] trap int3 ip:305864c159 sp:7fffd093d890 error:0
Jan 21 09:25:52 localhost kernel: [  201.038081] mutter[2992] trap int3 ip:305864c159 sp:7fff2b5e8ac0 error:0
Jan 21 09:25:52 localhost kernel: [  201.256754] mutter[2999] trap int3 ip:305864c159 sp:7fff8e284810 error:0
Jan 21 09:25:53 localhost kernel: [  201.506961] mutter[3015] trap int3 ip:305864c159 sp:7fff03a65610 error:0
Jan 21 09:25:53 localhost kernel: [  201.725853] mutter[3022] trap int3 ip:305864c159 sp:7fff804fbcf0 error:0
Jan 21 09:25:56 localhost kernel: [  205.016000] do_trap: 14 callbacks suppressed
Jan 21 09:25:56 localhost kernel: [  205.016045] mutter[3129] trap int3 ip:305864c159 sp:7ffff10a8e90 error:0
Jan 21 09:25:56 localhost kernel: [  205.236576] mutter[3136] trap int3 ip:305864c159 sp:7fffa1566f80 error:0
Jan 21 09:25:57 localhost kernel: [  205.455188] mutter[3143] trap int3 ip:305864c159 sp:7fff10d288c0 error:0
Jan 21 09:25:57 localhost kernel: [  205.672916] mutter[3150] trap int3 ip:305864c159 sp:7fff163d4530 error:0
Jan 21 09:25:57 localhost kernel: [  205.893497] mutter[3157] trap int3 ip:305864c159 sp:7fff79cf13a0 error:0
Jan 21 09:25:57 localhost kernel: [  206.112542] mutter[3164] trap int3 ip:305864c159 sp:7fffcb1b6c20 error:0
Jan 21 09:25:58 localhost kernel: [  206.332247] mutter[3171] trap int3 ip:305864c159 sp:7fff7d8fc620 error:0
Jan 21 09:25:58 localhost kernel: [  206.551543] mutter[3179] trap int3 ip:305864c159 sp:7fffa88032c0 error:0
Jan 21 09:25:58 localhost kernel: [  206.769932] mutter[3186] trap int3 ip:305864c159 sp:7fff41e18d50 error:0
Jan 21 09:25:58 localhost kernel: [  206.994423] mutter[3193] trap int3 ip:305864c159 sp:7fff0f151b20 error:0
Jan 21 09:26:01 localhost ntpd_intres[1092]: host name not found: 0.fedora.pool.ntp.org
Jan 21 09:26:01 localhost ntpd_intres[1092]: host name not found: 1.fedora.pool.ntp.org
Jan 21 09:26:01 localhost ntpd_intres[1092]: host name not found: 2.fedora.pool.ntp.org
Jan 21 09:26:01 localhost ntpd_intres[1092]: host name not found: 3.fedora.pool.ntp.org
Jan 21 09:26:02 localhost kernel: [  210.290412] do_trap: 14 callbacks suppressed
Jan 21 09:26:02 localhost kernel: [  210.290417] mutter[3299] trap int3 ip:305864c159 sp:7fff2c13d330 error:0
Jan 21 09:26:02 localhost kernel: [  210.517124] mutter[3306] trap int3 ip:305864c159 sp:7fff96fdfba0 error:0
Jan 21 09:26:02 localhost kernel: [  210.733910] mutter[3313] trap int3 ip:305864c159 sp:7fff50ac2e00 error:0
Jan 21 09:26:02 localhost kernel: [  210.950855] mutter[3320] trap int3 ip:305864c159 sp:7fff52d6e4e0 error:0
Jan 21 09:26:02 localhost kernel: [  211.176200] mutter[3327] trap int3 ip:305864c159 sp:7fff2a2ce660 error:0
Jan 21 09:26:03 localhost kernel: [  211.395273] mutter[3334] trap int3 ip:305864c159 sp:7fff63c54430 error:0
Jan 21 09:26:03 localhost kernel: [  211.615114] mutter[3341] trap int3 ip:305864c159 sp:7fffe6980d10 error:0
Jan 21 09:26:03 localhost kernel: [  211.834521] mutter[3348] trap int3 ip:305864c159 sp:7fff3e8e8ef0 error:0
Jan 21 09:26:03 localhost kernel: [  212.054240] mutter[3355] trap int3 ip:305864c159 sp:7fff667d4500 error:0
Jan 21 09:26:04 localhost kernel: [  212.273951] mutter[3362] trap int3 ip:305864c159 sp:7fff93255070 error:0
Jan 21 09:26:06 localhost kernel: [  214.670309] [drm] nouveau 0000:05:00.0: Setting dpms mode 3 on tmds encoder (output 3)
Jan 21 09:26:06 localhost kernel: [  214.690489] [drm] nouveau 0000:05:00.0: 0xD452: Parsing digital output script table
Jan 21 09:26:06 localhost kernel: [  214.741042] [drm] nouveau 0000:05:00.0: Setting dpms mode 0 on tmds encoder (output 3)
Jan 21 09:26:06 localhost kernel: [  214.741045] [drm] nouveau 0000:05:00.0: Output DVI-I-1 is running on CRTC 0 using output A
Jan 21 09:27:24 localhost kernel: [  292.973183] [drm] nouveau 0000:05:00.0: Setting dpms mode 3 on tmds encoder (output 3)
Jan 21 09:27:24 localhost kernel: [  292.993366] [drm] nouveau 0000:05:00.0: 0xD452: Parsing digital output script table
Jan 21 09:27:24 localhost kernel: [  293.044034] [drm] nouveau 0000:05:00.0: Setting dpms mode 0 on tmds encoder (output 3)
Jan 21 09:27:24 localhost kernel: [  293.044037] [drm] nouveau 0000:05:00.0: Output DVI-I-1 is running on CRTC 0 using output A
Jan 21 09:27:25 localhost kernel: [  293.380292] do_trap: 10 callbacks suppressed
Jan 21 09:27:25 localhost kernel: [  293.380297] mutter[3441] trap int3 ip:305864c159 sp:7fff815d6fd0 error:0
Jan 21 09:27:25 localhost kernel: [  293.600185] mutter[3667] trap int3 ip:305864c159 sp:7fff13bff920 error:0
Jan 21 09:27:25 localhost kernel: [  293.819963] mutter[3674] trap int3 ip:305864c159 sp:7fff39a48910 error:0
Jan 21 09:27:25 localhost kernel: [  294.039879] mutter[3681] trap int3 ip:305864c159 sp:7fff078581d0 error:0
Jan 21 09:27:25 localhost kernel: [  294.257541] mutter[3688] trap int3 ip:305864c159 sp:7fff2b0cb450 error:0
Jan 21 09:27:26 localhost kernel: [  294.479605] mutter[3695] trap int3 ip:305864c159 sp:7fffaa8d2390 error:0
Jan 21 09:27:26 localhost kernel: [  294.699995] mutter[3702] trap int3 ip:305864c159 sp:7fff4bc4fdf0 error:0
Jan 21 09:27:26 localhost kernel: [  294.919363] mutter[3709] trap int3 ip:305864c159 sp:7fff075a9300 error:0
Jan 21 09:27:26 localhost kernel: [  295.139485] mutter[3716] trap int3 ip:305864c159 sp:7fffbc8c45a0 error:0
Jan 21 09:27:27 localhost kernel: [  295.357728] mutter[3723] trap int3 ip:305864c159 sp:7fff08b45dc0 error:0
Jan 21 09:27:30 localhost kernel: [  298.723382] do_trap: 13 callbacks suppressed
Jan 21 09:27:30 localhost kernel: [  298.723386] mutter[3826] trap int3 ip:305864c159 sp:7fff29ba5840 error:0
Jan 21 09:27:30 localhost kernel: [  298.944395] mutter[3833] trap int3 ip:305864c159 sp:7ffff23e2990 error:0
Jan 21 09:27:30 localhost kernel: [  299.166476] mutter[3840] trap int3 ip:305864c159 sp:7fffe625ed10 error:0
Jan 21 09:27:31 localhost kernel: [  299.390330] mutter[3847] trap int3 ip:305864c159 sp:7fff0119c3b0 error:0
Jan 21 09:27:31 localhost kernel: [  299.610067] mutter[3854] trap int3 ip:305864c159 sp:7fffa79c1920 error:0
Jan 21 09:27:31 localhost kernel: [  299.828816] mutter[3861] trap int3 ip:305864c159 sp:7fff4a7d96b0 error:0
Jan 21 09:27:31 localhost kernel: [  300.046655] mutter[3868] trap int3 ip:305864c159 sp:7fff482e2830 error:0
Jan 21 09:27:32 localhost kernel: [  300.264149] mutter[3875] trap int3 ip:305864c159 sp:7fff0de630a0 error:0
Jan 21 09:27:32 localhost kernel: [  300.483621] mutter[3882] trap int3 ip:305864c159 sp:7fff89aa1a70 error:0
Jan 21 09:27:32 localhost kernel: [  300.702491] mutter[3889] trap int3 ip:305864c159 sp:7fffa43cb020 error:0
Jan 21 09:27:35 localhost kernel: [  304.006457] do_trap: 14 callbacks suppressed
Jan 21 09:27:35 localhost kernel: [  304.006462] mutter[3994] trap int3 ip:305864c159 sp:7fff1d781f50 error:0
Jan 21 09:27:35 localhost kernel: [  304.226356] mutter[4001] trap int3 ip:305864c159 sp:7fff056b13b0 error:0
Jan 21 09:27:36 localhost kernel: [  304.446825] mutter[4008] trap int3 ip:305864c159 sp:7fff83ba3be0 error:0
Jan 21 09:27:36 localhost kernel: [  304.674524] mutter[4015] trap int3 ip:305864c159 sp:7fffa826bb00 error:0
Jan 21 09:27:36 localhost kernel: [  304.897651] mutter[4022] trap int3 ip:305864c159 sp:7fff5701fa90 error:0
Jan 21 09:27:36 localhost kernel: [  305.117883] mutter[4029] trap int3 ip:305864c159 sp:7fffb79c0910 error:0
Jan 21 09:27:37 localhost kernel: [  305.335255] mutter[4036] trap int3 ip:305864c159 sp:7fffe676fde0 error:0
Jan 21 09:27:37 localhost kernel: [  305.555608] mutter[4043] trap int3 ip:305864c159 sp:7ffff5cdcd60 error:0
Jan 21 09:27:37 localhost kernel: [  305.773281] mutter[4050] trap int3 ip:305864c159 sp:7fffcd259e30 error:0
Jan 21 09:27:37 localhost kernel: [  305.993051] mutter[4057] trap int3 ip:305864c159 sp:7fff361c98b0 error:0
Jan 21 09:27:41 localhost kernel: [  309.332580] do_trap: 14 callbacks suppressed
Jan 21 09:27:41 localhost kernel: [  309.332585] mutter[4163] trap int3 ip:305864c159 sp:7fff997d1940 error:0
Jan 21 09:27:41 localhost kernel: [  309.556724] mutter[4170] trap int3 ip:305864c159 sp:7ffffa698a80 error:0
Jan 21 09:27:41 localhost kernel: [  309.775383] mutter[4177] trap int3 ip:305864c159 sp:7fff530bc4a0 error:0
Jan 21 09:27:41 localhost kernel: [  309.996894] mutter[4184] trap int3 ip:305864c159 sp:7ffffc2b2eb0 error:0
Jan 21 09:27:41 localhost kernel: [  310.218431] mutter[4191] trap int3 ip:305864c159 sp:7fff3f0a6c60 error:0
Jan 21 09:27:42 localhost kernel: [  310.444254] mutter[4198] trap int3 ip:305864c159 sp:7fff46d074b0 error:0
Jan 21 09:27:42 localhost kernel: [  310.664689] mutter[4205] trap int3 ip:305864c159 sp:7fff5a5c1a80 error:0
Jan 21 09:27:42 localhost kernel: [  310.883537] mutter[4212] trap int3 ip:305864c159 sp:7fff8cb38350 error:0
Jan 21 09:27:42 localhost kernel: [  311.102927] mutter[4219] trap int3 ip:305864c159 sp:7fffa4205990 error:0
Jan 21 09:27:43 localhost kernel: [  311.321783] mutter[4226] trap int3 ip:305864c159 sp:7ffff7650840 error:0
Jan 21 09:27:46 localhost kernel: [  314.635092] do_trap: 13 callbacks suppressed
Jan 21 09:27:46 localhost kernel: [  314.635097] mutter[4328] trap int3 ip:305864c159 sp:7fff07e36250 error:0
Jan 21 09:27:46 localhost kernel: [  314.856263] mutter[4335] trap int3 ip:305864c159 sp:7fffebd752c0 error:0
Jan 21 09:27:46 localhost kernel: [  315.087842] mutter[4342] trap int3 ip:305864c159 sp:7fff71a95400 error:0
Jan 21 09:27:47 localhost kernel: [  315.318809] mutter[4349] trap int3 ip:305864c159 sp:7fff81d3a7b0 error:0
Jan 21 09:27:47 localhost kernel: [  315.494288] gnome-settings-[2444]: segfault at 306522e430 ip 000000306522e430 sp 00007fffaeeb1db8 error 14 in libjpeg.so.62.0.0[3065a00000+3b000]

Hardware:
nvidia geforce 6600
Comment 1 Vlad 2011-01-20 22:03:12 EST
Could be related with https://bugzilla.redhat.com/show_bug.cgi?id=555133 but i was not able to reopen it.
Comment 2 Vlad 2011-02-22 10:15:42 EST
Looks like problem was in not complete deletion of closed-source nvidia drivers. I was managed to clean it completely, and now gnome-shell works.

Note You need to log in before you can comment on or make changes to this bug.