Bug 671321 - route command option mss sets MTU
route command option mss sets MTU
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: man-pages-overrides (Show other bugs)
5.5
All Linux
medium Severity medium
: rc
: ---
Assigned To: Ivana Varekova
: ManPageChange, Patch
Depends On:
Blocks: 699698
  Show dependency treegraph
 
Reported: 2011-01-21 02:45 EST by Takuma Umeya
Modified: 2011-07-21 11:57 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
The route(8) manual page now includes an explicit description of the "mss M" option.
Story Points: ---
Clone Of:
: 699698 (view as bug list)
Environment:
Last Closed: 2011-07-21 03:37:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
man page fix (735 bytes, patch)
2011-01-21 02:45 EST, Takuma Umeya
no flags Details | Diff

  None (edit)
Description Takuma Umeya 2011-01-21 02:45:51 EST
Created attachment 474592 [details]
man page fix

Description of problem:
mss option of route command sets MTU value. Looking in the code the value is passed to inet_ioctl() of kernel, which only accepts setting MTU. I have a patch to address this issue HOWEVER. Since this may affect the change in behavior significantly, I'd like to propose man page change, so users are aware that setting mss would mean setting MTU (although they are actually not the same thing). 

Version-Release number of selected component (if applicable):
net-tools-1.60-81.el5

How reproducible:
Always 

Steps to Reproduce:                                                      
e.g: 
1. # route del default
2. # route add default gw 192.168.122.1 mtu 1500
Above the action shows the below: 
[root@olive-kvm164 ~]# cat /proc/net/route
Iface   Destination     Gateway         Flags   RefCnt  Use     Metric  Mask            MTU     Window  IRTT                                                      
eth0    007AA8C0        00000000        0001    0       0       0       00FFFFFF        0       0       0                                                                              
eth0    0000FEA9        00000000        0001    0       0       0       0000FFFF        0       0       0                                                                              
eth0    00000000        017AA8C0        0003    0       0       0       00000000        1500    0       0           

  
Actual results:
Man page is not clear that mss sets MTU. 

Expected results:
Should be clear that mss sets MTU. 

Additional info:
Comment 17 Miroslav Svoboda 2011-07-15 12:38:41 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
The route(8) manual page now includes an explicit description of the "mss M" option.
Comment 18 errata-xmlrpc 2011-07-21 03:37:26 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2011-1009.html

Note You need to log in before you can comment on or make changes to this bug.