Bug 67158 - manpage zshall aint a meta-man-page.
manpage zshall aint a meta-man-page.
Status: CLOSED DUPLICATE of bug 19555
Product: Red Hat Linux
Classification: Retired
Component: zsh (Show other bugs)
7.3
athlon Linux
medium Severity low
: ---
: ---
Assigned To: Trond Eivind Glomsrxd
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-06-20 10:35 EDT by vilou
Modified: 2007-04-18 12:43 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-06-20 10:35:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description vilou 2002-06-20 10:35:04 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.5 (X11; Linux i686; U;) Gecko/0

Description of problem:
the man-page "zshall" should include *all* zsh manpages (zshmisc, zshexpn..
etc.. see man zsh :). But the ".so" directives in zshall.1.gz dont work because
file are gziped.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. man zshall
2. See the content

	

Actual Results:  `man zshall` is almost the same content as `man zsh` : 
[root@gruyere /usr/share/man/man1]# man zsh|wc -l 
    413
[root@gruyere /usr/share/man/man1]# man zshall|wc -l
    414


Expected Results:  man zshall should be much much longer as it should include
other zsh man pages.

Additional info:

this is the error output from man zshall|wc -l

[root@gruyere /usr/share/man/man1]# man zshall|wc -l
<standard input>:472: realpath on `man1/zshmisc.1' failed: Aucun fichier ou
ripertoire de ce type
<standard input>:473: realpath on `man1/zshexpn.1' failed: Aucun fichier ou
ripertoire de ce type
<standard input>:474: realpath on `man1/zshparam.1' failed: Aucun fichier ou
ripertoire de ce type
<standard input>:475: realpath on `man1/zshoptions.1' failed: Aucun fichier ou
ripertoire de ce type
<standard input>:476: realpath on `man1/zshbuiltins.1' failed: Aucun fichier ou
ripertoire de ce type
<standard input>:477: realpath on `man1/zshzle.1' failed: Aucun fichier ou
ripertoire de ce type
<standard input>:478: realpath on `man1/zshcompwid.1' failed: Aucun fichier ou
ripertoire de ce type
<standard input>:479: realpath on `man1/zshcompsys.1' failed: Aucun fichier ou
ripertoire de ce type
<standard input>:480: realpath on `man1/zshcompctl.1' failed: Aucun fichier ou
ripertoire de ce type
<standard input>:481: realpath on `man1/zshmodules.1' failed: Aucun fichier ou
ripertoire de ce type
<standard input>:482: realpath on `man1/zshzftpsys.1' failed: Aucun fichier ou
ripertoire de ce type
<standard input>:483: realpath on `man1/zshcontrib.1' failed: Aucun fichier ou
ripertoire de ce type

(sorry for the french.. it said "No such file or directory" and i'm a lazy boy..)

As theese files are gziped there is no man1/zshcontrib.1 but
man1/zshcontrib.1.gz. I have turned ".so man1/zshmisc.1" in zshall.1 into ".so
man1/zshmisc.1.gz" but this doesn't work either....

If all zsh*.1.gz are gunziped then the zshall page is anew a meta manpage
including all other zsh man pages..
Comment 1 Trond Eivind Glomsrxd 2002-06-20 11:03:56 EDT

*** This bug has been marked as a duplicate of 19555 ***

Note You need to log in before you can comment on or make changes to this bug.