Bug 67191 - typo in kernel source file
typo in kernel source file
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
: 67268 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-06-20 14:57 EDT by adler
Modified: 2007-04-18 12:43 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-07 14:46:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description adler 2002-06-20 14:57:38 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020513

Description of problem:
There's a typo in source file include/linux/sched.h which causes compilations to
break

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Found it by trying to build openafs
2.
3.
	

Additional info:

the following is a diff of the affected file
after its being fixed and the emacs ~ file,
which is the original one. Bascially #if
should be a #ifdef

/usr/src/linux-2.4/include/linux
[adler@newadler linux]$ diff sched.h sched.h~
454c454
< #ifdef CONFIG_SMP
---
> #if CONFIG_SMP
Comment 1 Arjan van de Ven 2002-06-20 17:19:00 EDT
No #if is actually correct too..... CONFIG_SMP is defined to 1 ....
I wonder if openafs has a bust makefile that does -DCONFIG_SMP and not the
proper thing.
Comment 2 adler 2002-06-20 17:54:26 EDT
If you look at other places of the code in the same file, you'll
find #ifdef CONFIG_SMP statements. So why does the sched.h file
have a mix of #if CONFIG_SMP and #ifdef CONFIG_SMP. You would
expect it to be consistant through out. ?????
Comment 3 Arjan van de Ven 2002-06-20 18:16:37 EDT
I didn't say it was nice or consistent... it's just not incorrect
sure it's nicer to be consistent :)
Comment 4 adler 2002-06-21 09:19:02 EDT
what's the correct -D statment then in the cc command line?
Comment 5 Arjan van de Ven 2002-06-21 09:21:54 EDT
there is no correct -D statement for this, because it MUST NOT be passed on the
command line, it's a config option that is automatically used correctly via
include/config.h, which everything that is relevant already includes.
Comment 6 Arjan van de Ven 2002-06-21 14:42:02 EDT
*** Bug  67268 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.