Bug 67268 - can't compile openafs-kernel-source-1.2.5-rh7.3.1.i386.rpm package
can't compile openafs-kernel-source-1.2.5-rh7.3.1.i386.rpm package
Status: CLOSED DUPLICATE of bug 67191
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.3
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-06-21 14:38 EDT by Need Real Name
Modified: 2007-04-18 12:43 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-06-21 14:38:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-06-21 14:38:13 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.0) Gecko/20020529

Description of problem:
I get compilation error on making the
openafs-kernel-source-1.2.5-rh7.3.1.i386.rpm package.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. download and install openafs-kernel-source-1.2.5-rh7.3.1.i386.rpm
2. change to /usr/src/openafs-kernel-source-1.2.5/src
3. do: ./configure; make
	

Actual Results:  
../linux/sched.h:454:15: #if with no expression
make[1]: *** [afs_analyze.o] Error 1
make[1]: Leaving directory `/usr/src/openafs-kernel-1.2.5/src/MODLOAD-2.4.18-5-MP'
make: *** [linux_compdirs] Error 2


Additional info:
the line 454 of /usr/src/linux-2.4.18-5/include/linux/sched.h is:
#if CONFIG_SMP
while it should be:
#ifdef CONFIG_SMP
Comment 1 Arjan van de Ven 2002-06-21 14:42:07 EDT
bug 67191 is about the same thing, marking this a duplicate

*** This bug has been marked as a duplicate of 67191 ***

Note You need to log in before you can comment on or make changes to this bug.