Bug 672023 - Abrt allows submitting backtraces without *any* debugsymbols
Summary: Abrt allows submitting backtraces without *any* debugsymbols
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: libreport
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: ---
Assignee: Denys Vlasenko
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedNTH RejectedBlocker
Depends On:
Blocks: F16Beta-accepted, F16BetaFreezeExcept
TreeView+ depends on / blocked
 
Reported: 2011-01-23 09:56 UTC by Christoph Wickert
Modified: 2011-09-26 01:41 UTC (History)
11 users (show)

Fixed In Version: libreport-2.0.5.980-1.fc16
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-09-26 01:41:34 UTC


Attachments (Terms of Use)

Description Christoph Wickert 2011-01-23 09:56:55 UTC
Description of problem:
In Fedora 15 ABRT again allows to submitting completely useless backtraces that do not contain *any* debug symbols. Please stop this ASAP. It adds a lot of work for our contributors and is frustrating both for them and the bug reporters.

Version-Release number of selected component (if applicable):
abrt-1.1.14-3.fc15.x86_64

How reproducible:
always

Steps to Reproduce:
1. Boot latest Xfce nightly from http://alt.fedoraproject.org/pub/alt/nightly-composes/xfce/
2. On login xfce4-settings-helper crashes, see bug 670522
3. Use ABRT to file a bug
  
Actual results:
The backtrace is completely useless, see attachment 474070 [details] in bug 670522.

Expected results:
ABRT MUST MUST MUST not allow submitting backtraces without any debug symbols. If a backtrace is not ok, it should show info how to use debuginfo-install to install the missing packages manually and then regenerate the backtrace.

Comment 1 Karel Klíč 2011-01-31 18:35:37 UTC
Fixed in upstream git, both master and 1.1.x branch.

There were two bugs:
1) ABRT failed to parse the backtrace (because it was produced by the new GDB)
   The result is that the backtrace was not rated.

2) ABRT allowed to submit the backtrace without rating.


Now if the backtrace parser fails, the backtrace is rated as lowest quality.

The parser was extended to parse the thread headers produced by the new GDB. Even with this change, the backtrace mentioned in this bug is still rated as lowest quality.

Comment 2 Christoph Wickert 2011-02-17 20:01:39 UTC
(In reply to comment #1)
> Fixed in upstream git, both master and 1.1.x branch.

If it was fixed in 1.1.x on January 31st, should the fix be in abrt-1.1.17-1.fc15 built on February 6th? I still get empty backtraces on the F15 alpha livemedia.

Comment 3 Christoph Wickert 2011-03-04 09:25:14 UTC
Hi there, any news?

Comment 4 Christoph Wickert 2011-04-09 11:23:14 UTC
Ping?!

Comment 5 Jiri Moskovcak 2011-04-10 20:56:02 UTC
There is a new version abrt-2.0.0 in updatest-testing which should have this fixed.

Comment 6 Steve Tyler 2011-04-20 23:15:19 UTC
I just submitted a report with no symbols:
Bug 698468 - [abrt] gnome-shell-2.91.92-3.fc15: Process /usr/bin/gnome-shell was killed by signal 6 (SIGABRT)

abrt-2.0.1-1.fc15.x86_64

Comment 7 Karel Klíč 2011-04-21 06:52:57 UTC
Steve, thank you for the pointer.

Btparser rates the backtrace it with 0. Function check_backtrace_and_allow_send in src/gui-wizard-gtk/wizard.c incorrectly expects the rating to have a value between 1 and 4; 0 is being ignored.

Comment 8 Karel Klíč 2011-04-21 07:01:31 UTC
Fixed in commit 884c0aed054302cb1cbb71c2b21c12df92a7e6e4 in upstream git.

Comment 9 Fedora Update System 2011-04-21 16:39:11 UTC
abrt-2.0.1-2.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/abrt-2.0.1-2.fc15

Comment 10 Fedora Update System 2011-04-22 00:11:19 UTC
Package abrt-2.0.1-2.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing abrt-2.0.1-2.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/abrt-2.0.1-2.fc15
then log in and leave karma (feedback).

Comment 11 Steve Tyler 2011-04-24 19:16:28 UTC
(In reply to comment #8)
> Fixed in commit 884c0aed054302cb1cbb71c2b21c12df92a7e6e4 in upstream git.

Thanks, Karel.
https://fedorahosted.org/abrt/changeset/884c0aed054302cb1cbb71c2b21c12df92a7e6e4

I couldn't figure out a way to recreate a backtrace with a zero rating,
but could test the fix by editing the rating file: -1, 0, 5 were all identified as unusable by abrt-gui.

Comment 12 Fedora Update System 2011-04-26 16:06:26 UTC
abrt-2.0.1-2.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 13 Christoph Wickert 2011-09-21 10:13:34 UTC
Reopening, because it is back in 2.0.5 as you can see in bug 740218.

Comment 14 Jiri Moskovcak 2011-09-21 15:40:06 UTC
Will roll a new update with a fix for this today or tmrw - proposing as a beta blocker, since this can create a lot of noise in bz.

Comment 15 Adam Williamson 2011-09-22 00:49:37 UTC
Discussed at the 2011-09-21 go/no-go meeting (note: in #fedora-meeting-1), acting as a blocker review meeting. Agreed that this is not a release blocker, as it doesn't prevent the submission of good reports, but nice to have, as it will prevent us getting useless reports from the live image.

Comment 16 Jiri Moskovcak 2011-09-22 12:10:38 UTC
Fixed in git (commit: 0dba21e4e82ec222d895750565e513151b675c27)

Comment 17 Fedora Update System 2011-09-22 16:16:00 UTC
libreport-2.0.5.980-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/libreport-2.0.5.980-1.fc16

Comment 18 Fedora Update System 2011-09-24 04:34:38 UTC
Package libreport-2.0.5.980-1.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing libreport-2.0.5.980-1.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/libreport-2.0.5.980-1.fc16
then log in and leave karma (feedback).

Comment 19 Fedora Update System 2011-09-26 01:41:12 UTC
libreport-2.0.5.980-1.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.