Bug 672092 - It's impossible to chat on Mumble due to the CELT codec which is not found.
Summary: It's impossible to chat on Mumble due to the CELT codec which is not found.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: mumble
Version: 14
Hardware: i686
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Andreas Osowski
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 667067 682572 691041 700879 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-01-23 22:25 UTC by Valentin Brémond
Modified: 2011-06-07 04:30 UTC (History)
13 users (show)

Fixed In Version: mumble-1.2.3-2.fc14
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-05-25 18:55:15 UTC
Type: ---


Attachments (Terms of Use)

Description Valentin Brémond 2011-01-23 22:25:05 UTC
Description of problem:

Connecting to a server works well, but it's impossible to hear people and to talk to other people because of a "Cannot find CELT codecs corresponding to other users. You will not be able to talk to other users." issue.

Version-Release number of selected component (if applicable):

Mumble : v.1.2.2.
CELT : v.0.8.1.

How reproducible:

Easily.

Steps to Reproduce:
1. Install Mumble with dependencies.
2. Connect to a server.
3. Try chatting.
  
Actual results:

Don't work.

Expected results:

If it could work, it would be great =)

Additional info:

Nothing.

Comment 1 Dirk Schlüter 2011-01-27 21:09:35 UTC
Same here. 

I've tried also with mumble-1.2.2-10.fc14.x86_64 from updates-testing. 

Mumble: mumble-1.2.2-10.fc14.x86_64 and mumble-1.2.2-8.fc14.x86_64
CELT  : celt-0.8.1-1.fc14.1.x86_64

strace output:

(...)
open("/usr/lib64/libcelt0.so.0.6.1", O_RDONLY) = -1 ENOENT (No such file or directory)
(...)
open("/usr/lib64/libcelt0.so.0.6.2.so", O_RDONLY) = -1 ENOENT (No such file or directory)
(...)
open("/usr/lib64/libcelt0.so.0.7.0", O_RDONLY) = -1 ENOENT (No such file or directory)
(...)
open("/usr/lib64/libcelt0.so.0.0.0", O_RDONLY) = -1 ENOENT (No such file or directory)
(...)

# locate libcelt
/usr/lib64/libcelt0.so.1
/usr/lib64/libcelt0.so.1.0.0
/usr/lib64/libcelt051.so.0
/usr/lib64/libcelt051.so.0.0.0

Testing with "ln -s /usr/lib64/libcelt0.so.1.0.0 /usr/lib64/libcelt.so.0.0.0.so" resulting in segmentation fault of mumble.

Comment 2 Dirk Schlüter 2011-01-27 21:12:47 UTC
Additional i've found this: https://bugzilla.redhat.com/show_bug.cgi?id=641572

Comment 3 Dirk Schlüter 2011-01-27 21:52:57 UTC
Sorry for posting again, but maybe it helps. 

I've taken this SRC RPM

http://th0br0.fedorapeople.org/celt071-0.7.1/celt071-0.7.1-1.fc13.src.rpm

and rebuild as celt071-0.7.1-1.fc14.x86_64.rpm.

After installing and "ln -s /usr/lib64/libcelt071.so.0 /usr/lib64/libcelt0.so.0.0.0", mumble works as expected. 

Workaround (steps rebuild from mind) ;) 

# cd /usr/local/src/
# wget http://th0br0.fedorapeople.org/celt071-0.7.1/celt071-0.7.1-1.fc13.src.rpm
# rpm -i celt071-0.7.1-1.fc13.src.rpm
# cd /root/rpmbuild/
# yum install libogg-devel
# rpmbuild -ba SPECS/celt071.spec
# rpm -ivh /root/rpmbuild/RPMS/x86_64/celt071-0.7.1-1.fc14.x86_64.rpm
# ln -s /usr/lib64/libcelt071.so.0 /usr/lib64/libcelt0.so.0.0.0

Comment 4 Valentin Brémond 2011-01-29 17:54:39 UTC
It works !

Great job, thank you a lot !

But I hope the developers will fix the issue. Should I send a mail to them or will they be alerted thanks to this report ?

Comment 5 Andreas Osowski 2011-01-29 23:01:23 UTC
I am aware of this problem and am currently solving it. 
I hope to be able to push an update fairly soon.

Comment 6 Valentin Brémond 2011-01-30 13:11:12 UTC
Ok, thank you.

I love Bugzilla =)

Comment 7 Simon Dwyer 2011-03-14 11:27:44 UTC
This is happening still with 15-alpha

Comment 8 Vinzenz Vietzke 2011-04-12 12:16:53 UTC
(In reply to comment #7)
> This is happening still with 15-alpha
Even with packages from f16-rawhide.

Comment 9 Andreas Osowski 2011-04-12 15:05:29 UTC
The reason for this is, as stated above, the lack of celt071.
However, last week, celt071 was reviewed and accepted. celt071 on f15 should make stable today / tomorrow; f14 should follow suit. Once that has happened, I'll push some update to mumble which will solve the oh so many bugs. So stay tuned, planning to push the change tomorrow, hopefully.

Comment 10 Dirk Schlüter 2011-04-12 21:19:21 UTC
Just a statement. I use mumble, now for month, with the rebuilded celt071 F14 rpm (described above) continuous for telephone conferences and it's stable. 

My thanks goes to the developers when this bug is closed. :)

Comment 11 Andreas Osowski 2011-05-17 21:44:06 UTC
*** Bug 682572 has been marked as a duplicate of this bug. ***

Comment 12 Andreas Osowski 2011-05-17 21:44:10 UTC
*** Bug 700879 has been marked as a duplicate of this bug. ***

Comment 13 Andreas Osowski 2011-05-17 21:44:27 UTC
*** Bug 667067 has been marked as a duplicate of this bug. ***

Comment 14 Andreas Osowski 2011-05-17 21:46:20 UTC
*** Bug 691041 has been marked as a duplicate of this bug. ***

Comment 15 Fedora Update System 2011-05-17 21:48:10 UTC
mumble-1.2.3-2.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/mumble-1.2.3-2.fc15

Comment 16 Fedora Update System 2011-05-17 21:53:28 UTC
mumble-1.2.3-2.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/mumble-1.2.3-2.fc14

Comment 17 Fedora Update System 2011-05-18 18:42:05 UTC
Package mumble-1.2.3-2.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing mumble-1.2.3-2.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/mumble-1.2.3-2.fc15
then log in and leave karma (feedback).

Comment 18 Rovanion Luckey 2011-05-18 20:20:03 UTC
I downloaded the packages and installed them, Mumble now works fine, thank you!

Comment 19 Andreas Osowski 2011-05-18 20:42:29 UTC
You're welcome.
Sorry for the long delay, school kept me from working on it :(

But glad to hear it's working fine now.

Comment 20 Fedora Update System 2011-05-25 18:55:01 UTC
mumble-1.2.3-2.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 21 Fedora Update System 2011-06-07 04:30:23 UTC
mumble-1.2.3-2.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.