Bug 672934 - [RFE] rebase perl-Date-Manip to 6.x tree
[RFE] rebase perl-Date-Manip to 6.x tree
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: perl-Date-Manip (Show other bugs)
6.2
All Linux
medium Severity medium
: rc
: ---
Assigned To: perl-maint-list
Petr Šplíchal
: FutureFeature, Rebase
Depends On: 705752
Blocks: GSS_6_2_PROPOSED 697582
  Show dependency treegraph
 
Reported: 2011-01-26 13:20 EST by Jeremy Eder
Modified: 2011-12-06 04:45 EST (History)
5 users (show)

See Also:
Fixed In Version: perl-Date-Manip-6.24-1.el6
Doc Type: Rebase: Bug Fixes and Enhancements
Doc Text:
Among other flaws, the previous version of the perl-Date-Manip package included outdated time zone definitions and an old API that is now considered deprecated. This update upgrades the perl-Date-Manip package to upstream version 6.24, which provides up-to-date time zone definitions and version 6 of the API. Users are still able to use the old API version 5 by explicitly using the Date::Manip::DM5 module.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-12-06 04:45:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Comment 2 RHEL Product and Program Management 2011-01-26 13:48:54 EST
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.
Comment 3 Petr Pisar 2011-01-27 04:10:32 EST
Differences in dependencies between current RHEL-6 (5.54) and Fedora-15 (6.21, latest upstream) version:

-BuildRequires:  perl(ExtUtils::MakeMaker) perl(Test::More)
+BuildRequires:  perl(Carp)
+BuildRequires:  perl(Encode)
+BuildRequires:  perl(Exporter)
+BuildRequires:  perl(Module::Build) >= 0.20
+BuildRequires:  perl(Storable)
+BuildRequires:  perl(Test::More)
+BuildRequires:  perl(YAML::Syck)
+# Tests only
+BuildRequires:  perl(Test::Inter)

All dependencies are satisfied by RHEL-6 except perl(Test::Inter). The Test::Inter module is needed only at build time to proceed upstream tests.

We can skip the tests (which I don't like) or we can import perl-Test-Inter package into RHEL-6 (that I prefer).


The perl-Test-Inter package requires:

BuildRequires:  perl(File::Basename)
BuildRequires:  perl(IO::File)
BuildRequires:  perl(Module::Build)
# Tests only:
BuildRequires:  perl(Test::Pod)
BuildRequires:  perl(Test::Pod::Coverage)

All perl-Test-Inter dependencies are satisfied by RHEL-6, the package is compilable and all tests pass.
Comment 17 Petr Pisar 2011-06-28 05:39:14 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Cause
    Current packaged version 5.54 contains various flaws
    including out-dated time zone definitions. Upstream
    moved to new API (version 6) and deprecated this old
    one (version 5).
Consequence
    The package would provide erroneous time zone data.
Change
    Package has been rebased to version 6.24 providing
    updated time zone definitions and new API. Old API
    is still provided but suffers from unfixable bugs.
Result
    Applications can obtain up-to-date time zone
    definitions and they can use new API (version 6) that
    allows to operate with time zones correctly.
Comment 18 Petr Pisar 2011-06-28 07:10:08 EDT
    Technical note updated. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    Diffed Contents:
@@ -11,5 +11,7 @@
     is still provided but suffers from unfixable bugs.
 Result
     Applications can obtain up-to-date time zone
-    definitions and they can use new API (version 6) that
+    definitions. They use new API (version 6) by default that
-    allows to operate with time zones correctly.+    allows to operate with time zones correctly or they can
+    use old API (version 5) explicitly by using
+    Date::Manip::DM5 module.
Comment 24 Jaromir Hradilek 2011-10-18 10:46:59 EDT
    Technical note updated. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    Diffed Contents:
@@ -1,17 +1 @@
-Cause
+Among other flaws, the previous version of the perl-Date-Manip package included outdated time zone definitions and an old API that is now considered deprecated. This update upgrades the perl-Date-Manip package to upstream version 6.24, which provides up-to-date time zone definitions and version 6 of the API. Users are still able to use the old API version 5 by explicitly using the Date::Manip::DM5 module.-    Current packaged version 5.54 contains various flaws
-    including out-dated time zone definitions. Upstream
-    moved to new API (version 6) and deprecated this old
-    one (version 5).
-Consequence
-    The package would provide erroneous time zone data.
-Change
-    Package has been rebased to version 6.24 providing
-    updated time zone definitions and new API. Old API
-    is still provided but suffers from unfixable bugs.
-Result
-    Applications can obtain up-to-date time zone
-    definitions. They use new API (version 6) by default that
-    allows to operate with time zones correctly or they can
-    use old API (version 5) explicitly by using
-    Date::Manip::DM5 module.
Comment 25 errata-xmlrpc 2011-12-06 04:45:52 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2011-1560.html

Note You need to log in before you can comment on or make changes to this bug.