Bug 672971 - smoltSendProfile does not work
smoltSendProfile does not work
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: smolt (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Orphan Owner
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-01-26 15:48 EST by Michael
Modified: 2011-02-03 02:47 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-02-03 02:47:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
messages (175.69 KB, application/octet-stream)
2011-01-26 15:50 EST, Michael
no flags Details

  None (edit)
Description Michael 2011-01-26 15:48:41 EST
Description of problem:

I run smoltSendProfile to get information about my system and send it to server, but smoltSendProfile give me error

Version-Release number of selected component (if applicable):

last in rawhide

How reproducible:

always

Steps to Reproduce:
1. run smoltSendProfile 
2.
3.
  
Actual results:

[root@localhost liveuser]# smoltSendProfile                                                                                                                  
Traceback (most recent call last):
  File "/usr/bin/smoltSendProfile", line 39, in <module>
    import smolt
  File "/usr/share/smolt/client/smolt.py", line 54, in <module>
    from devicelist import cat
ImportError: No module named devicelist
[root@localhost liveuser]# 

Expected results:

get information and send it to smolt server

Additional info:
Comment 1 Michael 2011-01-26 15:50:17 EST
Created attachment 475483 [details]
messages
Comment 2 Michael 2011-01-26 15:51:49 EST
please change attachment to text file
Comment 3 Adam Williamson 2011-02-02 13:24:51 EST
673015 is newer, but has the patch, so marking this as dupe of that.

*** This bug has been marked as a duplicate of bug 673015 ***
Comment 4 Pavel Zhukov 2011-02-03 02:43:00 EST
I've installed 
Name        : smolt
Version     : 1.4.3
Release     : 2.jlaska.fc15

but I think there are broken deps.
You have to add python-hwdata to Requres
and 
  File "/usr/share/smolt/client/devicelist.py", line 3, in <module>
    from hwdata import DeviceMap
ImportError: cannot import name DeviceMap

I cannot fix this import yet.

Fedora rawhide x84_64 last updates.
Comment 5 Pavel Zhukov 2011-02-03 02:47:36 EST
Sorry. URL for correct build
http://koji.fedoraproject.org/koji/buildinfo?buildID=216715

Note You need to log in before you can comment on or make changes to this bug.