Bug 673015 - Launching smoltGui or smoltSendProfile causes a traceback
Launching smoltGui or smoltSendProfile causes a traceback
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: smolt (Show other bugs)
rawhide
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Orphan Owner
Fedora Extras Quality Assurance
:
: 671538 673247 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-01-26 21:24 EST by Shyam Iyer
Modified: 2015-04-28 00:19 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-02-02 13:25:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
proposed smolt.spec patch (1.29 KB, patch)
2011-01-27 08:13 EST, James Laska
no flags Details | Diff
proposed smolt.spec patch (1.44 KB, patch)
2011-01-27 08:50 EST, James Laska
no flags Details | Diff

  None (edit)
Description Shyam Iyer 2011-01-26 21:24:19 EST
Description of problem:
Launching smoltGui or smoltSendProfile causes a traceback

Version-Release number of selected component (if applicable):
smolt-1.4.3-1.fc15.noarch
smolt-gui-1.4.3-1.fc15.noarch


How reproducible:
Always

Steps to Reproduce:
1.smoltSendprofile or smoltGui
2.
3.
  
Actual results:
[root@dell-per710-01 ~]# smoltSendProfile 
Traceback (most recent call last):
  File "/usr/bin/smoltSendProfile", line 39, in <module>
    import smolt
  File "/usr/share/smolt/client/smolt.py", line 54, in <module>
    from devicelist import cat
ImportError: No module named devicelist


Expected results:
SmoltGui should open a graphical window and SmoltSendProfile should send the hardware profile.

Additional info:
Comment 1 James Laska 2011-01-27 08:13:51 EST
Created attachment 475601 [details]
proposed smolt.spec patch

The attached patch against the smolt.spec in dist-git appears to include the client/devicelist.py file correctly.  I have built --scratch koji packages for testing at http://koji.fedoraproject.org/koji/taskinfo?taskID=2745384
Comment 2 James Laska 2011-01-27 08:50:26 EST
Created attachment 475606 [details]
proposed smolt.spec patch

New version of the patch ... there were some more missing %files.

Scratch build tested and available at http://koji.fedoraproject.org/koji/taskinfo?taskID=2745512
Comment 3 James Laska 2011-01-27 15:14:50 EST
*** Bug 673247 has been marked as a duplicate of this bug. ***
Comment 4 Adam Williamson 2011-02-02 13:24:43 EST
*** Bug 671538 has been marked as a duplicate of this bug. ***
Comment 5 Adam Williamson 2011-02-02 13:24:51 EST
*** Bug 672971 has been marked as a duplicate of this bug. ***
Comment 6 Adam Williamson 2011-02-02 13:25:46 EST
tested and reproduced the bug, applied jlaska's fix and tested that it does indeed fix the problem, pushed a fixed build. thanks.

Note You need to log in before you can comment on or make changes to this bug.