This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 673431 - IOException: Partition(s) 3 on /dev/sda have been written, but we have been unable to inform the kernel of the change, probably because it/they are in use. As a result, the old partition(s) will remain in use. You should reboot now before making further
IOException: Partition(s) 3 on /dev/sda have been written, but we have been u...
Status: CLOSED DUPLICATE of bug 650064
Product: Fedora
Classification: Fedora
Component: parted (Show other bugs)
rawhide
i386 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Brian Lane
Fedora Extras Quality Assurance
anaconda_trace_hash:40fa5153ad4db68b0...
:
: 673433 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-01-28 02:59 EST by Jóhann B. Guðmundsson
Modified: 2011-06-27 23:05 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-02-04 01:16:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (525.55 KB, text/plain)
2011-01-28 03:00 EST, Jóhann B. Guðmundsson
no flags Details
Attached traceback automatically from anaconda. (574.72 KB, text/plain)
2011-06-27 23:05 EDT, OsgoodJ
no flags Details

  None (edit)
Description Jóhann B. Guðmundsson 2011-01-28 02:59:53 EST
The following was filed automatically by anaconda:
anaconda 15.18 exception report
Traceback (most recent call first):
  File "/usr/lib/python2.7/site-packages/parted/disk.py", line 213, in commit
    return self.__disk.commit()
  File "/usr/lib/python2.7/site-packages/parted/decorators.py", line 30, in new
    ret = fn(*args, **kwds)
  File "/usr/lib/python2.7/site-packages/pyanaconda/storage/formats/disklabel.py", line 252, in commit
    self.partedDisk.commit()
  File "/usr/lib/python2.7/site-packages/pyanaconda/storage/devices.py", line 1476, in _destroy
    self.disk.originalFormat.commit()
  File "/usr/lib/python2.7/site-packages/pyanaconda/storage/devices.py", line 783, in destroy
    self._destroy()
  File "/usr/lib/python2.7/site-packages/pyanaconda/storage/deviceaction.py", line 277, in execute
    self.device.destroy()
  File "/usr/lib/python2.7/site-packages/pyanaconda/storage/devicetree.py", line 309, in processActions
    action.execute(intf=self.intf)
  File "/usr/lib/python2.7/site-packages/pyanaconda/storage/__init__.py", line 355, in doIt
    self.devicetree.processActions()
  File "/usr/lib/python2.7/site-packages/pyanaconda/packages.py", line 116, in turnOnFilesystems
    anaconda.storage.doIt()
  File "/usr/lib/python2.7/site-packages/pyanaconda/dispatch.py", line 211, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/python2.7/site-packages/pyanaconda/dispatch.py", line 130, in gotoNext
    self.moveStep()
  File "/usr/lib/python2.7/site-packages/pyanaconda/gui.py", line 1354, in setScreen
    self.anaconda.dispatch.gotoNext()
  File "/usr/lib/python2.7/site-packages/pyanaconda/gui.py", line 1266, in nextClicked
    self.setScreen ()
IOException: Partition(s) 3 on /dev/sda have been written, but we have been unable to inform the kernel of the change, probably because it/they are in use.  As a result, the old partition(s) will remain in use.  You should reboot now before making further changes.
Comment 1 Jóhann B. Guðmundsson 2011-01-28 03:00:00 EST
Created attachment 475743 [details]
Attached traceback automatically from anaconda.
Comment 2 Jóhann B. Guðmundsson 2011-01-28 03:04:15 EST
Happens when selecting "Use all space"
Comment 3 Brian Lane 2011-02-02 19:05:56 EST
Did you do anything unusual? This error should only show up when you have changed partitions on a drive that has other partitions already mounted.
Comment 4 Brian Lane 2011-02-02 19:19:26 EST
*** Bug 673433 has been marked as a duplicate of this bug. ***
Comment 5 Jóhann B. Guðmundsson 2011-02-03 03:46:26 EST
Nope just stock live usb other than selected Icelandic Keyboard layout and the timezone for Iceland it's an stock next next next install with Basic storage and "Use all space" selected which triggered this.
Comment 6 Jóhann B. Guðmundsson 2011-02-03 04:02:35 EST
This is an Dell Inspiron 6000 with 60GiB drive.

Note I did notice some other weirdness happening when partitioning I tested this the second time with the default storage option selected as in Basic storage and remove linux partition that when Anaconda proceeded without actually touching the previously created partitions as in Anaconda started creating /dev/sda{3,4,5} instead of the usual /dev/sda{1,2,3} not sure if that related/relevant to this bug thou.
Comment 7 Brian Lane 2011-02-04 01:16:16 EST
Duping to an older bug. I think this is an anaconda problem, libparted is complaining that the device is still active when it tries to partition it.

*** This bug has been marked as a duplicate of bug 650064 ***
Comment 8 OsgoodJ 2011-06-27 23:05:37 EDT
Created attachment 510190 [details]
Attached traceback automatically from anaconda.

Note You need to log in before you can comment on or make changes to this bug.