Bug 673433 - DeviceCreateError: ('Partition(s) 3 on /dev/sda have been written, but we have been unable to inform the kernel of the change, probably because it/they are in use. As a result, the old partition(s) will remain in use. You should reboot now before making
DeviceCreateError: ('Partition(s) 3 on /dev/sda have been written, but we hav...
Status: CLOSED DUPLICATE of bug 673431
Product: Fedora
Classification: Fedora
Component: parted (Show other bugs)
rawhide
i386 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Brian Lane
Fedora Extras Quality Assurance
anaconda_trace_hash:c247aa1dccc537cfd...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-01-28 03:04 EST by Jóhann B. Guðmundsson
Modified: 2011-09-04 17:57 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-02-02 19:19:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (754.10 KB, text/plain)
2011-01-28 03:04 EST, Jóhann B. Guðmundsson
no flags Details
Attached traceback automatically from anaconda. (955.78 KB, text/plain)
2011-05-30 12:07 EDT, wizardzwd
no flags Details
Attached traceback automatically from anaconda. (408.97 KB, text/plain)
2011-09-04 17:56 EDT, fortinogianfranco
no flags Details
Attached traceback automatically from anaconda. (408.97 KB, text/plain)
2011-09-04 17:57 EDT, fortinogianfranco
no flags Details

  None (edit)
Description Jóhann B. Guðmundsson 2011-01-28 03:04:06 EST
The following was filed automatically by anaconda:
anaconda 15.18 exception report
Traceback (most recent call first):
  File "/usr/lib/python2.7/site-packages/pyanaconda/storage/devices.py", line 748, in create
    raise DeviceCreateError(str(e), self.name)
  File "/usr/lib/python2.7/site-packages/pyanaconda/storage/deviceaction.py", line 238, in execute
    self.device.create(intf=intf)
  File "/usr/lib/python2.7/site-packages/pyanaconda/storage/devicetree.py", line 309, in processActions
    action.execute(intf=self.intf)
  File "/usr/lib/python2.7/site-packages/pyanaconda/storage/__init__.py", line 355, in doIt
    self.devicetree.processActions()
  File "/usr/lib/python2.7/site-packages/pyanaconda/packages.py", line 116, in turnOnFilesystems
    anaconda.storage.doIt()
  File "/usr/lib/python2.7/site-packages/pyanaconda/dispatch.py", line 211, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/python2.7/site-packages/pyanaconda/dispatch.py", line 130, in gotoNext
    self.moveStep()
  File "/usr/lib/python2.7/site-packages/pyanaconda/gui.py", line 1354, in setScreen
    self.anaconda.dispatch.gotoNext()
  File "/usr/lib/python2.7/site-packages/pyanaconda/gui.py", line 1266, in nextClicked
    self.setScreen ()
DeviceCreateError: ('Partition(s) 3 on /dev/sda have been written, but we have been unable to inform the kernel of the change, probably because it/they are in use.  As a result, the old partition(s) will remain in use.  You should reboot now before making further changes.', 'sda3')
Comment 1 Jóhann B. Guðmundsson 2011-01-28 03:04:13 EST
Created attachment 475744 [details]
Attached traceback automatically from anaconda.
Comment 2 Brian Lane 2011-02-02 19:19:26 EST

*** This bug has been marked as a duplicate of bug 673431 ***
Comment 3 wizardzwd 2011-05-30 12:07:11 EDT
Created attachment 501844 [details]
Attached traceback automatically from anaconda.
Comment 4 fortinogianfranco 2011-09-04 17:56:00 EDT
Created attachment 521402 [details]
Attached traceback automatically from anaconda.
Comment 5 fortinogianfranco 2011-09-04 17:57:05 EDT
Created attachment 521403 [details]
Attached traceback automatically from anaconda.

Note You need to log in before you can comment on or make changes to this bug.