Bug 673521 - PHP53 Lacks php53-pear
Summary: PHP53 Lacks php53-pear
Keywords:
Status: CLOSED DUPLICATE of bug 679121
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: distribution
Version: 5.6
Hardware: All
OS: Unspecified
unspecified
high
Target Milestone: rc
: ---
Assignee: RHEL Product and Program Management
QA Contact: Ondrej Hudlicky
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-01-28 14:42 UTC by James Findley
Modified: 2011-07-08 12:43 UTC (History)
13 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-07-08 12:43:47 UTC


Attachments (Terms of Use)

Description James Findley 2011-01-28 14:42:02 UTC
Description of problem:

The original php package provided php-pear, which includes both the pecl and pear binaries, as well as the tools to insteall various PHP modules.

This is missing from php53.  Attempts to use the old php-pear package don't work acceptably, with lots of warnings produced.  (this also breaks rpm builds of, for example, php-pecl-memcache).


Version-Release number of selected component (if applicable):

php53 (ALL)


How reproducible:
Always

Steps to Reproduce:
1. yum install php53-pear
2.
3.
  
Actual results:
No package found

Expected results:
php53-pear installed

Additional info:

Comment 1 Alain D D Williams 2011-04-11 16:55:15 UTC
Well, I have a work-around. I am not proud of it, but it appears to work.

Install http://www.phcomp.co.uk/Downloads/php53-shim-5.3.3-1.2.noarch.rpm
What this does is require the packages: php53 and php53-mbstring and export the packages: php and php-mbstring

I have now reinstalled nagios (seems to work), and squirrelmail (not tried it yet) and a bunch of my own stuff that got broken is now OK.

You will prob also need my signing key which is here: http://www.phcomp.co.uk/Software/RPM-GPG-KEY-PHCL-CentOS-5

If you want the source RPM get it from http://www.phcomp.co.uk/Downloads/php53-shim-5.3.3-1.2.src.rpm

Have fun, enjoy!

Comment 2 Alexander Lindqvist 2011-04-13 09:12:37 UTC
Im also missing the php53-pear package. What is the status on this and why was it not included ?

Comment 3 labradort 2011-06-13 18:21:06 UTC
I am another Redhat user who would like to see php53-pear package brought up to date.  It is not possible to support some applications without a newer pear, and I'd much rather keep this happening within Redhat package management.

Another example of software requiring a newer pear is Horde Webmail 4, which is now completely installed via pear.  "pear install PEAR-1.9.3" (or upgrade) does not do the trick.

Comment 4 labradort 2011-06-23 19:33:22 UTC
I tried the many ways to install pear, (such as "php go-pear.phar")
and none worked - they would come back to the command line.

Eventually I used --force and it worked:

pear upgrade --force Console_Getopt

pear upgrade --force pear

pear upgrade-all

Pear version is now 1.9.3 Stable with php53.

Comment 7 Joe Orton 2011-06-24 08:43:18 UTC

*** This bug has been marked as a duplicate of bug 679121 ***

Comment 8 Yury V. Zaytsev 2011-06-28 08:27:27 UTC
This bug is unrelated to #679121. It's a generic problem of PEAR not being shipped with php53. Please re-open.

Comment 10 Joe Orton 2011-07-08 12:43:47 UTC
Yury, there is no need for a separate pear package to work with 5.3, the existing php-pear will work once the warnings are fixed.

*** This bug has been marked as a duplicate of bug 679121 ***


Note You need to log in before you can comment on or make changes to this bug.