Bug 679121 - php-pear with php53 produces many warnings
php-pear with php53 produces many warnings
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: php-pear (Show other bugs)
5.6
All Linux
medium Severity medium
: rc
: ---
Assigned To: Joe Orton
BaseOS QE - Apps
: Reopened
: 664539 673521 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-02-21 11:33 EST by Martin Poole
Modified: 2013-04-15 05:13 EDT (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
When PEAR was used with the php53 package, the "pear" command emitted numerous redundant deprecation warnings. These warnings have been disabled and the "pear" command now behaves as expected.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-07-27 04:14:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
PEAR 13323 None None None Never

  None (edit)
Description Martin Poole 2011-02-21 11:33:42 EST
Description of problem:

When using php-pear with the php53 package there are a lot of deprecation warnings.

Version-Release number of selected component (if applicable):

$ rpm -q php53 php-pear
php53-5.3.3-1.el5_6.1
php-pear-1.4.9-6.el5

How reproducible:

Always

Steps to Reproduce:
1. pear list

  
Actual results:

$ pear list
PHP Notice:  Undefined offset: 8192 in /usr/share/pear/PEAR/Frontend.php on line 92

: Assigning the return value of new by reference is deprecated in Frontend.php on line 92
PHP Notice:  Undefined offset: 8192 in /usr/share/pear/PEAR/Config.php on line 575

: Assigning the return value of new by reference is deprecated in Config.php on line 575
PHP Notice:  Undefined offset: 8192 in /usr/share/pear/PEAR/Config.php on line 605

: Assigning the return value of new by reference is deprecated in Config.php on line 605
PHP Notice:  Undefined offset: 8192 in /usr/share/pear/PEAR/Config.php on line 672

: Assigning the return value of new by reference is deprecated in Config.php on line 672
PHP Notice:  Undefined offset: 8192 in /usr/share/pear/PEAR/Config.php on line 701

: Assigning the return value of new by reference is deprecated in Config.php on line 701
PHP Notice:  Undefined offset: 8192 in /usr/share/pear/PEAR/Config.php on line 832

: Assigning the return value of new by reference is deprecated in Config.php on line 832
PHP Notice:  Undefined offset: 8192 in /usr/share/pear/PEAR/Config.php on line 1466

: Assigning the return value of new by reference is deprecated in Config.php on line 1466
PHP Notice:  Undefined offset: 8192 in /usr/share/pear/PEAR/Config.php on line 1493

: Assigning the return value of new by reference is deprecated in Config.php on line 1493
PHP Notice:  Undefined offset: 8192 in /usr/share/pear/PEAR/Config.php on line 1989

: Assigning the return value of new by reference is deprecated in Config.php on line 1989
PHP Notice:  Undefined offset: 8192 in /usr/share/pear/PEAR/Config.php on line 2002

: Assigning the return value of new by reference is deprecated in Config.php on line 2002
PHP Notice:  Undefined offset: 8192 in /usr/share/pear/PEAR/Config.php on line 2058

: Assigning the return value of new by reference is deprecated in Config.php on line 2058
PHP Notice:  Undefined offset: 8192 in /usr/share/pear/PEAR/Registry.php on line 281

: Assigning the return value of new by reference is deprecated in Registry.php on line 281
PHP Notice:  Undefined offset: 8192 in /usr/share/pear/PEAR/Registry.php on line 1283

: Assigning the return value of new by reference is deprecated in Registry.php on line 1283
PHP Notice:  Undefined offset: 8192 in /usr/share/pear/PEAR/Registry.php on line 1289

: Assigning the return value of new by reference is deprecated in Registry.php on line 1289
PHP Notice:  Undefined offset: 8192 in /usr/share/pear/PEAR/Command.php on line 137

: Assigning the return value of new by reference is deprecated in Command.php on line 137
PHP Notice:  Undefined offset: 8192 in /usr/share/pear/PEAR/Command.php on line 154

: Assigning the return value of new by reference is deprecated in Command.php on line 154
PHP Notice:  Undefined offset: 8192 in /usr/share/pear/pearcmd.php on line 416

: Function set_magic_quotes_runtime() is deprecated in Config.php on line 942
PHP Notice:  Undefined offset: 8192 in /usr/share/pear/pearcmd.php on line 416

: Function set_magic_quotes_runtime() is deprecated in Config.php on line 954
PHP Notice:  Undefined offset: 8192 in /usr/share/pear/PEAR/Command/Registry.php on line 206

: Assigning the return value of new by reference is deprecated in PEAR/Command/Registry.php on line 206
PHP Notice:  Undefined offset: 8192 in /usr/share/pear/PEAR/Command/Registry.php on line 366

: Assigning the return value of new by reference is deprecated in PEAR/Command/Registry.php on line 366
PHP Notice:  Undefined offset: 8192 in /usr/share/pear/pearcmd.php on line 416

: Function eregi() is deprecated in PEAR/Registry.php on line 735
PHP Notice:  Undefined offset: 8192 in /usr/share/pear/pearcmd.php on line 416

: Function set_magic_quotes_runtime() is deprecated in PEAR/Registry.php on line 1002
PHP Notice:  Undefined offset: 8192 in /usr/share/pear/pearcmd.php on line 416

: Function set_magic_quotes_runtime() is deprecated in PEAR/Registry.php on line 1011
PHP Notice:  Undefined offset: 8192 in /usr/share/pear/pearcmd.php on line 416

: Function set_magic_quotes_runtime() is deprecated in PEAR/Registry.php on line 1002
PHP Notice:  Undefined offset: 8192 in /usr/share/pear/pearcmd.php on line 416

: Function set_magic_quotes_runtime() is deprecated in PEAR/Registry.php on line 1011
PHP Notice:  Undefined offset: 8192 in /usr/share/pear/pearcmd.php on line 416

: Function set_magic_quotes_runtime() is deprecated in PEAR/Registry.php on line 1002
PHP Notice:  Undefined offset: 8192 in /usr/share/pear/pearcmd.php on line 416

: Function set_magic_quotes_runtime() is deprecated in PEAR/Registry.php on line 1011
PHP Notice:  Undefined offset: 8192 in /usr/share/pear/pearcmd.php on line 416

: Function set_magic_quotes_runtime() is deprecated in PEAR/Registry.php on line 1002
PHP Notice:  Undefined offset: 8192 in /usr/share/pear/pearcmd.php on line 416

: Function set_magic_quotes_runtime() is deprecated in PEAR/Registry.php on line 1011
PHP Notice:  Undefined offset: 8192 in /usr/share/pear/pearcmd.php on line 416

: Function eregi() is deprecated in PEAR/Registry.php on line 735
PHP Notice:  Undefined offset: 8192 in /usr/share/pear/pearcmd.php on line 416

: Function eregi() is deprecated in PEAR/Registry.php on line 735
PHP Notice:  Undefined offset: 8192 in /usr/share/pear/pearcmd.php on line 416

: Function set_magic_quotes_runtime() is deprecated in PEAR/Registry.php on line 1002
PHP Notice:  Undefined offset: 8192 in /usr/share/pear/pearcmd.php on line 416

: Function set_magic_quotes_runtime() is deprecated in PEAR/Registry.php on line 1011
PHP Notice:  Undefined offset: 8192 in /usr/share/pear/PEAR/Common.php on line 359

: Assigning the return value of new by reference is deprecated in PEAR/Common.php on line 359
PHP Notice:  Undefined offset: 8192 in /usr/share/pear/PEAR/Common.php on line 390

: Assigning the return value of new by reference is deprecated in PEAR/Common.php on line 390
PHP Notice:  Undefined offset: 8192 in /usr/share/pear/PEAR/Common.php on line 421

: Assigning the return value of new by reference is deprecated in PEAR/Common.php on line 421
PHP Notice:  Undefined offset: 8192 in /usr/share/pear/PEAR/Common.php on line 486

: Assigning the return value of new by reference is deprecated in PEAR/Common.php on line 486
PHP Notice:  Undefined offset: 8192 in /usr/share/pear/PEAR/Common.php on line 519

: Assigning the return value of new by reference is deprecated in PEAR/Common.php on line 519
PHP Notice:  Undefined offset: 8192 in /usr/share/pear/PEAR/Common.php on line 544

: Assigning the return value of new by reference is deprecated in PEAR/Common.php on line 544
PHP Notice:  Undefined offset: 8192 in /usr/share/pear/PEAR/PackageFile/v1.php on line 357

: Assigning the return value of new by reference is deprecated in PEAR/PackageFile/v1.php on line 357
PHP Notice:  Undefined offset: 8192 in /usr/share/pear/PEAR/PackageFile/v1.php on line 1294

: Assigning the return value of new by reference is deprecated in PEAR/PackageFile/v1.php on line 1294
PHP Notice:  Undefined offset: 8192 in /usr/share/pear/PEAR/PackageFile/v1.php on line 1317

: Assigning the return value of new by reference is deprecated in PEAR/PackageFile/v1.php on line 1317
PHP Notice:  Undefined offset: 8192 in /usr/share/pear/pearcmd.php on line 416

: Function eregi() is deprecated in PEAR/Registry.php on line 735
PHP Notice:  Undefined offset: 8192 in /usr/share/pear/pearcmd.php on line 416

: Function eregi() is deprecated in PEAR/Registry.php on line 735
PHP Notice:  Undefined offset: 8192 in /usr/share/pear/pearcmd.php on line 416

: Function set_magic_quotes_runtime() is deprecated in PEAR/Registry.php on line 1002
PHP Notice:  Undefined offset: 8192 in /usr/share/pear/pearcmd.php on line 416

: Function set_magic_quotes_runtime() is deprecated in PEAR/Registry.php on line 1011
PHP Notice:  Undefined offset: 8192 in /usr/share/pear/pearcmd.php on line 416

: Function eregi() is deprecated in PEAR/Registry.php on line 735
PHP Notice:  Undefined offset: 8192 in /usr/share/pear/pearcmd.php on line 416

: Function eregi() is deprecated in PEAR/Registry.php on line 735
PHP Notice:  Undefined offset: 8192 in /usr/share/pear/pearcmd.php on line 416

: Function set_magic_quotes_runtime() is deprecated in PEAR/Registry.php on line 1002
PHP Notice:  Undefined offset: 8192 in /usr/share/pear/pearcmd.php on line 416

: Function set_magic_quotes_runtime() is deprecated in PEAR/Registry.php on line 1011
PHP Notice:  Undefined offset: 8192 in /usr/share/pear/PEAR/PackageFile/v2.php on line 154

: Assigning the return value of new by reference is deprecated in PEAR/PackageFile/v2.php on line 154
PHP Notice:  Undefined offset: 8192 in /usr/share/pear/PEAR/PackageFile/v2.php on line 172

: Assigning the return value of new by reference is deprecated in PEAR/PackageFile/v2.php on line 172
PHP Notice:  Undefined offset: 8192 in /usr/share/pear/PEAR/PackageFile/v2.php on line 567

: Assigning the return value of new by reference is deprecated in PEAR/PackageFile/v2.php on line 567
PHP Notice:  Undefined offset: 8192 in /usr/share/pear/PEAR/PackageFile/v2.php on line 609

: Assigning the return value of new by reference is deprecated in PEAR/PackageFile/v2.php on line 609
PHP Notice:  Undefined offset: 8192 in /usr/share/pear/PEAR/PackageFile/v2.php on line 1816

: Assigning the return value of new by reference is deprecated in PEAR/PackageFile/v2.php on line 1816
PHP Notice:  Undefined offset: 8192 in /usr/share/pear/PEAR/PackageFile/v2.php on line 1855

: Assigning the return value of new by reference is deprecated in PEAR/PackageFile/v2.php on line 1855
PHP Notice:  Undefined offset: 8192 in /usr/share/pear/pearcmd.php on line 416

: Function eregi() is deprecated in PEAR/Registry.php on line 735
PHP Notice:  Undefined offset: 8192 in /usr/share/pear/pearcmd.php on line 416

: Function eregi() is deprecated in PEAR/Registry.php on line 735
PHP Notice:  Undefined offset: 8192 in /usr/share/pear/pearcmd.php on line 416

: Function set_magic_quotes_runtime() is deprecated in PEAR/Registry.php on line 1002
PHP Notice:  Undefined offset: 8192 in /usr/share/pear/pearcmd.php on line 416

: Function set_magic_quotes_runtime() is deprecated in PEAR/Registry.php on line 1011
PHP Notice:  Undefined offset: 8192 in /usr/share/pear/pearcmd.php on line 416

: Function eregi() is deprecated in PEAR/Registry.php on line 735
Installed packages, channel pear.php.net:
=========================================
Package        Version State
Archive_Tar    1.3.1   stable
Console_Getopt 1.2     stable
PEAR           1.4.9   stable
XML_RPC        1.5.0   stable



Expected results:

$ pear list
Installed packages, channel pear.php.net:
=========================================
Package        Version State
Archive_Tar    1.3.1   stable
Console_Getopt 1.2     stable
PEAR           1.4.9   stable
XML_RPC        1.5.0   stable


Additional info:
Comment 1 Martin Poole 2011-02-21 11:35:38 EST
The upstream solution to this was not to clean up the pear code but simply to mask off all deprecation warnings.

http://pear.php.net/bugs/bug.php?id=13323&edit=12&patch=Ignore.E_DEPRECATED.as.fast.solution&revision=latest

This kludge was introduced in 1.7.2 and is still present in the RHEL6 version 1.9.0 and latest upstream 1.9.1
Comment 2 RHEL Product and Program Management 2011-05-31 11:18:45 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 3 Joe Orton 2011-06-24 04:43:18 EDT
*** Bug 673521 has been marked as a duplicate of this bug. ***
Comment 4 Joe Orton 2011-06-24 04:44:16 EDT
*** Bug 664539 has been marked as a duplicate of this bug. ***
Comment 5 RHEL Product and Program Management 2011-06-24 04:55:07 EDT
Development Management has reviewed and declined this request.  You may appeal
this decision by reopening this request.
Comment 6 Joe Orton 2011-06-24 05:58:13 EDT
Sorry, I did not intend to close this bug.
Comment 7 labradort 2011-06-27 09:47:05 EDT
Bug https://bugzilla.redhat.com/show_bug.cgi?id=673521 673521 has the description "PHP53 Lacks php53-pear".

Technically, a different issue.  Should not have been merged.  Please do not close or decline the request.  Pear needs to be updated and not left behind!
Comment 8 Yury V. Zaytsev 2011-06-28 04:28:46 EDT
php-pear should conflict with php53. php53-pear should be provided instead.
Comment 9 Joe Orton 2011-07-08 08:43:48 EDT
*** Bug 673521 has been marked as a duplicate of this bug. ***
Comment 11 Yury V. Zaytsev 2011-07-13 08:09:32 EDT
> Yury, there is no need for a separate pear package to work with 5.3, the
> existing php-pear will work once the warnings are fixed.

I am not quite sure if it makes sense to provide PEAR 1.4.9 which is god knows how old (the latest stable ATM is 1.9.4) for php53, since if an application *does* require php53, I believe it would also expect a reasonably recent matching PEAR version to be installed.

I feel that it is a much better idea to provide PEAR from RHEL6 (1.9.0 if I am not mistaken) for php53 renamed as php53-pear on RHEL5. This also means that you don't have to touch php-pear at all, which is surely a plus, but rather provide a new totally independent package which is also already maintained for RHEL6 and is not going to influence anything else.
Comment 13 Miroslav Svoboda 2011-07-14 13:16:07 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
When PEAR was used with the php53 package, the "pear" command emitted numerous redundant deprecation warnings. These warnings have been disabled and the "pear" command now behaves as expected.
Comment 15 errata-xmlrpc 2011-07-27 04:14:02 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-1097.html

Note You need to log in before you can comment on or make changes to this bug.