Bug 67374 - white space separated list of tokens from an error message is being interpreted as a list of packages
white space separated list of tokens from an error message is being interpret...
Status: CLOSED DEFERRED
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
7.3
i586 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-06-23 18:11 EDT by Skwar, Alexander
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-06-23 18:33:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Skwar, Alexander 2002-06-23 18:11:33 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; de-AT; rv:1.0rc2) Gecko/20020510

Description of problem:
I tried to build an RPM of the courier-mta tar.gz file from
http://courier-mta.org.  The tar.bz2 file can be downloaded from
http://digitalprojects.com/courier-0.38.2.20020619.tar.bz2 since the file is no
longer available on the original site.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Download .tar.bz2 file
2. rpmbuild --rebuild courier-0.38.2.20020619.tar.bz2
	

Actual Results:  When the RPMs are created, I see this as the Requires: line:

Requires: courier = 0.38.2.20020619 ld-linux.so.2 libc.so.6 libcrypt.so.1
libdl.so.2 libgdbm.so.2 libm.so.6 libmysqlclient.so.10 libnsl.so.1 libpam.so.0
libz.so.1 file perl is not owned by any package libc.so.6(GLIBC_2.0)
libc.so.6(GLIBC_2.1) libcrypt.so.1(GLIBC_2.0)

Strange is the part "file perl is not owned by any package".

Now, when I try to install these packages, I get:

        is   wird von courier-webmail-0.38.2.20020619-1 gebraucht
        not   wird von courier-webmail-0.38.2.20020619-1 gebraucht
        owned   wird von courier-webmail-0.38.2.20020619-1 gebraucht
        by   wird von courier-webmail-0.38.2.20020619-1 gebraucht
        any   wird von courier-webmail-0.38.2.20020619-1 gebraucht
        package   wird von courier-webmail-0.38.2.20020619-1 gebraucht

(I'll supply the original english text shortly)

Expected Results:  RPM should add the name of the package containing "perl" to
the Requires: list.  It might use the "perl" which is found in the path.  In my
case, this would have been /usr/bin/perl, which is part of perl-base-5.601-14mdk.

Additional info:

Using MandrakeLinux Cooker and Mandrakes rpm-4.0.4-5mdk RPM package.  RPM seems
to get confused by some perl scripts (courier/webadmin/*pl) which contain the
following first line:

#! perl

After changing this to the more usual

#! /usr/bin/perl

the error went away.
Comment 1 Skwar, Alexander 2002-06-23 18:33:40 EDT
Sorry, I cannot reproduce this bug anymore.  Don't know what happened, but when
I now do a --requild, I don't get this strange Requires:.

Further, I just noticed this:

[askwar@klama askwar]$ ll /usr/bin/perl
lrwxrwxrwx    1 root     root            5 May 16 04:02 /usr/bin/perl -> perl5*
[askwar@klama askwar]$ ll /usr/bin/perl5
lrwxrwxrwx    1 root     root            9 May 16 04:02 /usr/bin/perl5 -> perl5.6.1*
[askwar@klama askwar]$ ll /usr/bin/perl5.6.1 
-rwxr-xr-x    1 root     root         8932 May 15 05:11 /usr/bin/perl5.6.1*

Can this confuse RPM?
Comment 2 Jeff Johnson 2002-06-27 13:08:36 EDT
I'm gonna call this a packaging error for now and defer for
a better solution down the road.

Note You need to log in before you can comment on or make changes to this bug.