Bug 67395 - gcc segfaults on Linux 2.5.24 kernel compile
Summary: gcc segfaults on Linux 2.5.24 kernel compile
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gcc   
(Show other bugs)
Version: 7.2
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-06-24 10:40 UTC by Andrew Pam
Modified: 2007-04-18 16:43 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-02 21:31:26 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Andrew Pam 2002-06-24 10:40:53 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.5 (X11; Linux i586; U;) Gecko/20020606

Description of problem:
When compiling Linux kernel 2.5.24 and 2.5.24-dj1, compilation always aborts
while compiling arch/i386/kernel/entry.S with the following error message:

gcc: Internal error: Segmentation fault (program tradcpp0)
Please submit a full bug report.
See <URL:http://bugzilla.redhat.com/bugzilla/> for instructions.

Earlier kernels <= 2.5.21 compile OK.

Version-Release number of selected component (if applicable):
gcc-2.96-98 RPM

How reproducible:
Always

Steps to Reproduce:
1. Download and unpack linux-2.5.24.bz2
2. "make config", "make dep; make clean; make bzImage"
	

Actual Results:  Segmentation fault

Expected Results:  Successful compilation

Additional info:

350MHz AMD K6-2 CPU

Comment 1 Richard Henderson 2004-10-02 21:31:26 UTC
The kernel has built since then.


Note You need to log in before you can comment on or make changes to this bug.