Bug 674271 - SIGSEGV when browsing pop account
SIGSEGV when browsing pop account
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: mutt (Show other bugs)
6.1
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: jpacner
Lukas Zachar
: Patch
Depends On:
Blocks: 947782
  Show dependency treegraph
 
Reported: 2011-02-01 04:09 EST by Stanislaw Gruszka
Modified: 2014-07-28 05:01 EDT (History)
3 users (show)

See Also:
Fixed In Version: mutt-1.5.20-6.20091214hg736b6a.el6
Doc Type: Bug Fix
Doc Text:
Prior to this update, an internal hash referencing a specific subject in each envelope referenced a non-existent one. As a consequence, mutt terminated with a segmentation fault when the user attempted to synchronize mailbox after removing one or more messages in threaded mode. With this update, the subject hash updates correctly and the crash no longer occurs.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-07-28 05:01:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
abrt.log (52.65 KB, text/plain)
2011-02-01 04:09 EST, Stanislaw Gruszka
no flags Details
proposed very simple patch (628 bytes, patch)
2011-06-06 07:54 EDT, Honza Horak
no flags Details | Diff
mutt-fix.patch (2.43 KB, text/plain)
2011-10-02 15:12 EDT, Stanislaw Gruszka
no flags Details

  None (edit)
Description Stanislaw Gruszka 2011-02-01 04:09:51 EST
Created attachment 476338 [details]
abrt.log

Version-Release number of selected component (if applicable):
[root@dhcp-27-172 ~]# rpm -qa | grep mutt
mutt-1.5.20-2.20091214hg736b6a.el6.i686
mutt-debuginfo-1.5.20-2.20091214hg736b6a.el6.i686
[root@dhcp-27-172 ~]# rpm -qa | grep glibc
glibc-headers-2.12-1.7.el6.i686
glibc-debuginfo-2.12-1.7.el6.i686
glibc-common-2.12-1.7.el6.i686
glibc-devel-2.12-1.7.el6.i686
glibc-2.12-1.7.el6.i686
[root@dhcp-27-172 ~]# rpm -qa | grep tokyo
tokyocabinet-1.4.33-6.el6.i686
tokyocabinet-debuginfo-1.4.33-6.el6.i686
Comment 2 Stanislaw Gruszka 2011-02-01 04:19:16 EST
I think this happen in threaded mode when I delete some emails from thread and do sync-mailbox command ($ key). I had this only with "-f pops://..." .
Comment 3 RHEL Product and Program Management 2011-02-01 11:48:40 EST
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.
Comment 4 Honza Horak 2011-06-06 07:54:48 EDT
Created attachment 503203 [details]
proposed very simple patch

Unfortunately, I'm not able to reproduce this failure, but I think this very easy patch should fix this failure and shouldn't bring another regression. 

I've submitted this patch to upstream to see what mutt developers think: http://dev.mutt.org/trac/ticket/3525
Comment 5 Stanislaw Gruszka 2011-06-10 07:47:12 EDT
Jan, I'm not ignoring your patch, but I also can not reproduce bug currently on unpatched mutt. I'm not sure what make a difference, perhaps that before I had much more messages in the pop3 mbox (1500 > ) now I have about 400. I plan to post lots of emails to myself and check if could find the way to reproduce to confirm the fix.
Comment 6 RHEL Product and Program Management 2011-07-05 21:37:56 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.
Comment 7 Stanislaw Gruszka 2011-08-14 08:01:33 EDT
Patch did not fix the problem, see:
https://bugzilla.redhat.com/show_bug.cgi?id=690409#c6
Comment 8 Stanislaw Gruszka 2011-10-02 15:12:25 EDT
Created attachment 525954 [details]
mutt-fix.patch

I spent this Sunday afternoon on drinking kofola and debugging mutt. This is a result.

I wanted post patch to mutt-dev@mutt.org but ML is for subscribers only. I'm a bit reluctant to subscribe just to post one patch. Hopefully Honza, you can post it and do whatever needed to make it applied. Thanks.
Comment 9 Honza Horak 2011-10-04 12:05:04 EDT
Thanks for a great job! 
I've forwarded your patch to upstream, let's wait what they say:
http://dev.mutt.org/trac/ticket/3525
Comment 13 Honza Horak 2013-06-27 07:43:53 EDT
(In reply to Honza Horak from comment #9)
> I've forwarded your patch to upstream, let's wait what they say:
> http://dev.mutt.org/trac/ticket/3525

The patch was accepted upstream (http://dev.mutt.org/trac/changeset/6231) and is already applied in Fedora.
Comment 20 jpacner 2014-05-16 08:31:07 EDT
Fixed in commit http://pkgs.devel.redhat.com/cgit/rpms/mutt/commit/?h=rhel-6.6&id=011263dbff90337a51aa840f40a299e2fc02d6de (build mutt-1.5.20-5.20091214hg736b6a.el6).
Comment 23 jpacner 2014-07-23 10:08:19 EDT
List of patches present on mutt-1.5.20-6.20091214hg736b6a.el6:
http://pkgs.devel.redhat.com/cgit/rpms/mutt/commit/?h=rhel-6.6&id=011263dbff90337a51aa840f40a299e2fc02d6de
Comment 27 errata-xmlrpc 2014-07-28 05:01:24 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0945.html

Note You need to log in before you can comment on or make changes to this bug.