Bug 690409 - mutt crash
mutt crash
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: mutt (Show other bugs)
6.1
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: jpacner
Lukas Zachar
: Patch
Depends On:
Blocks: 947782
  Show dependency treegraph
 
Reported: 2011-03-24 05:38 EDT by Stanislaw Gruszka
Modified: 2014-07-28 05:01 EDT (History)
3 users (show)

See Also:
Fixed In Version: mutt-1.5.20-7.20091214hg736b6a.el6
Doc Type: Bug Fix
Doc Text:
Previously, the array that stores mutt message headers did not properly handle empty header entries. This could cause mutt to terminate unexpectedly with a segmentation fault when a change of message IDs occurred on the IMAP server, for example when the IMAP server was connected with multiple clients while removing messages through one of them. In this update, the handling of empty headers has been optimized and sorting messages in the array has been streamlined. As a result, multiple connected clients now synchronize correctly.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-07-28 05:01:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
abrt.log (18.23 KB, text/plain)
2011-03-24 05:38 EDT, Stanislaw Gruszka
no flags Details
patched mutt core dump on Fedora 14 (3.09 MB, application/octet-stream)
2011-08-14 07:55 EDT, Stanislaw Gruszka
no flags Details

  None (edit)
Description Stanislaw Gruszka 2011-03-24 05:38:16 EDT
Created attachment 487266 [details]
abrt.log

Description of problem:
See attached abrt.log

How reproducible:
Happens once, I did not try to reproduce.
Comment 2 RHEL Product and Program Management 2011-03-24 06:07:49 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.
Comment 5 RHEL Product and Program Management 2011-07-05 20:07:45 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.
Comment 6 Stanislaw Gruszka 2011-08-14 07:55:22 EDT
Created attachment 518178 [details]
patched mutt core dump on Fedora 14

This core dump is on patched mutt from F-14.

Patch did not help. I mange to reproduce the problem, seem it must be more than 1500 messages in the mail box. I'm not going to purge my pop3 mbox, so will be able now to test other patches or provide more info. 

> Core was generated by `mutt -f pops://stf_xl@pop3.wp.pl'.
> Program terminated with signal 11, Segmentation fault.
> #0  0x080b8b6c in find_subject (ctx=0x920bd88, init=<value optimized out>) at thread.c:433
> 433             !tmp->fake_thread &&             /* don't match pseudo threads */
> Missing separate debuginfos, use: debuginfo-install glibc-2.13-1.i686 krb5-libs-1.8.2-7.fc14.i686 nss-softokn-freebl-3.12.9-2.fc14.i686 openssl-1.0.0c-1.fc14.i686
> (gdb) bt
> #0  0x080b8b6c in find_subject (ctx=0x920bd88, init=<value optimized out>) at thread.c:433
> #1  pseudo_threads (ctx=0x920bd88, init=<value optimized out>) at thread.c:503
> #2  mutt_sort_threads (ctx=0x920bd88, init=<value optimized out>) at thread.c:960
> #3  0x080b6015 in mutt_sort_headers (ctx=0x920bd88, init=<value optimized out>) at sort.c:297
> #4  0x0808ea67 in mx_sync_mailbox (ctx=0x920bd88, index_hint=0xbfd3d260) at mx.c:1182
> #5  0x08066091 in mutt_index_menu () at curs_main.c:1034
> #6  0x08082e6d in main (argc=1, argv=0xbfd3e3c4) at main.c:1020
> (gdb) list
> 428                                           ctx->subj_hash->nelem);
> 429       for (ptr = ctx->subj_hash->table[hash]; ptr; ptr = ptr->next)
> 430       {
> 431         tmp = ((HEADER *) ptr->data)->thread;
> 432         if (tmp && tmp != cur &&             /* don't match the same message */
> 433             !tmp->fake_thread &&             /* don't match pseudo threads */
> 434             tmp->message->subject_changed && /* only match interesting replies */
> 435             !is_descendant (tmp, cur) &&     /* don't match in the same thread */
> 436             (date >= (option (OPTTHREADRECEIVED) ?
> 437                       tmp->message->received :
Comment 7 Stanislaw Gruszka 2011-08-14 08:00:31 EDT
Oops, sorry above attachment was intended for bug 674271.
Comment 18 jpacner 2014-05-16 08:34:23 EDT
Fixed in commit http://pkgs.devel.redhat.com/cgit/rpms/mutt/commit/?h=rhel-6.6&id=017aa85aa6eeeed43f2feef496dc5f7d972321aa (build mutt-1.5.20-5.20091214hg736b6a.el6).
Comment 25 jpacner 2014-07-25 05:26:04 EDT
dist-git commits related to build mutt-1.5.20-7.20091214hg736b6a.el6:
http://pkgs.devel.redhat.com/cgit/rpms/mutt/commit/?h=rhel-6.6&id=d2bdd799fd8ff27c4ec0c23921591afb668a6f94
Comment 29 errata-xmlrpc 2014-07-28 05:01:27 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0945.html

Note You need to log in before you can comment on or make changes to this bug.