Bug 674416 - [abrt] VtableFactory::initializeBlock (SIGBUS)
[abrt] VtableFactory::initializeBlock (SIGBUS)
Status: CLOSED DUPLICATE of bug 767708
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
14
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
abrt_hash:420fb47c411e597b409930ecf27...
:
: 684029 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-02-01 14:57 EST by Jeffrey S Austin
Modified: 2011-12-15 00:21 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-02-09 11:51:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (34.40 KB, text/plain)
2011-02-01 14:57 EST, Jeffrey S Austin
no flags Details

  None (edit)
Description Jeffrey S Austin 2011-02-01 14:57:02 EST
abrt version: 1.1.14
architecture: x86_64
Attached file: backtrace
cmdline: /usr/lib64/openoffice.org3/program/soffice.bin -quickstart -nologo -nodefault
component: openoffice.org
crash_function: bridges::cpp_uno::shared::VtableFactory::initializeBlock
executable: /usr/lib64/openoffice.org3/program/soffice.bin
kernel: 2.6.35.10-74.fc14.x86_64.debug
package: openoffice.org-brand-1:3.3.0-19.2.fc14
rating: 4
reason: Process /usr/lib64/openoffice.org3/program/soffice.bin was killed by signal 7 (SIGBUS)
release: Fedora release 14 (Laughlin)
How to reproduce: Don't know.
time: 1296414030
uid: 501
Comment 1 Jeffrey S Austin 2011-02-01 14:57:05 EST
Created attachment 476471 [details]
File: backtrace
Comment 2 Caolan McNamara 2011-02-01 15:24:12 EST
A SIGBUS is typically unavoidable by an app, e.g. mmap of a file and the filesystem disappears. 

Is your /home dir a network mount over samba of nfs or anything odd like that ?
Comment 3 Caolan McNamara 2011-02-09 11:51:07 EST
Shouldn't have SIGBUSed clearly, but OOo follows the same pattern as libgcj to get some filesystem on which it can mmap some executable memory, i.e. http://www.akkadia.org/drepper/selinux-mem.html 

I don't think we can do more than that.
Comment 4 Caolan McNamara 2011-03-11 03:28:11 EST
*** Bug 684029 has been marked as a duplicate of this bug. ***
Comment 5 David Tardon 2011-12-15 00:21:13 EST

*** This bug has been marked as a duplicate of bug 767708 ***

Note You need to log in before you can comment on or make changes to this bug.