This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 767708 - [abrt] VtableFactory::initializeBlock: write to mmap'ed file w/o disk space: SIGBUS
[abrt] VtableFactory::initializeBlock: write to mmap'ed file w/o disk space: ...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: libreoffice (Show other bugs)
15
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Stephan Bergmann
Fedora Extras Quality Assurance
abrt_hash:aaff2030c2ad675ca8e88a37873...
:
: 674416 690681 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-12-14 12:25 EST by Milan Bouchet-Valat
Modified: 2012-01-25 17:29 EST (History)
8 users (show)

See Also:
Fixed In Version: libreoffice-3.3.4.1-2.fc15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-12-23 17:22:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: dso_list (21.08 KB, text/plain)
2011-12-14 12:25 EST, Milan Bouchet-Valat
no flags Details
File: maps (79.68 KB, text/plain)
2011-12-14 12:25 EST, Milan Bouchet-Valat
no flags Details
File: backtrace (64.41 KB, text/plain)
2011-12-14 12:25 EST, Milan Bouchet-Valat
no flags Details

  None (edit)
Description Milan Bouchet-Valat 2011-12-14 12:25:14 EST
abrt version: 2.0.3
architecture:   x86_64
backtrace_rating: 4
cmdline:        /usr/lib64/libreoffice/program/scalc.bin -calc file:///home/milan/Nanterre/Interro%202/TD%20lundi/Djoumad%20Djillali.xls
comment:        I tried to open a .xls file and there was no free space on / and ~. This is the second time I see this.
component:      libreoffice
crash_function: bridges::cpp_uno::shared::VtableFactory::initializeBlock
executable:     /usr/lib64/libreoffice/program/scalc.bin
kernel:         2.6.38.5-22.fc15.x86_64
os_release:     Fedora release 15 (Lovelock)
package:        libreoffice-calc-3.3.3.1-7.fc15
reason:         Process /usr/lib64/libreoffice/program/scalc.bin was killed by signal 7 (SIGBUS)
time:           Wed Dec 14 17:43:45 2011
uid:            1000
username:       milan
xsession_errors: 

backtrace:      Text file, 65960 bytes
dso_list:       Text file, 21581 bytes
maps:           Text file, 81596 bytes

environ:
:ORBIT_SOCKETDIR=/tmp/orbit-milan
:XDG_SESSION_ID=1
:HOSTNAME=milan
:IMSETTINGS_INTEGRATE_DESKTOP=yes
:GIO_LAUNCHED_DESKTOP_FILE_PID=20798
:GPG_AGENT_INFO=/tmp/keyring-Tc2qTh/gpg:0:1
:SHELL=/bin/bash
:TERM=dumb
:DESKTOP_STARTUP_ID=nautilus-3060-milan-libreoffice-32_TIME52265010
:HISTSIZE=1000
:XDG_SESSION_COOKIE=9e1782da896cc13ddd95ca060000000c-1323763072.374437-1852123091
:GJS_DEBUG_OUTPUT=stderr
:OLDPWD=/usr/lib64/libreoffice/program
:GNOME_KEYRING_CONTROL=/tmp/keyring-Tc2qTh
:'GJS_DEBUG_TOPICS=JS ERROR;JS LOG'
:IMSETTINGS_MODULE=none
:USER=milan
:LD_LIBRARY_PATH=/usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0.x86_64/jre/lib/amd64/client:/usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0.x86_64/jre/lib/amd64/native_threads:/usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0.x86_64/jre/lib/amd64
:SSH_AUTH_SOCK=/tmp/keyring-Tc2qTh/ssh
:USERNAME=milan
:SESSION_MANAGER=local/unix:@/tmp/.ICE-unix/1403,unix/unix:/tmp/.ICE-unix/1403
:GIO_LAUNCHED_DESKTOP_FILE=/usr/share/applications/libreoffice-calc.desktop
:MAIL=/var/spool/mail/milan
:PATH=/usr/lib64/ccache:/usr/local/bin:/usr/bin:/bin:/usr/local/sbin:/usr/sbin:/sbin
:DESKTOP_SESSION=gnome
:QT_IM_MODULE=xim
:PWD=/home/milan
:XMODIFIERS=@im=none
:KDE_IS_PRELINKED=1
:GNOME_KEYRING_PID=1395
:LANG=fr_FR.utf8
:GDM_LANG=fr_FR.utf8
:KDEDIRS=/usr
:GDMSESSION=gnome
:HISTCONTROL=ignoredups
:HOME=/home/milan
:SHLVL=2
:GNOME_DESKTOP_SESSION_ID=this-is-deprecated
:SAL_ENABLE_FILE_LOCKING=1
:LOGNAME=milan
:CVS_RSH=ssh
:DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-zPgXlDIJMI,guid=5e4de05a9df0e683a024ed6300000025
:'LESSOPEN=||/usr/bin/lesspipe.sh %s'
:WINDOWPATH=1
:XDG_RUNTIME_DIR=/run/user/milan
:DISPLAY=:0.0
:G_BROKEN_FILENAMES=1
:XAUTHORITY=/var/run/gdm/auth-for-milan-tNKIFM/database
:_=/usr/lib64/libreoffice/program/scalc.bin

var_log_messages:
:Dec 14 17:40:29 milan abrt[20753]: saved core dump of pid 20730 (/usr/lib64/libreoffice/program/scalc.bin) to /var/spool/abrt/ccpp-2011-12-14-17:40:27-20730.new/coredump (103870464 bytes)
:Dec 14 17:43:47 milan abrt[20827]: saved core dump of pid 20810 (/usr/lib64/libreoffice/program/scalc.bin) to /var/spool/abrt/ccpp-2011-12-14-17:43:45-20810.new/coredump (103989248 bytes)
Comment 1 Milan Bouchet-Valat 2011-12-14 12:25:18 EST
Created attachment 546827 [details]
File: dso_list
Comment 2 Milan Bouchet-Valat 2011-12-14 12:25:20 EST
Created attachment 546828 [details]
File: maps
Comment 3 Milan Bouchet-Valat 2011-12-14 12:25:22 EST
Created attachment 546829 [details]
File: backtrace
Comment 4 Stephan Bergmann 2011-12-14 14:27:52 EST
This apparently allocates a file in the USE_DOUBLE_MMAP case VtableFactory::createBlock (via mkstemp, ftruncate to enlarge to required size, mmap), but ftruncate overcommits disk space (i.e., doesn't care whether there is disk space to eventually back the mmap'ed file's pages), disk is already full as user reports ("there was no free space on / and ~"), so first write to the mmap'ed memory gives SIGBUS.  Solution is to use posix_fallocate (even though, reportedly, even that can fail "with journaling/COW/snapshots/thin provisioning.")
Comment 5 David Tardon 2011-12-15 00:21:13 EST
*** Bug 674416 has been marked as a duplicate of this bug. ***
Comment 6 David Tardon 2011-12-15 00:21:49 EST
*** Bug 690681 has been marked as a duplicate of this bug. ***
Comment 7 Fedora Update System 2011-12-15 15:43:16 EST
libreoffice-3.4.4.2-6.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/libreoffice-3.4.4.2-6.fc16
Comment 8 Milan Bouchet-Valat 2011-12-15 18:20:55 EST
I can't test the package since I'm still on Fedora 15, but I must say I'm really impressed by your responsiveness! ;-)
Comment 9 Fedora Update System 2011-12-16 14:59:18 EST
Package libreoffice-3.4.4.2-6.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing libreoffice-3.4.4.2-6.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2011-17186/libreoffice-3.4.4.2-6.fc16
then log in and leave karma (feedback).
Comment 10 Fedora Update System 2011-12-23 17:22:24 EST
libreoffice-3.4.4.2-6.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 11 Fedora Update System 2012-01-17 04:09:37 EST
libreoffice-3.3.4.1-2.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/libreoffice-3.3.4.1-2.fc15
Comment 12 Fedora Update System 2012-01-25 17:29:00 EST
libreoffice-3.3.4.1-2.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.