Bug 67448 - i830 module causes kernel oops on exit from X
i830 module causes kernel oops on exit from X
Status: CLOSED DUPLICATE of bug 67978
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-06-25 09:55 EDT by Mark A J Ashdown
Modified: 2007-04-18 12:43 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-06-25 10:15:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mark A J Ashdown 2002-06-25 09:55:21 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.5 (X11; Linux i686; U;) Gecko/0

Description of problem:
When exiting from X, i830 kernel module causes kernel oops and display locks up.

Version-Release number of selected component (if applicable): 2.4.18-5


How reproducible:
Always

Steps to Reproduce:
1. Login on console.
2. Start X using startx.
2. Exit from X.

	

Actual Results:  Display locks up. Kernel oops attached below. System still
responds to keyboard (verified audibly) and remote login is possible via network.

Expected Results:  X should exit and display should return to console.

Additional info:

The bug occured on a Dell Latitude X200 laptop with Intel i830 chipset. The bug
was not present in kernel 2.4.18-4. Output from dmesg:

Unable to handle kernel paging request at virtual address 0100001b
 printing eip:
c0128962
*pde = 00000000
Oops: 0000
i810_audio ac97_codec soundcore i830 agpgart ds yenta_socket pcmcia_core 3c59x
CPU:    0
EIP:    0010:[<c0128962>]    Not tainted
EFLAGS: 00013246

EIP is at unlock_page [kernel] 0x2 (2.4.18-5)
eax: 01000000   ebx: c129f150   ecx: c129f150   edx: 00000000
esi: cbfbc000   edi: cdca2800   ebp: 00000000   esp: cd1a5ed4
ds: 0018   es: 0018   ss: 0018
Process X (pid: 1038, stackpage=cd1a5000)
Stack: c129f150 cbfbc000 d014b953 c129f150 cdcd0c40 cdbf4800 d014b9af cdca2800 
       cbfbc000 00000000 bffffa24 cd1a5f54 d014bf2c cdca2800 cdca2800 00000002 
       00000000 00000000 00000000 00000000 00000000 00000000 00000000 00000000 
Call Trace: [<d014b953>] i830_free_page [i830] 0x33 
[<d014b9af>] i830_dma_cleanup [i830] 0x3f 
[<d014bf2c>] i830_dma_init [i830] 0xac 
[<d0147924>] i830_ioctl [i830] 0xe4 
[<c0145c47>] sys_ioctl [kernel] 0x217 
[<c0108913>] system_call [kernel] 0x33 


Code: 0f b6 50 1b 8b 1c 95 2c 55 33 c0 89 c2 69 d2 01 00 37 9e 8b
Comment 1 Mark A J Ashdown 2002-06-25 10:15:17 EDT
The kernel oops only occurs when using the DRI, so there is a simple workaround:

In the file /etc/X11/XF86Config-4, comment out the line containing

Load "dri"
Comment 2 Mike A. Harris 2002-07-10 08:55:43 EDT

*** This bug has been marked as a duplicate of 67978 ***

Note You need to log in before you can comment on or make changes to this bug.