Bug 674838 - embedded browser fails with org.eclipse.swt.SWTError: XPCOM error -2147467261
embedded browser fails with org.eclipse.swt.SWTError: XPCOM error -2147467261
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: eclipse (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Sami Wagiaalla
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-02-03 08:57 EST by David Juran
Modified: 2016-06-07 18:46 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-07-12 07:20:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
JVM crash log (67.36 KB, text/plain)
2011-02-03 11:54 EST, David Juran
no flags Details
log form latest crash (67.32 KB, text/plain)
2011-02-23 05:21 EST, David Juran
no flags Details
JVM crash log (58.93 KB, text/plain)
2011-04-12 08:35 EDT, David Juran
no flags Details

  None (edit)
Description David Juran 2011-02-03 08:57:49 EST
Description of problem:
When starting azureus on rawhide, the embedded browser fails with the rather cryptic error message "org.eclipse.swt.SWTError: XPCOM error -2147467261"

Now I don't even know where to start looking for what this error code means but running the very same version of azurueus works fine on F14 so I'm hoping that eclipse could be the correct component to assign this to...


Version-Release number of selected component (if applicable):
eclipse-swt-3.6.1-4.fc15.x86_64

How reproducible:
Every time


Steps to Reproduce:
1. start azureus form the command line
2. Watch how the embedded browser GUI doesn't come up and the above error is spewed out.

Additional info:
Comment 1 Andrew Overholt 2011-02-03 09:01:42 EST
Has xulrunner changed recently?  If so, Eclipse may need to be rebuilt.
Comment 2 Severin Gehwolf 2011-02-03 09:09:06 EST
Looks like it did change recently:
http://koji.fedoraproject.org/koji/buildinfo?buildID=215797
Comment 3 Alexander Kurtakov 2011-02-03 09:20:24 EST
I have never been able to make swt work with latest xulrunner (2.x) though it compiles against it.
Comment 4 Andrew Overholt 2011-02-03 09:25:23 EST
Alex pointed this link out to me:

http://web.archiveorange.com/archive/v/WKyaraG5QTD6IfxEo5OS
Comment 5 Alexander Kurtakov 2011-02-03 09:41:09 EST
David, I'll recommend you to add -Dorg.eclipse.swt.browser.UseWebKitGTK=true parameter to your azureus startup script. This will make it use webkit explicitly and azureus should be safe though the general problem for swt will still be here.
Comment 6 David Juran 2011-02-03 11:52:27 EST
Setting -Dorg.eclipse.swt.browser.UseWebKitGTK=true causes the JVM (java-1.6.0-openjdk-1.6.0.0-51.1.9.5.fc15.x86_64) to crash in a way similar to what is described in http://icedtea.classpath.org/bugzilla/show_bug.cgi?id=532

Attaching the hs_err log.

To reproduce the crash, set the -Dorg.eclipse.swt.browser.UseWebKitGTK=true parameter in the azureus start script (/usr/bin/azureus) and then when azureus starts up, click on "Vuze HD network" in the side bar.
Comment 7 David Juran 2011-02-03 11:54:55 EST
Created attachment 476822 [details]
JVM crash log
Comment 8 Alexander Kurtakov 2011-02-18 06:28:17 EST
Can you try using webkitgtk after all the rebuilds? It might be just a rebuild was needed.
Comment 9 David Juran 2011-02-18 09:48:17 EST
Tried it with a freshly updated rawhide using webkitgtk-1.3.11-2.fc15.x86_64 and it still crashes.
Comment 10 David Juran 2011-02-19 06:20:51 EST
I tried giving this a quick look but it seems eclipse doesn't provide any debuginfo (bug 153247)

/me gives up and hopes someone with more debugging experience will have the time/inclination...
Comment 12 David Juran 2011-02-23 05:21:57 EST
Created attachment 480404 [details]
log form latest crash
Comment 13 Alexander Kurtakov 2011-04-06 03:59:02 EDT
(In reply to comment #12)
> Created attachment 480404 [details]
> log form latest crash

Can you try http://koji.fedoraproject.org/koji/taskinfo?taskID=2977859 on F-15 with webkit?
Comment 14 David Juran 2011-04-06 13:58:35 EDT
libswt-gnome-gtk.so seem to be missing...

This is what I get as soon as I try to start azureus:

java.lang.reflect.InvocationTargetException
	at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
	at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:57)
	at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:45)
	at java.lang.reflect.Constructor.newInstance(Constructor.java:532)
	at org.gudy.azureus2.ui.swt.Main.<init>(Main.java:114)
	at org.gudy.azureus2.ui.swt.Main.main(Main.java:292)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
	at java.lang.reflect.Method.invoke(Method.java:616)
	at com.aelitis.azureus.launcher.MainExecutor$1.run(MainExecutor.java:37)
	at java.lang.Thread.run(Thread.java:636)
Caused by: java.lang.UnsatisfiedLinkError: Could not load SWT library. Reasons: 
	no swt-gnome-gtk-3659 in java.library.path
	no swt-gnome-gtk in java.library.path
	Can't load library: /tmp/swtlib-64/libswt-gnome-gtk-3659.so
	Can't load library: /tmp/swtlib-64/libswt-gnome-gtk.so

	at org.eclipse.swt.internal.Library.loadLibrary(Library.java:267)
	at org.eclipse.swt.internal.Library.loadLibrary(Library.java:174)
	at org.eclipse.swt.internal.gnome.GNOME.<clinit>(GNOME.java:21)
	at org.eclipse.swt.program.Program.gnome_24_launch(Program.java:397)
	at org.eclipse.swt.program.Program.launch(Program.java:1086)
	at org.eclipse.swt.program.Program.launch(Program.java:1042)
	at org.gudy.azureus2.ui.swt.Utils.launch(Utils.java:948)
	at com.aelitis.azureus.ui.swt.Initializer.checkInstallID(Initializer.java:304)
	at com.aelitis.azureus.ui.swt.Initializer.runInSWTThread(Initializer.java:273)
	at org.gudy.azureus2.ui.swt.mainwindow.SWTThread.<init>(SWTThread.java:220)
	at org.gudy.azureus2.ui.swt.mainwindow.SWTThread.createInstance(SWTThread.java:63)
	at com.aelitis.azureus.ui.swt.Initializer.<init>(Initializer.java:163)
	... 12 more
Comment 15 Alexander Kurtakov 2011-04-08 17:03:41 EDT
Problem should  be fixed in http://koji.fedoraproject.org/koji/buildinfo?buildID=238280 . Webkit is the only one supposed to work
Comment 16 David Juran 2011-04-12 08:34:31 EDT
Still crashes (although in a different place) as soon as one starts azureus. JVM crash log attached
Comment 17 David Juran 2011-04-12 08:35:29 EDT
Created attachment 491473 [details]
JVM crash log
Comment 18 Sami Wagiaalla 2011-04-13 12:16:09 EDT
Hi David,

I am trying to reproduce the crash but things seem to be working for me.

I use f15 64, yum updated everything, yum installed azureus, and edited /usr/bin/azureus to add -Dorg.eclipse.swt.browser.UseWebKitGTK=true and things seem to be working for me. I can open "Vuze HD network" and click on a few links.

What are we doing differently. Can you think of anything to help me reproduce this ?
Comment 19 Sami Wagiaalla 2011-07-11 10:23:14 EDT
David,
Are you still experiencing this ?
Comment 20 David Juran 2011-07-12 07:20:02 EDT
Sorry, forgot to close this issue.

If I'm not mistaken, the crash in #17 only happens when there are _no_ fonts at all installed on the system. If it's worth reporting (a system running a GUI typically should have some fonts installed), I'll open a new BZ about this.

For the issue I had with azureus, after the latest updates to eclipse and exchanging xulrunner for webkit, everything now works fine.

Note You need to log in before you can comment on or make changes to this bug.