Bug 675010 - GeForce 6150SE in F15: totally corrupted display and doesn't go to fallback mode
GeForce 6150SE in F15: totally corrupted display and doesn't go to fallback mode
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: gnome-session (Show other bugs)
15
All Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F15GNOMEfail
  Show dependency treegraph
 
Reported: 2011-02-03 17:02 EST by Andre Robatino
Modified: 2011-05-22 14:11 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-05-22 14:11:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg output (182.76 KB, text/plain)
2011-02-17 15:12 EST, Andre Robatino
no flags Details
/var/log/messages (118.73 KB, text/plain)
2011-02-17 15:13 EST, Andre Robatino
no flags Details
/var/log/Xorg.0.log (47.81 KB, text/plain)
2011-02-17 15:14 EST, Andre Robatino
no flags Details

  None (edit)
Description Andre Robatino 2011-02-03 17:02:21 EST
Description of problem:

My machine has nVidia GeForce 6150SE nForce 430 video. The mesa-drivers-dri-experimental 3D support gives a totally corrupted display (both F13 and F14), so I have to use the proprietary nVidia driver to get working 3D support. Unfortunately, Rawhide doesn't appear to realize that the built-in 3D doesn't work, so am left with an unusable system (unless I can force it to fall back somehow in order to be able to install the proprietary driver first). Bug 581769 looks like my problem except that it refers to compiz, and my problem happens even without desktop effects enabled.

Smolt URL: http://www.smolts.org/client/show/pub_e6c78f7d-d38c-47df-8f06-47696b5c01b3

Version-Release number of selected component (if applicable):
whatever is on http://adamwill.fedorapeople.org/gnome3_test_day_20110203/gnome3_test_20110203.iso (the 64-bit live image)
Comment 1 Adam Williamson 2011-02-16 14:19:59 EST
I'm not sure if being able to detect the 3D support being present but buggy is a realistic ask of the fallback code; if not, we should re-assign this to nouveau and fix the corruption.
Comment 2 Andre Robatino 2011-02-17 15:11:33 EST
I booted from the 32-bit Gnome3 test day image (I don't have the 64-bit image at the moment, but the symptoms are the same either way) with the kernel options drm.debug=14 log_buf_len=16M, logged into VT2 as root (since graphical mode is unusable), and collected the following log files. I can't get glxinfo output since it can't open the display on VT2. There is no xorg.conf file, and only the one Xorg.*.log file.
Comment 3 Andre Robatino 2011-02-17 15:12:30 EST
Created attachment 479392 [details]
dmesg output
Comment 4 Andre Robatino 2011-02-17 15:13:24 EST
Created attachment 479393 [details]
/var/log/messages
Comment 5 Andre Robatino 2011-02-17 15:14:07 EST
Created attachment 479394 [details]
/var/log/Xorg.0.log
Comment 6 Andre Robatino 2011-02-23 01:53:28 EST
On the Nouveau test day, things look much better - Gnome shell actually works (with a few glitches). I posted my results on the wiki.
Comment 7 Andre Robatino 2011-03-12 07:42:03 EST
Using Fedora-15-Alpha-i686-Live-Desktop, one day it works fine, the next day I get the corrupted display, even after powering down and rebooting. So whatever the fix was, doesn't seem to be reliable. The 2011-03-10 Gnome3 test day image seems to work fine each time I tested it (only a few times, though).
Comment 8 Andre Robatino 2011-05-22 14:11:42 EDT
Gnome Shell seems to work okay in F15 Final (AKA RC3), both with nouveau and the proprietary nvidia driver from Rpmfusion. Closing.

Note You need to log in before you can comment on or make changes to this bug.