This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 675138 - liveusb-creator crashes while "installing bootloader"
liveusb-creator crashes while "installing bootloader"
Status: CLOSED DUPLICATE of bug 585468
Product: Fedora
Classification: Fedora
Component: parted (Show other bugs)
14
Unspecified Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Brian Lane
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-02-04 07:48 EST by Honza Horak
Modified: 2011-02-09 14:04 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-02-09 14:04:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Honza Horak 2011-02-04 07:48:09 EST
Description of problem:
When creating a live USB stick from iso image using liveusb-creator, program crashes when "installing bootloader". 

Version-Release number of selected component (if applicable):
liveusb-creator-3.9.3-1.fc14.noarch
parted-2.3-4.fc14.i686

How reproducible:
Allways.

Steps to Reproduce:
1. Try to create a live USB stick from any Fedora live iso image.
2. 
3.
  
Actual results:
Application crashes during step "installing bootloader". The USB drive is not bootable.

Expected results:
Application creates a bootable live USB stick.

Additional info:
Creating live USB stick is correct using other applications (e.g. livecd-iso-to-disk), the same USB stick and iso file.

Backtrace has 20 calls on stack:
  20: /lib/libparted.so.0(ped_assert+0x2b) [0x1218bbb]
  19: /lib/libparted.so.0(+0x42d7f) [0x124fd7f]
  18: /lib/libparted.so.0(+0x43a67) [0x1250a67]
  17: /lib/libparted.so.0(+0x46537) [0x1253537]
  16: /lib/libparted.so.0(+0x102f2) [0x121d2f2]
  15: /lib/libparted.so.0(ped_disk_add_partition+0x277) [0x1220857]
  14: /lib/libparted.so.0(+0x453d9) [0x12523d9]
  13: /lib/libparted.so.0(+0x45a30) [0x1252a30]
  12: /lib/libparted.so.0(ped_disk_new+0x7d) [0x1220d3d]
  11: /usr/lib/python2.7/site-packages/_pedmodule.so(_ped_Disk_init+0x83) [0x614cc3]
  10: /usr/lib/libpython2.7.so.1.0() [0x3700466]
  9: /usr/lib/libpython2.7.so.1.0(PyObject_Call+0x5d) [0x36a000d]
  8: /usr/lib/libpython2.7.so.1.0(PyEval_EvalFrameEx+0x3d64) [0x3744974]
  7: /usr/lib/libpython2.7.so.1.0(PyEval_EvalCodeEx+0x7f0) [0x3747130]
  6: /usr/lib/libpython2.7.so.1.0() [0x36cb4dd]
  5: /usr/lib/libpython2.7.so.1.0(PyObject_Call+0x5d) [0x36a000d]
  4: /usr/lib/libpython2.7.so.1.0(PyEval_EvalFrameEx+0x37bd) [0x37443cd]
  3: /usr/lib/libpython2.7.so.1.0(PyEval_EvalCodeEx+0x7f0) [0x3747130]
  2: /usr/lib/libpython2.7.so.1.0(PyEval_EvalFrameEx+0x4722) [0x3745332]
  1: /usr/lib/libpython2.7.so.1.0(PyEval_EvalCodeEx+0x7f0) [0x3747130]
Comment 1 Honza Horak 2011-02-09 10:11:27 EST
Component switched to parted component, because it is probably the right place where the problem exists.

Moreover, I found that partition table was broken on the USB stick, that I was working with. After I repaired (reformatted) it, the problem disappeared and live USB is created as usual, so I think the issue occurs only when working with USB, which has corrupted partition table.

Now I would like to reproduce this error, but I can't remember, what I'd done with the partition table to break it. Any idea how to break partition table on the USB stick?
Comment 2 Brian Lane 2011-02-09 11:55:29 EST
Was there any additional info, maybe a line that looked like this:

Assertion (head_size <= 63) at ../../../libparted/labels/dos.c:662 in
function
probe_partition_for_geom() failed.


Some USB sticks come pre-formatted with CHS values that are invalid, so parted throws an error.
Comment 3 Honza Horak 2011-02-09 12:11:29 EST
There were no other errors printed besides the Backtrace. 

However, the USB stick wasn't formatted by me before, AFAIK, so this could be the problem.
Comment 4 Brian Lane 2011-02-09 14:04:08 EST

*** This bug has been marked as a duplicate of bug 585468 ***

Note You need to log in before you can comment on or make changes to this bug.