Bug 675652 - Can't start alternative (non-default) DE with gdm-2.91.6-2.fc15
Summary: Can't start alternative (non-default) DE with gdm-2.91.6-2.fc15
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gdm
Version: rawhide
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Ray Strode [halfline]
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 677513 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-02-07 07:16 UTC by dominique
Modified: 2011-04-16 05:20 UTC (History)
11 users (show)

Fixed In Version: gdm-2.91.6-9.fc15
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-04-15 18:12:11 UTC


Attachments (Terms of Use)

Description dominique 2011-02-07 07:16:54 UTC
There is an update to gdm (gdm-2.91.6-2.fc15), and I use kde.
But this new gdm start with gnome and I don't see in gdm window the option where I can choose gnome or kde (in the previous gdm this option is in the bottom of window.)
Where is this option?

Comment 1 Valdis Kletnieks 2011-02-08 02:41:41 UTC
I'd like to thank whoever decided that being able to select alternate sessions like KDE or locally home-grown custom environments was no longer necessary.  It used to be that GDM allowed customization of things like login banners.  That evaporated with the move to gdm2 (and no customization tool has surfaced *yet* (bug #433649 was literally *years* ago).

Now the "There is only One True Way" zealots have gone a step further, and said that Thou Shalt Run Gnome.  If I missed the "Only Gnome window manager will be supported in Fedora 15 and later" announcement, please point me at it...

(Yes, I know it's possible that it's merely an oversight - but I still have a bad taste in my mouth after bug #433649)

Comment 2 Rex Dieter 2011-02-11 15:12:50 UTC
Alternate session support is coming, so I'm told.  patience grasshopper.

(that said, nominating as a blocker for tracking purposes, it is important)

Comment 3 Matthew Miller 2011-02-13 21:46:59 UTC
This isn't just "Can't start KDE", is it? This is "can't start any alternate desktop environment", right?

Comment 4 Rex Dieter 2011-02-13 21:59:24 UTC
Yes (as I understand it), adjusting summary to match reality.

Comment 5 Valdis Kletnieks 2011-02-13 22:01:18 UTC
Correct, it ate my custom e16 Enlightenment setup.

Comment 6 Adam Williamson 2011-02-14 16:42:08 UTC
proposing as NTH for Alpha so we can get a fix for this through the freeze; seems like a no-brainer to me.

Comment 7 Adam Williamson 2011-02-15 05:38:23 UTC
*** Bug 677513 has been marked as a duplicate of this bug. ***

Comment 8 Adam Williamson 2011-02-17 06:49:24 UTC
Ray, contrary to what we discussed on IRC, this does indeed break the Xfce spin.

Why? Simple: gdm requires gnome-session. So even on the Xfce spin, gnome-session is present. So gdm tries to start gnome-session, and that fails because the rest of GNOME isn't there.

Comment 9 Ray Strode [halfline] 2011-02-18 15:58:24 UTC
Sorry Adam, you're wrong :-)

gnome-session doesn't ship a desktop file /usr/share/xsessions (gnome-session-xsession does).

I talked with cwickert.  There are two things breaking xfce:

1) They were shipping an old version of gdm that was getting hit by bug 674978
2) after upgrading gdm to a recent version, they started hitting a crasher in gnome-session

I built the session chooser in yesterday though.

Comment 10 Adam Williamson 2011-02-18 16:54:04 UTC
fair enough. But still, I don't see how running Xfce should break due to a crasher in gnome-session. ;)

Comment 11 James Laska 2011-02-18 20:05:12 UTC
From the 2011-02-18 Alpha blocker review meeting (http://meetbot.fedoraproject.org/fedora-bugzappers/2011-02-18/f15-alpha-bug-review.2011-02-18-17.00.html)

AGREED: 675652 - RejectedNTH. adamw, cwickert and halfline will investigate gnome-session crash for futher action

Comment 12 Adam Williamson 2011-04-15 18:12:11 UTC
Discussed again at 2011-04-15 blocker review meeting, no change to previous evaluation. The reported bug is fixed, so let's close this. Xfce spin is currently using LXDM, if we decide to switch it back to GDM we'll test and file any bugs encountered separately.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 13 Kevin Kofler 2011-04-16 05:20:44 UTC
Actually, the Xfce spin has already been changed back to GDM by Christoph Wickert:
http://git.fedorahosted.org/git/?p=spin-kickstarts.git;a=commitdiff;h=e46a627ceb1426f45664ac3aa5f4cde66920993f


Note You need to log in before you can comment on or make changes to this bug.