Bug 67583 - startkde and /etc/skel/.kde problem
startkde and /etc/skel/.kde problem
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kdebase (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Ben Levenson
:
: 89153 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-06-27 15:35 EDT by aleahy
Modified: 2007-04-18 12:43 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-05 10:44:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description aleahy 2002-06-27 15:35:48 EDT
Description of Problem:   There's a bug in /usr/bin/startkde.  On line 44, it
performs:

[ -d "$HOME"/.kde/share/config ] || mkdir -p "$HOME"/.kde/share/config

which makes sure $HOME/.kde exists.  Then down on line 56 it performs the test:

if [ ! -d "$HOME"/.kde -a -d /etc/skel/.kde ]; then
  ( cd /etc/skel && tar cpf - .kde ) | ( cd "$HOME" && tar xpf - )
fi

Given what happened on line 44, there's no way to pass this test.  So the
contents of /etc/skel/.kde will never get copied to the user's directory.




Version-Release number of selected component (if applicable):


How Reproducible:




Steps to Reproduce:
1. 
2. 
3. 

Actual Results:


Expected Results:


Additional Information:
Comment 1 Marcin Garski 2004-11-04 17:04:53 EST
There isn't more:
if [ ! -d "$HOME"/.kde -a -d /etc/skel/.kde ]; then
  ( cd /etc/skel && tar cpf - .kde ) | ( cd "$HOME" && tar xpf - )
fi

in Fedora Core, so IMHO this bug should be closed, but I'll leave it
for Ngo Than, because maybe there is some "hidden" bug in this report ;)
Comment 2 Ngo Than 2004-11-05 10:44:05 EST
it's already fixed in the current FC release.
Comment 3 Marcin Garski 2004-11-05 10:46:38 EST
*** Bug 89153 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.