Bug 89153 - /etc/skel/.kde never copied from startkde
/etc/skel/.kde never copied from startkde
Status: CLOSED DUPLICATE of bug 67583
Product: Red Hat Linux
Classification: Retired
Component: kdebase (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Ben Levenson
Depends On:
  Show dependency treegraph
Reported: 2003-04-18 12:15 EDT by derrien
Modified: 2007-04-18 12:53 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-02-21 13:52:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description derrien 2003-04-18 12:15:59 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; SunOS sun4u; en-US; rv:1.0.1) Gecko/20020920

Description of problem:
At the beginning of startkde we have :

[ -d "$HOME"/.kde/share/config ] || mkdir -p "$HOME"/.kde/share/config

so the following test :

if [ ! -d "$HOME"/.kde -a -d /etc/skel/.kde ]; then
  ( cd /etc/skel && tar cpf - .kde ) | ( cd "$HOME" && tar xpf - )

is always false and /etc/skel/.kde is never copied in the user HOME...

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.execute startkde

Actual Results:  /etc/skel/.kde is not copied in $HOME/.kde

Expected Results:  /etc/skel/.kde is copied in $HOME/.kde

Additional info:
Comment 1 Dave Shield 2003-07-30 10:50:52 EDT
This bug has been present since RedHat 7.3 (see bug reports #52502 & #67583)

It could be fixed very simply by moving the "test || mkdir" line to come
after the "tar /etc/.skel" block.

It was reported to me that this had been done almost two years ago,
so it's somewhat disappointing that this bug is still present.
Comment 2 Marcin Garski 2004-11-05 10:46:25 EST
This bug is fixed in the current FC release.

*** This bug has been marked as a duplicate of 67583 ***
Comment 3 Red Hat Bugzilla 2006-02-21 13:52:44 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.