Bug 67586 - post_max_size config not settable in apache conf
post_max_size config not settable in apache conf
Status: CLOSED DUPLICATE of bug 73516
Product: Red Hat Linux
Classification: Retired
Component: php (Show other bugs)
7.2
i386 Linux
low Severity low
: ---
: ---
Assigned To: Joe Orton
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-06-27 15:51 EDT by kop
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-09-23 16:03:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description kop 2002-06-27 15:51:55 EDT
Description of Problem:

The php post_max_size configuation directive is not settable using
php_value post_max_size <blah>
in the Apache configuration file.

Also, it's not documented in the php manual as a config directive.

In the documenation in the php.ini file its not clear how post_max_size
and upload_max_filesize interrelate.  You'd assume that because files
are uploaded in a POST operation, that post_max_size places futher
limits on the maximum file upload size, but nothing is spelled out.



Version-Release number of selected component (if applicable):
php-4.0.6-15

How Reproducible:
Always

Steps to Reproduce:
Try setting post_max_size in httpd.conf and then run a php
script that does nothing but call phpconf() and see what's
set.

Actual Results:
post_max_size doesn't change.

Expected Results:
Should be set in apache conf.
Comment 1 Phil Copeland 2002-08-05 14:57:16 EDT
what the heck is phpconf()? I'm going to assume you meant phpinfo()

Ok lets see...

============================================================================
From: http://www.php.net/manual/en/configuration.php#ini.upload-max-filesize
upload_max_filesize  integer

The maximum size of an uploaded file. The value is in bytes. 


From: http://www.php.net/manual/en/configuration.php#ini.post-max-size
post_max_size  integer

    Sets max size of post data allowed. This setting also affects file upload.
To upload large files, this value must be larger than upload_max_filesize.

If memory limit is enabled by configure script, memory_limit also affects file
uploading. Generally speaking, memory_limit should be larger than post_max_size. 
============================================================================

Now then, my defaults are
post_max_size  8M  8M
upload_max_filesize  2M  2M

If I tweak the php.ini file so we have 6M and 4M,..

ah right you are,.. they don't change

Ok lets see if that 8/2Mb is a minimum
nope,.. they don't change

or rather should I say that they aren't reported as being changed.



AAAAAAAHHH!!!!
ok restart httpd between changes and macke sure that the web broswer has no
cacheing enabled
It does change. Just between the web server and the browser they hang onto the
old values

Not a bug just an effect of caching

Phil
=--=
Comment 2 kop 2002-08-05 17:55:57 EDT
You misunderstand the problem.  Yes, the config can be changed using php.ini. 
The bug is that it can't be changed in httpd.conf using the php_value method of
setting the variable.

(Yes, I ment phpinfo() sorry.)
Comment 3 Joe Orton 2002-09-24 06:13:02 EDT

*** This bug has been marked as a duplicate of 73516 ***

Note You need to log in before you can comment on or make changes to this bug.