Bug 73516 - php_value etc unusable from httpd.conf
Summary: php_value etc unusable from httpd.conf
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: php (Show other bugs)
(Show other bugs)
Version: 8.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Joe Orton
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
: 67586 (view as bug list)
Depends On:
Blocks: 73513
TreeView+ depends on / blocked
 
Reported: 2002-09-05 16:41 UTC by Gary Benson
Modified: 2007-04-18 16:46 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-25 16:46:15 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Gary Benson 2002-09-05 16:41:18 UTC
Description of Problem:
If /etc/php.ini has short_open_tag = off, this cannot be overridden from within
a .htaccess or from within httpd.conf.  See http://bugs.php.net/bug.php?id=17234
for more details.

Version-Release number of selected component (if applicable):
php-4.2.2-8.0.5

How Reproducible:
Always

Steps to Reproduce:
1. Make sure/etc/php.ini says:

  register_globals = Off
  short_open_tag = Off

2. Add this to httpd.conf:

  <Directory /foo/bar/baz>
    php_value register_globals 1
    php_value short_open_tag 1
  </Directory>

3. Create a phpinfo() in /foo/bar/baz/phpinfo.php and look at it.

Actual Results:

  Directive          Local value       Global value
  register_globals   On                Off
  short_open_tag     Off               Off

Expected Results:

  Directive          Local value       Global value
  register_globals   On                Off
  short_open_tag     On                Off

Comment 1 Phil Copeland 2002-09-05 19:24:02 UTC
*blink*
Well, it ain't going to get fixed for the next release as we just went past the
cutoff date for changes

I'll look into this

Phil
=--=

Comment 2 Joe Orton 2002-09-24 10:12:56 UTC
*** Bug 67586 has been marked as a duplicate of this bug. ***

Comment 3 Joe Orton 2002-12-04 09:28:29 UTC
With php-4.2.2-10, "php_admin_flag" and "php_admin_value" can be used in
httpd.conf to override php.ini settings.  php_flag and php_value still don't
work in httpd.conf.

Comment 4 Ngo Than 2002-12-08 22:20:06 UTC
/etc/httpd/conf.d/wordtrans.conf
---------
Alias /wordtrans /var/www/wordtrans

<Directory /var/www/wordtrans>
   php_admin_flag short_open_tag On
</Directory>
-----------

/etc/init.d/http start

httpd starten: Syntax error on line 4 of /etc/httpd/conf.d/wordtrans.conf:
Invalid command 'php_admin_flag', perhaps mis-spelled or defined by a module not
included in the server configuration

It does not work with php-4.2.2-11.



Comment 5 Denice 2003-01-29 16:11:40 UTC
I had also noted these problems with php directives when
I reported the safe_mode problem at:

https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=76974

This report was marked as a duplicate (the problem had already
been reported in the beta version of RH 8.0).  But you might
want to look at the report anyway for what I found with php 
directives in httpd.conf.

Comment 6 Joe Orton 2005-01-25 16:46:15 UTC
Thanks for the report.  This is a mass bug update; since this release
of Red Hat Linux is no longer supported, please either:

a) try and reproduce the bug with a supported version of Red Hat
Enterprise Linux or Fedora Core, and re-open this bug as appropriate
after changing the Product field, or,

b) if relevant, try and reproduce this bug using the current version
of the upstream package, and report the bug upstream.

c) report the bug to the Fedora Legacy project who may wish to
continue maintenance of this package.



Note You need to log in before you can comment on or make changes to this bug.