Bug 676415 - xorg does not respect keyboard configuration, tries to force us, ends up with no keyboard at all
xorg does not respect keyboard configuration, tries to force us, ends up with...
Status: CLOSED DUPLICATE of bug 676827
Product: Fedora
Classification: Fedora
Component: system-setup-keyboard (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Adel Gadllah
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-02-09 14:16 EST by Nicolas Mailhot
Modified: 2011-02-23 20:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-02-23 20:11:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
config file (312 bytes, text/plain)
2011-02-09 14:17 EST, Nicolas Mailhot
no flags Details
logs (55.37 KB, text/plain)
2011-02-09 14:17 EST, Nicolas Mailhot
no flags Details

  None (edit)
Description Nicolas Mailhot 2011-02-09 14:16:26 EST
Description of problem:

The attached keyboard config file (carried over from previous Fedora versions) in not honoured by fedora-devle xorg, that tries to force us layout, ending up with no layout at all (so no keyboard to log in or switch to the console)


Version-Release number of selected component (if applicable):
xorg-x11-font-utils-7.5-5.fc15.x86_64
xorg-x11-drv-vmmouse-12.6.99.901-1.20101209git07232feb6.fc15.x86_64
xorg-x11-drv-trident-1.3.4-3.fc15.x86_64
xorg-x11-drv-mach64-6.8.2-5.fc15.x86_64
xorg-x11-drv-s3virge-1.10.4-5.fc15.x86_64
xorg-x11-util-macros-1.11.0-2.fc15.noarch
xorg-x11-utils-7.5-1.fc15.x86_64
xorg-x11-drv-wacom-0.10.10-2.20101122.fc15.x86_64
xorg-x11-drv-v4l-0.2.0-10.fc15.x86_64
xorg-x11-drv-savage-2.3.2-1.fc15.x86_64
xorg-x11-drv-apm-1.2.3-4.fc15.x86_64
xorg-x11-server-Xorg-1.9.99.1-3.20101201.fc15.x86_64
xorg-x11-drv-hyperpen-1.3.99.1-1.20101202git0a03c1fd0.fc15.x86_64
xorg-x11-drv-rendition-4.2.4-3.fc15.x86_64
xorg-x11-drv-evdev-2.6.0-1.fc15.x86_64
xorg-x11-drv-synaptics-1.3.99-2.20101125.fc15.x86_64
xorg-x11-drv-sisusb-0.9.4-3.fc15.x86_64
xorg-x11-drv-nouveau-0.0.16-17.20110117git38e8809.fc15.x86_64
xorg-x11-xkb-utils-7.5-2.fc15.x86_64
xorg-x11-drv-sis-0.10.3-3.fc15.x86_64
xorg-x11-drv-ast-0.91.10-3.fc15.x86_64
xorg-x11-drv-dummy-0.3.4-3.fc15.x86_64
xorg-x11-drv-i128-1.3.4-5.fc15.x86_64
xorg-x11-drv-nv-2.1.18-4.fc15.x86_64
xorg-x11-drv-void-1.3.1-3.20101202gitcb8d19b8a.fc15.x86_64
xorg-x11-drv-ati-6.14.0-1.20110204gita27b5dbd9.fc15.x86_64
xorg-x11-drv-mouse-1.6.99-2.20101125.fc15.x86_64
xorg-x11-server-utils-7.5-3.fc15.x86_64
xorg-x11-drv-i740-1.3.2-5.fc15.x86_64
xorg-x11-drv-glint-1.2.4-5.fc15.x86_64
xorg-x11-drv-intel-2.14.0-1.fc15.x86_64
xorg-x11-server-common-1.9.99.1-3.20101201.fc15.x86_64
xorg-x11-drv-fbdev-0.4.1-6.fc15.x86_64
xorg-x11-drv-cirrus-1.3.2-5.fc15.x86_64
xorg-x11-xinit-1.0.9-19.fc15.x86_64
xorg-x11-drv-acecad-1.4.99-1.20101203gitf8e87eaf4.fc15.x86_64
xorg-x11-drv-mga-1.4.13-4.fc15.x86_64
libxkbfile-1.0.7-1.fc15.x86_64
xorg-x11-drv-vmware-11.0.3-2.fc15.x86_64
xorg-x11-xauth-1.0.2-8.fc15.x86_64
xorg-x11-drv-tdfx-1.4.3-5.fc15.x86_64
xorg-x11-drv-vesa-2.3.0-4.fc15.x86_64
xorg-x11-drv-voodoo-1.2.4-3.fc15.x86_64
xorg-x11-drv-r128-6.8.1-7.fc15.x86_64
xorg-x11-drv-openchrome-0.2.904-10.fc15.x86_64


Expected results:
A working keyboard or at least a way to switch to the console
Comment 1 Nicolas Mailhot 2011-02-09 14:17:12 EST
Created attachment 477888 [details]
config file
Comment 2 Nicolas Mailhot 2011-02-09 14:17:44 EST
Created attachment 477889 [details]
logs
Comment 3 Matěj Cepl 2011-02-14 10:27:33 EST
Could you run please

systemctl is-enabled system-setup-keyboard.service || echo "it's not enabled"

and if indicates it is not enabled, you can enable it manually via

ln -sf /lib/systemd/system/system-setup-keyboard.service \
 /etc/systemd/system/graphical.target.wants/system-setup-keyboard.service

Does it helpL?
Comment 4 Peter Hutterer 2011-02-23 20:11:47 EST

*** This bug has been marked as a duplicate of bug 676827 ***

Note You need to log in before you can comment on or make changes to this bug.