Bug 676488 - update showing Error message ??? instead of actual error message
Summary: update showing Error message ??? instead of actual error message
Keywords:
Status: CLOSED DUPLICATE of bug 668282
Alias: None
Product: Fedora
Classification: Fedora
Component: PackageKit
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Richard Hughes
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedBlocker
Depends On:
Blocks: F16Blocker, F16FinalBlocker
TreeView+ depends on / blocked
 
Reported: 2011-02-10 03:46 UTC by A S Alam
Modified: 2013-07-03 01:07 UTC (History)
13 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-10-20 07:34:04 UTC


Attachments (Terms of Use)
Red Line showing Error Message (broken) (122.05 KB, image/png)
2011-02-10 03:46 UTC, A S Alam
no flags Details
groupinfo shows fuzzy message (????) (57.45 KB, image/png)
2011-10-20 06:16 UTC, A S Alam
no flags Details

Description A S Alam 2011-02-10 03:46:53 UTC
Created attachment 477952 [details]
Red Line showing Error Message (broken)

Description of problem:
While updating packages (those having dependency error), it shows ??? symbol instead of actual text.


Error message with kpackagekit:
---
barry-0.17-0.6.20110126git.fc15.x86_64 ??? ?????? ?? libboost_serialization.so.1.44.0()(64bit) : ???? - ???? ??????????
---

Error message with yum (from konsole) (UTF-8 text):
--
ਗਲਤੀ: ਪਕਜ: barry-0.17-0.6.20110126git.fc15.x86_64 (@rawhide)
          ਚਾਹੀਦਾ ਹ: libboost_serialization.so.1.44.0()(64bit)
          ਹਟਾਇਆ ਜਾ ਰਿਹਾ ਹ: boost-serialization-1.44.0-7.fc15.x86_64 (@rawhide)
              libboost_serialization.so.1.44.0()(64bit)
          ਅਪਡਟ ਕੀਤਾ: boost-serialization-1.46.0-0.1.beta1.fc15.x86_64 (rawhide)
              ਨਹੀ ਲਭਾ
 ਤਸੀ ਸਮਸਿਆ ਨਾਲ ਨਿਪਟ ਲਈ --skip-broken ਦੀ ਵਰਤ ਕਰਕ ਕਮ ਚਲਾ ਸਕਦ ਹ
 ਤਹਾਨ ਚਲਾਉਣ ਦੀ ਕਸਿਸ ਕਰ ਸਕਦ ਹ: rpm -Va --nofiles --nodiges
--

Version-Release number of selected component (if applicable):
kpackagekit-0.6.3.3-1.fc15.x86_64
yum-3.2.29-3.fc15.noarch
PackageKit-0.6.12-2.fc15.x86_64

How reproducible:


Steps to Reproduce:
1. run update with Language pa_IN.UTF-8 interface
2. Error message with dependency broken shown as ??? symbol 
3.
  
Actual results:
Error message shown in application is not readable (not unicode?)

Expected results:
same data as yum is showing

Additional info:
Screenshot - Error message
Screenshot - Package information with kpackagekit (showing properly)

Comment 1 Adam Williamson 2011-07-26 02:03:40 UTC
To help us in assessing the blocker status of this bug, please cite the release criterion - https://fedoraproject.org/wiki/Fedora_Release_Criteria - you think it infringes. Thanks!



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 2 Akira TAGOH 2011-07-26 03:56:28 UTC
assuming that this meets to """
All applications listed under the Applications menu or category must withstand a basic functionality test and not crash after a few minutes of normal use. They must also have working Help and Help -> About menu items
""" in Final Release Criteria. Displaying the error messages should be sort of "basic functionality".

Comment 3 Adam Williamson 2011-09-30 19:09:16 UTC
Discussed at 2011-09-30 blocker review meeting. We felt this merits blocker
consideration, but we do not have criteria for translations at present. We
decided to accept it as NTH and table blocker status until next week; we will
aim to propose a criterion for translations this week.

Comment 4 Adam Williamson 2011-10-07 18:32:36 UTC
Discussed at 2011-10-07 blocker review meeting. We did not manage to create the i18n criteria yet so we're punting for another week. We'll definitely evaluate this next week.

Comment 5 Adam Williamson 2011-10-14 18:07:42 UTC
Discussed at 2011-10-14 blocker review meeting. Accepted as a blocker under newly-minted and updated i18n criterion "All critical path actions on release-blocking desktop environments should correctly display all sufficiently complete translations available for use".

Comment 6 A S Alam 2011-10-20 06:16:18 UTC
Created attachment 529196 [details]
groupinfo shows fuzzy message (????)

Package kpackagekit-0.6.3.3-2.fc15.i686 is obsoleted by apper-0.7.0-5.fc16.i686 (by yum)

apper also same problem (Screenshot)

Comment 7 Kevin Kofler 2011-10-20 07:34:04 UTC
This is a PackageKit bug, there's absolutely nothing we can do about this in Apper.

*** This bug has been marked as a duplicate of bug 668282 ***


Note You need to log in before you can comment on or make changes to this bug.