Bug 676525 - AttributeError: Values instance has no attribute 'repos' when using Yumex
Summary: AttributeError: Values instance has no attribute 'repos' when using Yumex
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: yumex
Version: rawhide
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Tim Lauridsen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 672047 678713 681063 691061 691196 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-02-10 06:05 UTC by John Watzke
Modified: 2011-04-07 18:52 UTC (History)
6 users (show)

Fixed In Version: yumex-3.0.2-1.fc14
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-04-05 21:34:31 UTC


Attachments (Terms of Use)

Description John Watzke 2011-02-10 06:05:26 UTC
Description of problem:
On startup, yumex tries to read repo information and then a traceback is thrown.

Version-Release number of selected component (if applicable):
yumex.noarch 0:3.0.1-1.fc15
pexpect.noarch 0:2.3-5.fc14

How reproducible:
Everytime

Steps to Reproduce:
1. Start yumex
  
Actual results:
Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/yumexbackend/yum_server.py", line 1314, in dispatcher
    self.parse_command(args[0], args[1:])
  File "/usr/lib/python2.7/site-packages/yumexbackend/yum_server.py", line 1242, in parse_command
    self.get_packages(args[0], args[1])
  File "/usr/lib/python2.7/site-packages/yumexbackend/yum_server.py", line 71, in newFunc
    return func(*args, **kwargs)
  File "/usr/lib/python2.7/site-packages/yumexbackend/yum_server.py", line 509, in get_packages
    ygh = self.doPackageLists(pkgnarrow=narrow, showdups=show_dupes)
  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 2254, in doPackageLists
    for (n,a,e,v,r) in self.up.getUpdatesList():
  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 878, in <lambda>
    up = property(fget=lambda self: self._getUpdates(),
  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 702, in _getUpdates
    self._up = rpmUtils.updates.Updates(self.rpmdb.simplePkgList(), self.pkgSack.simplePkgList())
  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 859, in <lambda>
    pkgSack = property(fget=lambda self: self._getSacks(),
  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 645, in _getSacks
    self.repos.populateSack(which=repos)
  File "/usr/lib/python2.7/site-packages/yum/repos.py", line 260, in populateSack
    self.doSetup()
  File "/usr/lib/python2.7/site-packages/yum/repos.py", line 72, in doSetup
    self.ayum.plugins.run('prereposetup')
  File "/usr/lib/python2.7/site-packages/yum/plugins.py", line 184, in run
    func(conduitcls(self, self.base, conf, **kwargs))
  File "/usr/lib/yum-plugins/auto-update-debuginfo.py", line 117, in prereposetup_hook
    enable_debuginfo_repos(yb, conduit)
  File "/usr/lib/yum-plugins/auto-update-debuginfo.py", line 42, in enable_debuginfo_repos
    for opt, repoexp in opts.repos:
AttributeError: Values instance has no attribute 'repos'

Comment 1 Tim Lauridsen 2011-02-11 10:55:49 UTC
This is an error in the auto-update-debuginfo plugin

disable it an yumex will work again

Comment 2 John Watzke 2011-02-11 15:20:50 UTC
Okay, no biggie.  I don't really use yumex all that much.  I was just running through common tools people do use to flush out any bugs.  This is at least a workaround in the meanwhile.

Comment 3 Tim Lauridsen 2011-02-19 07:47:45 UTC
*** Bug 678713 has been marked as a duplicate of this bug. ***

Comment 4 Tim Lauridsen 2011-02-19 07:50:36 UTC
*** Bug 672047 has been marked as a duplicate of this bug. ***

Comment 5 Tim Lauridsen 2011-02-19 07:54:13 UTC
I have fixed the cause in the auto-update-debuginfo in upstream yum-utils and I have made a temporary workaround in yumex, because it will be faster to a new yumex version out than a new yum-utils release.

Comment 6 Tim Lauridsen 2011-02-23 06:05:02 UTC
The fix is released in the pre-release repo

http://repos.fedorapeople.org/repos/timlau/yumex/

Comment 7 Raphos 2011-02-23 16:31:49 UTC
(In reply to comment #6)
> The fix is released in the pre-release repo
> 
> http://repos.fedorapeople.org/repos/timlau/yumex/

Thanks, Yumex works again.

Comment 8 Tim Lauridsen 2011-03-01 09:47:18 UTC
*** Bug 681063 has been marked as a duplicate of this bug. ***

Comment 9 Tim Lauridsen 2011-03-27 11:46:17 UTC
*** Bug 691061 has been marked as a duplicate of this bug. ***

Comment 10 Tim Lauridsen 2011-03-27 16:26:40 UTC
*** Bug 691196 has been marked as a duplicate of this bug. ***

Comment 11 Steven Usdansky 2011-03-29 17:32:10 UTC
Updated to latest Rawhide:
~$ rpm -qa | grep NetworkManager
NetworkManager-0.8.997-5.git20110328.fc16.x86_64
NetworkManager-glib-0.8.997-5.git20110328.fc16.x86_64
NetworkManager-gnome-0.8.997-5.git20110328.fc16.x86_64
~$ rpm -qa | grep yumex
yumex-3.0.2-0.1.git20110302.fc16.noarch
~$ yumex
/usr/lib/python2.7/site-packages/guihelpers/__init__.py:256: GtkWarning: gtk_scrolled_window_add(): cannot add non scrollable widget use gtk_scrolled_window_add_with_viewport() instead
  self.add_from_file(filename)
12:19:37 : INFO - Not connected to an network

Comment 12 Fedora Update System 2011-03-30 07:55:07 UTC
yumex-3.0.2-1.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/yumex-3.0.2-1.fc15

Comment 13 Fedora Update System 2011-03-30 07:55:33 UTC
yumex-3.0.2-1.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/yumex-3.0.2-1.fc14

Comment 14 Fedora Update System 2011-03-30 20:04:36 UTC
Package yumex-3.0.2-1.fc14:
* should fix your issue,
* was pushed to the Fedora 14 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing yumex-3.0.2-1.fc14'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/yumex-3.0.2-1.fc14
then log in and leave karma (feedback).

Comment 15 Fedora Update System 2011-04-05 21:34:12 UTC
yumex-3.0.2-1.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 16 Fedora Update System 2011-04-07 18:52:11 UTC
yumex-3.0.2-1.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.