Bug 676542 - 'No module named iutil' when attempting to load an installer interface component
'No module named iutil' when attempting to load an installer interface component
Status: CLOSED DUPLICATE of bug 676032
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
high Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F15Alpha/F15AlphaBlocker
  Show dependency treegraph
 
Reported: 2011-02-10 02:25 EST by He Rui
Modified: 2011-02-10 04:51 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-02-10 04:51:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
anaconda.log (9.25 KB, text/plain)
2011-02-10 02:25 EST, He Rui
no flags Details
error window (128.15 KB, image/png)
2011-02-10 02:26 EST, He Rui
no flags Details

  None (edit)
Description He Rui 2011-02-10 02:25:52 EST
Created attachment 477987 [details]
anaconda.log

Description of problem:
On a kvm with F15 installed, try to install F15 again. Delete old partitioning and customize the partioning. After partitioning, An error window pop up(See attached). Traceback in anaconda.log(attached) noted 'No module named iutil'

Version-Release number of selected component (if applicable):
anaconda 15.19
f15-Alpha-tc1

How reproducible:
often

Steps to Reproduce:
0. Install F15 or old fedora releases for a kvm.
1. Install F-15 again on this kvm. 
2. At partitioning step, choose custom layout to delete old partitions and create new partitions.
3. Error occurred.

Actual result:
01:59:08,406 ERR anaconda.stdout: Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/pyanaconda/gui.py", line 1309, in setScreen
    loaded = imp.load_module(moduleName, *found)
  File "/usr/lib/python2.7/site-packages/pyanaconda/iw/bootloader_main_gui.py", line 24, in <module>
    import iutil
ImportError: No module named iutil
Comment 1 He Rui 2011-02-10 02:26:28 EST
Created attachment 477988 [details]
error window
Comment 2 Jeff Raber 2011-02-10 02:50:38 EST

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 3 He Rui 2011-02-10 03:57:19 EST
Wow, it seems related to the partitioning. As long as I create partitions by 'create custom layout', no matter on kvm or bare metal, this error will occur.
Comment 4 Joachim Frieben 2011-02-10 04:01:24 EST
Simply reusing an existing partition layout through 'create custom layout' is sufficient to trigger this exception. Anaconda 15.18 did not exhibit this bug.
Comment 5 Joachim Backes 2011-02-10 04:36:09 EST
(In reply to comment #4)
> Simply reusing an existing partition layout through 'create custom layout' is
> sufficient to trigger this exception. Anaconda 15.18 did not exhibit this bug.

Having exactly the same issue:

Getting an error message: "An error occured when attempting to load an installer interface component
className = MainBootloaderWindow"
Comment 6 He Rui 2011-02-10 04:41:16 EST
Propose it as Alpha blocker since it blocks anyone who tries to partition using 'create custom layout', though it's not included in release criteria[1].

[1] https://fedoraproject.org/wiki/Fedora_15_Alpha_Release_Criteria
Comment 7 Ales Kozumplik 2011-02-10 04:51:03 EST

*** This bug has been marked as a duplicate of bug 676032 ***

Note You need to log in before you can comment on or make changes to this bug.