Bug 676837 - [abrt] evolution-2.32.1-1.fc14: qtSettingsInit: Process /usr/bin/evolution was killed by signal 11 (SIGSEGV)
Summary: [abrt] evolution-2.32.1-1.fc14: qtSettingsInit: Process /usr/bin/evolution wa...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: qtcurve-gtk2
Version: 14
Hardware: i686
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Thomas Janssen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:cecec66da9d64c232d91d60e52c...
: 667543 677150 677423 677455 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-02-11 13:43 UTC by Robert Welsh
Modified: 2011-03-03 02:46 UTC (History)
18 users (show)

Fixed In Version: qtcurve-gtk2-1.8.5-3.fc15
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-02-24 20:52:32 UTC


Attachments (Terms of Use)
File: backtrace (163.75 KB, text/plain)
2011-02-11 13:43 UTC, Robert Welsh
no flags Details

Description Robert Welsh 2011-02-11 13:43:25 UTC
abrt version: 1.1.14
architecture: i686
Attached file: backtrace
cmdline: /usr/bin/evolution
comment: This is the first time trying to bring up Evolution since Kernel update downloaded.  Not other tools running in the desktop.
component: evolution
crash_function: qtSettingsInit
executable: /usr/bin/evolution
kernel: 2.6.35.11-83.fc14.i686
package: evolution-2.32.1-1.fc14
rating: 4
reason: Process /usr/bin/evolution was killed by signal 11 (SIGSEGV)
release: Fedora release 14 (Laughlin)
time: 1297431142
uid: 500

How to reproduce
-----
1. First startup of Evolution with latest Linux Kernel update.
2. Fedora Kernel 2.6.35.11-83.fc14
3. Moved local .evolution directory to another name, removed and re-installed evolution with same crash.

Comment 1 Robert Welsh 2011-02-11 13:43:27 UTC
Created attachment 478241 [details]
File: backtrace

Comment 2 John Curcio 2011-02-12 01:31:19 UTC
Package: evolution-2.32.1-1.fc14
Architecture: i686
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1.upgraded kernel to 2.6.35.11-83.fc14.i686
2. delete home/.kde, reboot
3.start evolution

Comment 3 thanosk 2011-02-13 13:03:29 UTC
Package: evolution-2.32.1-1.fc14
Architecture: i686
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. Evolution crashed on system start-up
2.
3.

Comment 4 Blondetech9 2011-02-13 17:54:56 UTC
Package: evolution-2.32.1-1.fc14
Architecture: i686
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1.Booted system
2.clicked to start evolution
3.crashes every time now since a kernel update last week


Comment
-----
Never had a problem before, I did find if I uninstalled evolution and deleated the remaining evolution folder in .gconf > apps> If I then reinstalled evolution it would allow me to set up an account and even send and receive test emails, but once I close the program it will crash on loading from that point on.

Comment 5 John Curcio 2011-02-13 17:59:52 UTC
Sorry ... I forgot the most obvious and interesting aspect of this issue. This issue only shows up when I am running KDE. When I am running Gnome, evolution starts without any problem.

Sorry I didn't include that in my initial report.

John C

Comment 6 Blondetech9 2011-02-13 19:57:11 UTC
Same Here, Evolution works under gnome but crashes under KDE !

Started after updates last week were installed, I believe one was a kernel improvement.

Comment 7 Robert Welsh 2011-02-14 05:11:02 UTC
I did find once I removed qtcurve-kde4 and qtcurve-gtk2, Evolution started working properly again.  Once Evolution started working again, I have not had the issue re-appear.

Comment 8 Blondetech9 2011-02-14 05:51:14 UTC
I just removed qtcurve-gtk2 and evolution now works.

Did this change affect the appearance of your programs as well ???

Comment 9 Milan Crha 2011-02-14 07:11:39 UTC
*** Bug 677150 has been marked as a duplicate of this bug. ***

Comment 10 Milan Crha 2011-02-14 07:13:21 UTC
Thanks for a bug report and investigation. I'm moving this to qtcurve-gtk2.

Comment 11 Milan Crha 2011-02-15 08:10:20 UTC
*** Bug 677423 has been marked as a duplicate of this bug. ***

Comment 12 Milan Crha 2011-02-15 08:10:28 UTC
*** Bug 677455 has been marked as a duplicate of this bug. ***

Comment 13 Giovanni Bacaro 2011-02-15 10:38:17 UTC
Package: evolution-2.32.1-1.fc14
Architecture: i686
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. Simply, Evolution crashes when I try to open it (all the times) 
2.
3.

Comment 14 Thomas Janssen 2011-02-15 11:52:04 UTC
I can't reproduce that here with evolution-2.32.2-1.fc14.x86_64

Let me try and downgrade to 2.32.1-1

Comment 15 Thomas Janssen 2011-02-15 12:10:09 UTC
Nope. Doesn't crash with 2.32.1-1.
KDE = 4.6.00
Qt = 4.7.1-15
qtcurve-gtk = 1.8.5-1

Not sure if that's a x86 only regression. I need a i686 VM and try to reproduce it there.

I guess you all use updates repo only, no updates-testing. I will start with it in the VM.

Comment 16 Robert Welsh 2011-02-15 14:04:53 UTC
(In reply to comment #15)
> Nope. Doesn't crash with 2.32.1-1.
> KDE = 4.6.00
> Qt = 4.7.1-15
> qtcurve-gtk = 1.8.5-1
> 
> Not sure if that's a x86 only regression. I need a i686 VM and try to reproduce
> it there.
> 
> I guess you all use updates repo only, no updates-testing. I will start with it
> in the VM.

Hello Thomas,

Initial backtrace shows version of kernel and evolution I was running when this problem occurred.  This issue popped up when I updated from kernel 2.6.35.10-74.fc14 to kernel 2.6.35.11-83.fc14.  I removed qtcurve-gtk2 1.8.5-1.fc14 to correct the issue.  Have been able to reproduce the issue by re-installing qtcurve-gtk2.  I am running an AMD64 dual-core system.

Hope that helps.

Bob

Comment 17 bob brush 2011-02-15 16:12:50 UTC
Package: evolution-2.32.1-1.fc14
Architecture: i686
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1.Opened Mail
2.
3.

Comment 18 Rex Dieter 2011-02-15 19:27:13 UTC
Our best guess from some discussion on irc today, was there's some sort of symbol collision with qtcurve-gtk2's use of a (poorly-named) global named 'opts'

We're going to try to rename/namespace this in qtcurve-gtk2, and see if that helps the problem here.

Comment 19 Rex Dieter 2011-02-15 19:28:38 UTC
Fwiw, the line these backtraces reference is:

qtSettings.useAlpha=opts.bgndOpacity<100 || opts.dlgOpacity<100 || opts.menuBgndOpacity<100 || !(opts.square&SQUARE_POPUP_MENUS) || !(opts.square&SQUARE_TOOLTIPS);

where qtSettings and opts are both structs

Comment 20 Thomas Janssen 2011-02-15 20:32:03 UTC
Hey,

could you test this scratch build if it fixes the problem?

http://koji.fedoraproject.org/koji/taskinfo?taskID=2842708

Thanks

Comment 21 Robert Welsh 2011-02-15 22:39:07 UTC
(In reply to comment #20)
> Hey,
> 
> could you test this scratch build if it fixes the problem?
> 
> http://koji.fedoraproject.org/koji/taskinfo?taskID=2842708
> 
> Thanks

Hello Thomas,

Downloaded and installed scratch build.  Was able to bring up evolution with no problem.

Regards,

Bob Welsh

Comment 22 Blondetech9 2011-02-16 01:09:25 UTC
Downloaded and installed the scratch build, fixed the evolution problem and brought my application look back ( was looking like a version of win2K with the performance setting set for ugly ( no graphic enhancement ) 

Great fix guys and gals !

Comment 23 John Curcio 2011-02-16 01:18:35 UTC
So does anyone recommend we NOT install the rpm from http://koji.fedoraproject.org/koji/taskinfo?taskID=2842708 just yet?

Kudos for such fast work! This is really impressive.

John C

Comment 24 Thomas Janssen 2011-02-16 11:40:07 UTC
Thanks to Kevin_Kofler and rdieter in IRC, we have a lightning fast fix. Thanks guys!

The new update will be in updates-testing soonish (info will be posted in this bug). With enough Karma as well in updates (stable).
Thanks to all for testing the fixed version and reporting the issue!

Comment 25 Fedora Update System 2011-02-16 11:55:14 UTC
qtcurve-gtk2-1.8.5-3.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/qtcurve-gtk2-1.8.5-3.fc15

Comment 26 Fedora Update System 2011-02-16 11:55:22 UTC
qtcurve-gtk2-1.8.5-2.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/qtcurve-gtk2-1.8.5-2.fc14

Comment 27 Fedora Update System 2011-02-16 14:20:40 UTC
qtcurve-gtk2-1.8.5-3.fc15 has been pushed to the Fedora 15 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update qtcurve-gtk2'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/qtcurve-gtk2-1.8.5-3.fc15

Comment 28 Eugene Mah 2011-02-21 14:49:30 UTC
Package: evolution-2.32.1-1.fc14
Architecture: i686
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. Launch evolution from task bar or command line
2. Boom. Crash.
3.


Comment
-----
Started crashing following updates I did 18-Feb-2011. Updates included kernel-2.6.35.11-83.fc14.i686, glibc-2.13-1.i686 and a bunch of others.

Evolution was working fine before updates. Rebooted after updates were finished and Evolution started crashing.

Comment 29 Robert Welsh 2011-02-21 15:40:39 UTC
Hello,

Did you attempt to download and install the path build in comment 20 from Thomas Jansen?  He patched qtcurve-gtk and I loaded the patch and it corrected the issue.  IF this does not work, make sure you un-install qtcurve-gtk to see if this corrects the problem.

Also, note comment 23 about the RPM patch.  This might not be ready quite yet.

Let everyone know what you find.

Bob Welsh

(In reply to comment #28)
> Package: evolution-2.32.1-1.fc14
> Architecture: i686
> OS Release: Fedora release 14 (Laughlin)
> 
> 
> How to reproduce
> -----
> 1. Launch evolution from task bar or command line
> 2. Boom. Crash.
> 3.
> 
> 
> Comment
> -----
> Started crashing following updates I did 18-Feb-2011. Updates included
> kernel-2.6.35.11-83.fc14.i686, glibc-2.13-1.i686 and a bunch of others.
> 
> Evolution was working fine before updates. Rebooted after updates were finished
> and Evolution started crashing.

Comment 30 Eugene Mah 2011-02-21 15:59:04 UTC
after filing the report, i came here to see what people were saying and installed qtcurve-gtk2-1.8.5-2.fc14.i686 from updates-testing. Got Evolution started up and it seems to be running without any problems so far.

eugene

(In reply to comment #29)
> Hello,
> 
> Did you attempt to download and install the path build in comment 20 from
> Thomas Jansen?  He patched qtcurve-gtk and I loaded the patch and it corrected
> the issue.  IF this does not work, make sure you un-install qtcurve-gtk to see
> if this corrects the problem.
> 
> Also, note comment 23 about the RPM patch.  This might not be ready quite yet.
> 
> Let everyone know what you find.
> 
> Bob Welsh
>

Comment 31 Rafhael Almeida 2011-02-21 17:52:29 UTC
Package: evolution-2.32.1-1.fc14
Architecture: i686
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. no ararnca
2.
3.

Comment 32 Ambrogio 2011-02-23 11:34:48 UTC
Package: evolution-2.32.1-1.fc14
Architecture: i686
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. segmentation fault starting evo

2. removing all about .gconf/apps/evolution and .local/share/evolution
3. start evo - configuring a simple account
4. close evo
5. start evo
Result is segfault

Comment 33 Ambrogio 2011-02-23 13:07:16 UTC
Solved usign the updates-testing repo.
But I think that the actual package should be removed or updated.

Bye
 Ambrogio

Comment 34 Thomas Janssen 2011-02-23 18:34:57 UTC
All it needs is another positive karma in bodhi and the new build will hit the updates repository.

https://admin.fedoraproject.org/updates/qtcurve-gtk2-1.8.5-2.fc14

Comment 35 Fedora Update System 2011-02-24 20:52:26 UTC
qtcurve-gtk2-1.8.5-2.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 36 Milan Crha 2011-02-28 08:04:13 UTC
*** Bug 667543 has been marked as a duplicate of this bug. ***

Comment 37 Sergio Monteiro Basto 2011-03-02 21:10:22 UTC
BTW: 
since qtcurve give so much problems .

https://bugzilla.redhat.com/show_bug.cgi?id=648055

still unresolved just workaround by disable rounded corners , but I try enable again and the results now are  worse

Comment 38 Thomas Janssen 2011-03-02 23:07:19 UTC
(In reply to comment #37)
> BTW: 
> since qtcurve give so much problems .
> 
> https://bugzilla.redhat.com/show_bug.cgi?id=648055
> 
> still unresolved just workaround by disable rounded corners , but I try enable
> again and the results now are  worse

Please stop posting nonsense to closed bugreports. No software is bugfree and for qtcurve there are 3 bugreports at all. Not so much problems at all.

If you think there is a *new* problem with qtcurve, then file a *new* bug.

Comment 39 Fedora Update System 2011-03-03 02:45:57 UTC
qtcurve-gtk2-1.8.5-3.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.