Bug 677218 - missing iso 9660 image during installation via NFS
Summary: missing iso 9660 image during installation via NFS
Keywords:
Status: CLOSED DUPLICATE of bug 676821
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: rawhide
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: F15Beta, F15BetaBlocker
TreeView+ depends on / blocked
 
Reported: 2011-02-14 05:20 UTC by Hongqing Yang
Modified: 2011-02-22 06:37 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-02-22 06:37:35 UTC
Type: ---


Attachments (Terms of Use)
anaconda log (12.92 KB, application/octet-stream)
2011-02-14 05:20 UTC, Hongqing Yang
no flags Details
anaconda log (13.40 KB, application/octet-stream)
2011-02-16 07:30 UTC, Hongqing Yang
no flags Details
anaconda.log (11.84 KB, text/plain)
2011-02-21 07:16 UTC, He Rui
no flags Details
program.log (47.24 KB, text/plain)
2011-02-21 07:16 UTC, He Rui
no flags Details

Description Hongqing Yang 2011-02-14 05:20:56 UTC
Created attachment 478548 [details]
anaconda log

Description of problem:

install f15-alpha-tc1 via NFS, dialog pop up says: 
Missing ISO 9660 image
The installer has tried to mount the installation image, but cannot find it on the hard drive.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Boot the installer using Fedora-15-Alpha-x86_64-DVD.iso
2. Direct anaconda to use NFS as the installation type by adding the boot command: askmethod
3.
  
Actual results:


Expected results:


Additional info:

Test case :https://fedoraproject.org/wiki/QA/TestCases/InstallSourceNfs

Comment 1 Chris Lumens 2011-02-14 13:37:10 UTC
Note the version number that anaconda's finding here:

04:50:49,332 INFO loader: file location: nfs:nfs.englab.nay.redhat.com:/pub/fedora/linux/releases/14/Fedora/x86_64/os/.treeinfo

What happens if you use a directory that contains F15 stuff instead of F14 stuff?

Comment 2 Hongqing Yang 2011-02-16 07:30:44 UTC
Created attachment 479030 [details]
anaconda log

reproduced on both i386 and x86_64 with F15 stuff during f15 alpha tc2 test.

Comment 3 Hongqing Yang 2011-02-16 08:37:48 UTC

*** This bug has been marked as a duplicate of bug 676821 ***

Comment 4 He Rui 2011-02-21 07:15:16 UTC
Reproduced on F15-alpha-tc2. I mounted a DVD.iso to nfs server with -o loop, then boot tc2 netinst.iso with kernel para: repo=nfs:nfs server:/path.
And then error occurred when retrieving the repo.

According to anaconda.log, the nfs repo was first mounted on /mnt/isodir, and then anaconda tried to mount /mnt/iso/None on /mnt/source as iso9660.

The nfs repo isn't nfs iso repos, so shouldn't the nfs repo be directly mounted on /mnt/source? I think this is not a dupe of bug#676821.

logs attached. Mark it as F15-Beta blocker as it blocks nfs repo install.

Comment 5 He Rui 2011-02-21 07:16:05 UTC
Created attachment 479832 [details]
anaconda.log

Comment 6 He Rui 2011-02-21 07:16:33 UTC
Created attachment 479833 [details]
program.log

Comment 7 Chris Lumens 2011-02-21 13:30:32 UTC
Can you test with the updates image referenced in bug 676821 just to rule that out?

Comment 8 He Rui 2011-02-22 02:58:01 UTC
(In reply to comment #7)
> Can you test with the updates image referenced in bug 676821 just to rule that
> out?

Oh sorry, I forgot to mention that this issue still happens if applying that updates image on anaconda 15.20(TC#2), but not happen on anaconda 15.19(TC#1)

Comment 9 He Rui 2011-02-22 06:37:35 UTC
Just retest it on anaconda 15.20.1(Alpha RC1), this issue doesn't occur with the updates image in bug#676821, so close it again as a dup.

*** This bug has been marked as a duplicate of bug 676821 ***


Note You need to log in before you can comment on or make changes to this bug.