Bug 677218 - missing iso 9660 image during installation via NFS
missing iso 9660 image during installation via NFS
Status: CLOSED DUPLICATE of bug 676821
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks: F15Beta/F15BetaBlocker
  Show dependency treegraph
 
Reported: 2011-02-14 00:20 EST by Hongqing Yang
Modified: 2011-02-22 01:37 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-02-22 01:37:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
anaconda log (12.92 KB, application/octet-stream)
2011-02-14 00:20 EST, Hongqing Yang
no flags Details
anaconda log (13.40 KB, application/octet-stream)
2011-02-16 02:30 EST, Hongqing Yang
no flags Details
anaconda.log (11.84 KB, text/plain)
2011-02-21 02:16 EST, He Rui
no flags Details
program.log (47.24 KB, text/plain)
2011-02-21 02:16 EST, He Rui
no flags Details

  None (edit)
Description Hongqing Yang 2011-02-14 00:20:56 EST
Created attachment 478548 [details]
anaconda log

Description of problem:

install f15-alpha-tc1 via NFS, dialog pop up says: 
Missing ISO 9660 image
The installer has tried to mount the installation image, but cannot find it on the hard drive.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Boot the installer using Fedora-15-Alpha-x86_64-DVD.iso
2. Direct anaconda to use NFS as the installation type by adding the boot command: askmethod
3.
  
Actual results:


Expected results:


Additional info:

Test case :https://fedoraproject.org/wiki/QA/TestCases/InstallSourceNfs
Comment 1 Chris Lumens 2011-02-14 08:37:10 EST
Note the version number that anaconda's finding here:

04:50:49,332 INFO loader: file location: nfs:nfs.englab.nay.redhat.com:/pub/fedora/linux/releases/14/Fedora/x86_64/os/.treeinfo

What happens if you use a directory that contains F15 stuff instead of F14 stuff?
Comment 2 Hongqing Yang 2011-02-16 02:30:44 EST
Created attachment 479030 [details]
anaconda log

reproduced on both i386 and x86_64 with F15 stuff during f15 alpha tc2 test.
Comment 3 Hongqing Yang 2011-02-16 03:37:48 EST

*** This bug has been marked as a duplicate of bug 676821 ***
Comment 4 He Rui 2011-02-21 02:15:16 EST
Reproduced on F15-alpha-tc2. I mounted a DVD.iso to nfs server with -o loop, then boot tc2 netinst.iso with kernel para: repo=nfs:nfs server:/path.
And then error occurred when retrieving the repo.

According to anaconda.log, the nfs repo was first mounted on /mnt/isodir, and then anaconda tried to mount /mnt/iso/None on /mnt/source as iso9660.

The nfs repo isn't nfs iso repos, so shouldn't the nfs repo be directly mounted on /mnt/source? I think this is not a dupe of bug#676821.

logs attached. Mark it as F15-Beta blocker as it blocks nfs repo install.
Comment 5 He Rui 2011-02-21 02:16:05 EST
Created attachment 479832 [details]
anaconda.log
Comment 6 He Rui 2011-02-21 02:16:33 EST
Created attachment 479833 [details]
program.log
Comment 7 Chris Lumens 2011-02-21 08:30:32 EST
Can you test with the updates image referenced in bug 676821 just to rule that out?
Comment 8 He Rui 2011-02-21 21:58:01 EST
(In reply to comment #7)
> Can you test with the updates image referenced in bug 676821 just to rule that
> out?

Oh sorry, I forgot to mention that this issue still happens if applying that updates image on anaconda 15.20(TC#2), but not happen on anaconda 15.19(TC#1)
Comment 9 He Rui 2011-02-22 01:37:35 EST
Just retest it on anaconda 15.20.1(Alpha RC1), this issue doesn't occur with the updates image in bug#676821, so close it again as a dup.

*** This bug has been marked as a duplicate of bug 676821 ***

Note You need to log in before you can comment on or make changes to this bug.